Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 24/02/2017, à 12:10

fwehrli

{Résolu}: ubuntu + pylote

Bonjour,
    J'ai installé pylote avec les paquets python nécessaires.
    Cependant quand le lance pylote, j'ai le message suivant qui s'affiche:
    python pylote.pyw
    TESTS:  False PYQT:  PYQT4
    ('SCREEN_MODE:', u'FULL_SPACE')
    QCursor: Cannot create bitmap cursor; invalid bitmap(s)
    QCursor: Cannot create bitmap cursor; invalid bitmap(s)
    QCursor: Cannot create bitmap cursor; invalid bitmap(s)
    QCursor: Cannot create bitmap cursor; invalid bitmap(s)
    Cannot open file './images/instruments/regle.svg', because: No such file or directory
    Cannot open file './images/instruments/equerre.svg', because: No such file or directory
    Cannot open file './images/instruments/equerre_non_graduee.svg', because: No such file or directory
    Cannot open file './images/instruments/rapporteur.svg', because: No such file or directory
    Cannot open file './images/instruments/compas.svg', because: No such file or directory
    Traceback (most recent call last):
      File "pylote.pyw", line 125, in <module>
        mainWindow = main.MainWindow(locale, appTranslator)
      File "/home/jeanmonnet/pylote/main.py", line 111, in __init__
        self.readSettings()
      File "/home/jeanmonnet/pylote/main.py", line 372, in readSettings
        'ScreenShotDelay', defaultSettings.value('ScreenShotDelay')))
    TypeError: int() argument must be a string or a number, not 'NoneType'

    Pour information je suis sur Xubuntu 14.10
    Merci d'avance

Dernière modification par fwehrli (Le 15/03/2017, à 19:12)

Hors ligne

#2 Le 24/02/2017, à 12:12

smokeh

Re : {Résolu}: ubuntu + pylote

ta version ubuntu est périmé : https://doc.ubuntu-fr.org/utopic
et le paquet python3-qt4 est installé>? http://pascal.peter.free.fr/pylote.html

Dernière modification par smokeh (Le 24/02/2017, à 12:18)

Hors ligne

#3 Le 24/02/2017, à 12:19

fwehrli

Re : {Résolu}: ubuntu + pylote

Non je me suis trompé c'est une 14.04.1.
J'ai régulièrement des mises à jour à effectuer

Hors ligne

#4 Le 24/02/2017, à 12:22

smokeh

Re : {Résolu}: ubuntu + pylote

donne le retour de cette commande :

cat /etc/*-release

Hors ligne

#5 Le 24/02/2017, à 12:24

fwehrli

Re : {Résolu}: ubuntu + pylote

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.5 LTS"
NAME="Ubuntu"
VERSION="14.04.5 LTS, Trusty Tahr"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 14.04.5 LTS"
VERSION_ID="14.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

Hors ligne

#6 Le 24/02/2017, à 12:30

smokeh

Re : {Résolu}: ubuntu + pylote

donc tu es sous la version 14.04.5
donne des retours correct comme nous le faisons quand on écris une commande
quel est ta version de python?

apt-cache show python | grep "Version"

Dernière modification par smokeh (Le 24/02/2017, à 12:32)

Hors ligne

#7 Le 24/02/2017, à 12:35

fwehrli

Re : {Résolu}: ubuntu + pylote

Désolé
Version: 2.7.5-5ubuntu3

Hors ligne

#8 Le 24/02/2017, à 12:38

smokeh

Re : {Résolu}: ubuntu + pylote

fwehrli a écrit :

Désolé
Version: 2.7.5-5ubuntu3

c'est encore pas un bon retour...
donne le retour de :

sudo apt install python-qt4

Hors ligne

#9 Le 24/02/2017, à 12:41

fwehrli

Re : {Résolu}: ubuntu + pylote

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
python-qt4 est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  evolution-common geoclue-ubuntu-geoip gir1.2-gnomebluetooth-1.0 hunspell-fr
  hyphen-en-us indicator-keyboard kde-l10n-engb kde-l10n-fr
  libasn1-8-heimdal:i386 libavformat-extra-54 libbaloocore4 libbaloofiles4
  libbalooxapian4 libcapi20-3:i386 libecal-1.2-16 libepub0 liberror-perl
  libexif12:i386 libgd3:i386 libgdata-common libgdata13 libgee2 libgif4:i386
  libgphoto2-6:i386 libgphoto2-port10:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386
  libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0
  libhcrypto4-heimdal:i386 libhdb9-heimdal libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libieee1284-3:i386
  libkdc2-heimdal libkidletime4 libkrb5-26-heimdal:i386 liblcms2-2:i386
  libldap-2.4-2:i386 libltdl7:i386 libmail-spf-perl libmotif-common
  libmpg123-0:i386 libmrm4 libneon27 libnetaddr-ip-perl liboauth0
  libopenal1:i386 libosmesa6:i386 libp11-kit-gnome-keyring:i386
  libpoppler-qt4-4 libpst4 libqmobipocket1 libqtkeychain0
  libreoffice-help-en-gb libreoffice-help-en-us libreoffice-help-fr
  libreoffice-l10n-en-gb libreoffice-l10n-en-za libreoffice-l10n-fr
  libroken18-heimdal:i386 libsane:i386 libsasl2-2:i386 libsasl2-modules:i386
  libsasl2-modules-db:i386 libsys-hostname-long-perl libtimezonemap1 libuil4
  libunity-control-center1 libusb-1.0-0:i386 libwind0-heimdal:i386
  libxcomposite1:i386 libxcursor1:i386 libxinerama1:i386 libxm4 libxpm4:i386
  libxrandr2:i386 libytnef0 libzip2 linux-headers-3.13.0-32
  linux-headers-3.13.0-32-generic linux-headers-3.13.0-55
  linux-headers-3.13.0-55-generic linux-image-3.13.0-32-generic
  linux-image-3.13.0-55-generic linux-image-extra-3.13.0-32-generic
  linux-image-extra-3.13.0-55-generic mythes-en-au obexd-client
  ocl-icd-libopencl1:i386 openoffice.org-hyphenation p11-kit-modules:i386 re2c
  spamc unity-settings-daemon wine-gecko2.21:i386
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Hors ligne

#10 Le 24/02/2017, à 12:45

smokeh

Re : {Résolu}: ubuntu + pylote

fwehrli a écrit :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
python-qt4 est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  evolution-common geoclue-ubuntu-geoip gir1.2-gnomebluetooth-1.0 hunspell-fr
  hyphen-en-us indicator-keyboard kde-l10n-engb kde-l10n-fr
  libasn1-8-heimdal:i386 libavformat-extra-54 libbaloocore4 libbaloofiles4
  libbalooxapian4 libcapi20-3:i386 libecal-1.2-16 libepub0 liberror-perl
  libexif12:i386 libgd3:i386 libgdata-common libgdata13 libgee2 libgif4:i386
  libgphoto2-6:i386 libgphoto2-port10:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386
  libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0
  libhcrypto4-heimdal:i386 libhdb9-heimdal libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libieee1284-3:i386
  libkdc2-heimdal libkidletime4 libkrb5-26-heimdal:i386 liblcms2-2:i386
  libldap-2.4-2:i386 libltdl7:i386 libmail-spf-perl libmotif-common
  libmpg123-0:i386 libmrm4 libneon27 libnetaddr-ip-perl liboauth0
  libopenal1:i386 libosmesa6:i386 libp11-kit-gnome-keyring:i386
  libpoppler-qt4-4 libpst4 libqmobipocket1 libqtkeychain0
  libreoffice-help-en-gb libreoffice-help-en-us libreoffice-help-fr
  libreoffice-l10n-en-gb libreoffice-l10n-en-za libreoffice-l10n-fr
  libroken18-heimdal:i386 libsane:i386 libsasl2-2:i386 libsasl2-modules:i386
  libsasl2-modules-db:i386 libsys-hostname-long-perl libtimezonemap1 libuil4
  libunity-control-center1 libusb-1.0-0:i386 libwind0-heimdal:i386
  libxcomposite1:i386 libxcursor1:i386 libxinerama1:i386 libxm4 libxpm4:i386
  libxrandr2:i386 libytnef0 libzip2 linux-headers-3.13.0-32
  linux-headers-3.13.0-32-generic linux-headers-3.13.0-55
  linux-headers-3.13.0-55-generic linux-image-3.13.0-32-generic
  linux-image-3.13.0-55-generic linux-image-extra-3.13.0-32-generic
  linux-image-extra-3.13.0-55-generic mythes-en-au obexd-client
  ocl-icd-libopencl1:i386 openoffice.org-hyphenation p11-kit-modules:i386 re2c
  spamc unity-settings-daemon wine-gecko2.21:i386
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

fait des efforts d'abord

Hors ligne

#11 Le 24/02/2017, à 12:47

fwehrli

Re : {Résolu}: ubuntu + pylote

Quels efforts?
Je saisis ce que vous me demandez, je ne peux pas faire mieux.
Bonne journée

Hors ligne

#12 Le 24/02/2017, à 12:49

smokeh

Re : {Résolu}: ubuntu + pylote

fwehrli a écrit :

Quels efforts?
Je saisis ce que vous me demandez, je ne peux pas faire mieux.
Bonne journée

https://forum.ubuntu-fr.org/viewtopic.php?id=1614731

Hors ligne

#13 Le 25/02/2017, à 15:35

fwehrli

Re : {Résolu}: ubuntu + pylote

jeanmonnet@wehrlitbi:~$ sudo apt install python-qt4
Unknown parameter encountered: "password level"
Ignoring unknown parameter "password level"
Unknown parameter encountered: "update encrypted"
Ignoring unknown parameter "update encrypted"
sudo: impossible de déterminer le nom de l'hôte wehrlitbi
[sudo] password for jeanmonnet: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
python-qt4 est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  evolution-common geoclue-ubuntu-geoip gir1.2-gnomebluetooth-1.0 hunspell-fr
  hyphen-en-us indicator-keyboard kde-l10n-engb kde-l10n-fr
  libasn1-8-heimdal:i386 libavformat-extra-54 libbaloocore4 libbaloofiles4
  libbalooxapian4 libcapi20-3:i386 libecal-1.2-16 libepub0 liberror-perl
  libexif12:i386 libgd3:i386 libgdata-common libgdata13 libgee2 libgif4:i386
  libgphoto2-6:i386 libgphoto2-port10:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386
  libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0
  libhcrypto4-heimdal:i386 libhdb9-heimdal libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libieee1284-3:i386
  libkdc2-heimdal libkidletime4 libkrb5-26-heimdal:i386 liblcms2-2:i386
  libldap-2.4-2:i386 libltdl7:i386 libmail-spf-perl libmotif-common
  libmpg123-0:i386 libmrm4 libneon27 libnetaddr-ip-perl liboauth0
  libopenal1:i386 libosmesa6:i386 libp11-kit-gnome-keyring:i386
  libpoppler-qt4-4 libpst4 libqmobipocket1 libqtkeychain0
  libreoffice-help-en-gb libreoffice-help-en-us libreoffice-help-fr
  libreoffice-l10n-en-gb libreoffice-l10n-en-za libreoffice-l10n-fr
  libroken18-heimdal:i386 libsane:i386 libsasl2-2:i386 libsasl2-modules:i386
  libsasl2-modules-db:i386 libsys-hostname-long-perl libtimezonemap1 libuil4
  libunity-control-center1 libusb-1.0-0:i386 libwind0-heimdal:i386
  libxcomposite1:i386 libxcursor1:i386 libxinerama1:i386 libxm4 libxpm4:i386
  libxrandr2:i386 libytnef0 libzip2 linux-headers-3.13.0-32
  linux-headers-3.13.0-32-generic linux-headers-3.13.0-55
  linux-headers-3.13.0-55-generic linux-image-3.13.0-32-generic
  linux-image-3.13.0-55-generic linux-image-extra-3.13.0-32-generic
  linux-image-extra-3.13.0-55-generic mythes-en-au obexd-client
  ocl-icd-libopencl1:i386 openoffice.org-hyphenation p11-kit-modules:i386 re2c
  spamc unity-settings-daemon wine-gecko2.21:i386
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
jeanmonnet@wehrlitbi:~$ 

Hors ligne

#14 Le 25/02/2017, à 19:39

smokeh

Re : {Résolu}: ubuntu + pylote

alors visiblement vous avez toutes les dépendances qui sont ok. et malheureusement pylote n'est pas beaucoup documenté sur internet... vous avez fais quelque chose sur votre machine récemment pour que ça ne fonctionne plus?
visiblement certains dossier n'existent plus :

Cannot open file './images/instruments/regle.svg', because: No such file or directory
    Cannot open file './images/instruments/equerre.svg', because: No such file or directory
    Cannot open file './images/instruments/equerre_non_graduee.svg', because: No such file or directory
    Cannot open file './images/instruments/rapporteur.svg', because: No such file or directory
    Cannot open file './images/instruments/compas.svg', because: No such file or directory

ce sont des dossiers caché ( on le remarque par le point avant images.
regardez si vous avez toujours ces dossier de présent pourrait être une piste...
essayer d'ouvrir avec la commande :

sudo python pylote.pyw

vous pouvez aussi faire un

apt-get autoremove 

pour nettoyer l'inutile

tentez aussi de retélécharger a nouveau pylote et de lancer le nouveau on sait jamais...

Dernière modification par smokeh (Le 25/02/2017, à 19:46)

Hors ligne

#15 Le 07/03/2017, à 19:59

fwehrli

Re : {Résolu}: ubuntu + pylote

Bonjour,
J'ai téléchargé et réinstallé pylote. Cela fonctionne (lancement). Par contre je n'arrive pas à écrire sur mes documents et à avoir les deux fenêtres en même temps.

Hors ligne