Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 11/09/2007, à 15:35

HugKub

Clavier : au login, premier caractère tapé au clavier pas affiché

Bonjour,

Après mise à jour de ma Kubuntu 6.10 vers Kubuntu 7.04, le premier caractère tapé au clavier (après démarrage ou redémarrage du système) est ignoré. Lorsque j'arrive sur la fenêtre de connexion de KDM, je suis obligé de taper 2 fois le premier caractère de mon nom d'utilisateur (le premier caractère tapé ne s'affiche pas).

Si je démarre en mode console (mode Single depuis Grub ou mode console depuis KDM), le premier caractère tapé ne s'affiche pas mais en plus cela éteint la led "Verr num" du clavier ! A noter que cette led ne s'éteint qu'un dixième de seconde lorsque je démarre KDE par KDM.

Auriez-vous une piste ?

Cordialement.

Dernière modification par HugKub (Le 13/09/2007, à 10:20)


Medion Akoya E1210 - 1 Go RAM - Noyau 2.6.27-11-generic
Ubuntu 8.10 (Intrepid) + Ubuntu Netbook Remix (UNR)

Hors ligne

#2 Le 11/09/2007, à 17:56

Titoubuntu

Re : Clavier : au login, premier caractère tapé au clavier pas affiché

Peut-être que ton clavier est redevenu QWERTY ??
Tape ton login, comme si c'était un clavier anglosaxon.

#3 Le 11/09/2007, à 18:09

pouchat

Re : Clavier : au login, premier caractère tapé au clavier pas affiché

je suis heureux de voir ce post, car sur toutes les versions d'Ubuntu (sauf Feisty) j'ai eu ce même problème (sur un laptop acer et un fixe générique) alors que sur d'autres machines ça marchait très bien.

De mémoire je crois que la première fois ou j'ai eu ce problème c'était sur une Sarge avant que je vire de bord pour ubuntu.

C'est hyper chiant et pis on s'habitue. On tape instinctivement 2 fois le premier caractère du login comme tu dis. Mais le bug est bizarre ! J'ai pourtant essayé sur KDM, GDM et aussi le truc moche de démarrage à la "windows".

Dernière modification par pouchat (Le 12/09/2007, à 08:47)

Hors ligne

#4 Le 11/09/2007, à 18:22

HugKub

Re : Clavier : au login, premier caractère tapé au clavier pas affiché

@Titoubuntu : Non, cela ne semble pas être un problème d'encodage du clavier car le caractère n'est tout simplement pas affiché (nom de login). De plus la première lettre étant "h", si mes souvenirs sont corrects cette touche est au même endroit.

@Pouchat : C'est rassurant mad Ce n'est donc pas spécifique à ma configuration. Ce qui est bizarre c'est que c'est la première fois que j'ai le phénomène sur cette machine. Avec la version 6.10 de Kubuntu c'était bon...

Cela ne doit pas être KDM ou GDM car en démarrant directement en console (mode single sans lancer KDM) on a le même phénomène. Comme tu dis c'est ch... d'être emm... par un truc aussi basique que le login en mode console !

J'aimerais bien trouver une solution.

Merci pour vos infos.

Cordialement.


Medion Akoya E1210 - 1 Go RAM - Noyau 2.6.27-11-generic
Ubuntu 8.10 (Intrepid) + Ubuntu Netbook Remix (UNR)

Hors ligne

#5 Le 12/09/2007, à 01:49

Titoubuntu

Re : Clavier : au login, premier caractère tapé au clavier pas affiché

Bizarre ton histoire. hmm

Aucun problème de ce genre chez moi, que ce soit Feisty 7.04 ou autre.
Je choisis Gnome ou Kde à la fenêtre d'identification de session.
Aucun problème avec KDE & Gnome

#6 Le 13/09/2007, à 10:00

HugKub

Re : Clavier : au login, premier caractère tapé au clavier pas affiché

Titoubuntu a écrit :

Bizarre ton histoire. hmm

Aucun problème avec KDE & Gnome

Effectivement, car c'est un problème en amont, au niveau du pilote/module/noyau ? du clavier. C'est vraiment la première touche tapée au clavier qui est ignorée. Par exemple, sous KDM, la touche "tabulation" est ignorée (la première frappe seulement).

Quelqu'un aurait une idée de l'endroit où chercher ? Merci.

Cordialement.


Medion Akoya E1210 - 1 Go RAM - Noyau 2.6.27-11-generic
Ubuntu 8.10 (Intrepid) + Ubuntu Netbook Remix (UNR)

Hors ligne

#7 Le 13/09/2007, à 12:08

HugKub

Re : Clavier : au login, premier caractère tapé au clavier pas affiché

Bonjour,

J'ai poursuivi mes investigations.

Remarques :

- Dans mon Bios, le verrouillage "Verr Num" est activé.
- Le paquet "numlockx" est installé.
- Dans le menu K - Réglages du système - Administration de l'ordinateur / Clavier & Souris, l'option "Verrouillage numérique au démarrage de KDE" est activée.

Tests :

1°) J'ai désactivé  le verrouillage "Verr Num" dans le Bios : la 1ère touche appuyée sur le clavier allume la led 'Verr Num".

J'ai pensé que le problème pouvait venir du paquet "numlockx".

2°) J'ai désinstallé (purgé) le paquet "numlockx" : la 1ère touche n'est pas affichée.

3°) J'ai désactivé l'option "Verrouillage numérique au démarrage de KDE" (sans trop y croire car le problème est en amont du lancement de KDE) : la 1ère touche n'est pas affichée.

4°) J'ai réactivé le verrouillage "Verr Num" dans le Bios : la 1ère touche éteint la led "Verr Num" !

De tout ceci, j'en conclus que l'appui sur la première touche commande le "Verr Num" au lieu d'envoyer un caractère. Un peu comme lorsque l'on est en "économiseur d'écran". Par contre, je suis toujours coincé, je ne sais pas où chercher maintenant (et trouver !). Si quelqu'un a une idée...

Cordialement.


Medion Akoya E1210 - 1 Go RAM - Noyau 2.6.27-11-generic
Ubuntu 8.10 (Intrepid) + Ubuntu Netbook Remix (UNR)

Hors ligne

#8 Le 01/03/2017, à 15:56

Gaara

Re : Clavier : au login, premier caractère tapé au clavier pas affiché

Salut !

Alors j'ai trouvé une solution pour ce petit désagrément. Car ça fait bien 6 mois que je suis dans ce cas, alors je me suis énervé (un peu), et j'ai trouvé une solution.
La solution qui a fonctionné pour moi a été de supprimer le paquet laptop-mode-tools.

Alors comme mon pc est fixe, pas de soucis de gestion d'énergie, mais il se peut que ce paquet soit utile, dans ce cas voici les liens qui m'ont mis sur la piste:
http://r3dux.org/2014/10/how-to-fix-usb … -in-linux/
http://www.wulftone.com/2014/03/26/make … -keyboard/

Merci à cqfd93 d'avoir débloqué le fil initialement archivé, car je déterre force 10 ^^


Kubuntu 16.10 x64
Une tablette de prototypage pour RPi et Odroid
Téléchargement de vidéo Pluzz et C+
                                        <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne