Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 17/12/2010, à 00:13

rochjub

VIRTUALBOX : pas de reseau wifi en "bridged"

Salut !

Je viens d'installer Virtualbox pour la premiere fois pour m'entrainer un peu a la securite reseau. J'ai donc besoin de voir ma machine virtuelle sur le reseau depuis mon ubuntu. En NAT j'ai une conection mais forcement la machine virtuelle n'apparait pas sur le reseau, et quand je passe en mode "pont" plus de conection. J'ai lu quelques articles et appliqué la methode du plus complet (http://www.scottro.net/vboxbridge.html#Wireless) mais rien n'y fait. L'ip est bien configurée sur la machine virtuelle mais c'est tout. N'etant pas un expert, je penses passer a coter de quelque chose...

J'utilise un ordi portable toshiba satelite t130, sur lequel tourne la derniere version d'Ubuntu, j'ai installé XP HOME SP2 sur VirtualBox, j'ai installé le driver "Realtek wireless LAN" mais rien n'y fait.

J'utilise la carte wlan0, mon ip locale 192.168.4.120 et voila le code que j'ai donc tapé

root@SAFAR-ENGINE:~# sysctl net.ipv4.ip_forward=1
net.ipv4.ip_forward = 1
root@SAFAR-ENGINE:~# VBoxTunctl -b -u 0
tap0
root@SAFAR-ENGINE:~# ip link set tap0 up
root@SAFAR-ENGINE:~# ip addr add 192.168.4.130/24 dev tap0
root@SAFAR-ENGINE:~# parprouted wlan0 tap0
root@SAFAR-ENGINE:~# route add -net 192.168.4.0 netmask 255.255.255.0 tap0
root@SAFAR-ENGINE:~# iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE

noter que mon nom d'utilisateur sur winXP est "test" et que quand je tape VBoxTunctl -b -u test, ca me retourne "'test' is neither a username nor a numeric uid." j'utilise donc 0 comme uid logique, l'erreur vient peut etre de la.

Tant que j'y suis, quand je scan avec angry ip sous windows(je suis en dual boot) j'ai l'ip 192.168.4.51 qui est connécté, je peux me ballader dans les fichiers partager sans problemes, mais sous linux, toujours avec angry ip, la meme adresse apparait down alors que l'ordi et toujours allumé et que le ping se passe bien

Dernière modification par rochjub (Le 17/12/2010, à 01:07)

Hors ligne

#2 Le 17/12/2010, à 20:27

src

Re : VIRTUALBOX : pas de reseau wifi en "bridged"

Pourquoi tu te prends la tête avec les lignes de commande? Virtualbox a des menus graphiques.


Actuellement sur Manjaro Xfce (amd64)

Hors ligne

#3 Le 17/12/2010, à 22:58

rochjub

Re : VIRTUALBOX : pas de reseau wifi en "bridged"

Si tu parles de la configuration de la machine virtuelle dans l'onglet reseau j'ai tout essayé, sinon une expliquation un peu plus poussé ne serait pas de refus.

merci

Hors ligne

#4 Le 18/12/2010, à 03:08

src

Re : VIRTUALBOX : pas de reseau wifi en "bridged"

J'ai trouvé 3 moyens pour rendre une machine accessible depuis le réseau.

1) Mode d'accès Réseau: Accès par pont.

C'est le plus facile, cela équivaut à créer un switch virtuel sur ton ordinateur, où serait relié le système virtuel. Il devrait recevoir une adresse IP si tu as un serveur DHCP sur le réseau (ce qui est le cas avec les *box).

2) Réseau privé hôte, solution 1 (routage)

Au démarrage de la machine virtuelle, sur ton hôte tu vas voir une nouvelle interface vboxnet0 avec 192.168.56.1/24. Sur ta machine virtualisée tu dois mettre les paramètres IP suivants:

IP: 192.168.56.X (X valant 10 par exemple)
Masque: 255.255.255.0
Passerelle: 192.168.56.1
DNS: 8.8.8.8 (ceux de Google)

Ensuite sur ton hôte tu actives l'ip forwarding (tu sais le faire puisque tu as mis la commande dans ton premier post). Sur ton routeur domestique, tu créé une nouvelle route avec les paramètres suivants:

Réseau: 192.168.56.0, masque 255.255.255.0 - passerelle: IP de ton hôte

Pour contacter ta machine virtuelle il faudra utiliser son IP (dans notre cas, 192.168.56.10). Le routeur de chez toi renverra les paquets vers ton hôte (puisqu'on l'a défini comme passerelle) et ce dernier les enverra sur la machine virtuelle.

3) Réseau privé hôte, solution 2 (NAT)

Solution si ton routeur domestique ne permet pas de créer des routes. C'est de la traduction d'adresse et de la redirection de port, donc une config à faire pour chaque port (alors que les deux premières solutions sont plus souples). Ça fonctionne un peu comme une box, si tu fais un serveur Web sur ta machine virtuelle, tu vas devoir rediriger le port 80...

La procédure est la même que pour le point 2 sauf que tu ne créé pas de route sur ton routeur. Et en plus d'activer l'IP forwarding sur ton hôte, tu dois activer le NAT (dernière commande que tu donnes). Ensuite tu dois créer des règles iptables pour rediriger les ports. La commande est:

iptables -A PREROUTING -t nat -i wlan0 -p tcp --dport 8080 -j DNAT --to 172.16.48.128:80

Ici dans cet exemple je redirige le port 8080 de mon PC vers le port 80 de ma machine virtuelle qui a pour IP 172.16.48.128. Tu as juste à t'en inspirer pour créer tes règles.

Ca a l'air galère comme ça mais le parefeu de Fedora fait tout ça graphiquement (je ne sais pas si il y a un équivalent sur ubuntu).



Si tu es du genre à te faciliter la vie je te conseille de tenter le pont réseau décrit en 1) car c'est le plus simple... Le 2) et 3) c'est du bidouillage avec la magie d'ipv4.


Actuellement sur Manjaro Xfce (amd64)

Hors ligne

#5 Le 18/12/2010, à 20:06

rochjub

Re : VIRTUALBOX : pas de reseau wifi en "bridged"

quand je choisis acces par pont, ce qui est mon probleme depuis le debut, je n'ai pas de reseau !!!

Hors ligne

#6 Le 20/02/2017, à 23:43

oliv77

Re : VIRTUALBOX : pas de reseau wifi en "bridged"

Dans mon cas Wifi sur LiveBox orange, Windows10, Virtualbox, j'ai rencontré le même problème. Pour que le mode bridge fonctionne correctement (c.a.d que je vois ma machine virtuelle sous Ubuntu 16.04 depuis le reste de mon réseau WIFI), je dois préciser à VirtualBox que la carte réseau de mon PC doit décoder l'ensemble des paquets IP et non pas uniquement ceux destinés à ma machine sous Windows10. Je fais cela grâce au menu VirtualBox -> Settings -> Network -> Onglet Adapter 1 (celui qui est en Bridge Adapter) -> Advanced -> Promiscuous Mode : Allow All.

Dernière modification par oliv77 (Le 21/02/2017, à 00:17)

Hors ligne

#7 Le 20/02/2017, à 23:55

jplemoine

Re : VIRTUALBOX : pas de reseau wifi en "bridged"

rochjub a écrit :

quand je choisis acces par pont, ce qui est mon probleme depuis le debut, je n'ai pas de reseau !!!

Il faut faire un pont vers la carte physique effectivement utilisée.
Exemple : sur mon PC, j'ai :
- enp0s3 : carte réseau filaire
- wlp7s0 : carte wi-fi.
Si je ne choisis pas la bonne carte, ça ne fonctionne pas.


Cordialement, Jean-Philippe.
Système principal Sous Ubuntu de 2009 à février 2015 - Xubuntu depuis.
Xubuntu 16.04 (poste principal portable) - Ubuntu 16.04 server (desktop converti en serveur DHCP, DNS, dépôt local et supervision (shinken))
Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)

Hors ligne