Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 23/01/2017, à 11:38

tcsevens

[Résolu]Aucune interface graphique/ No directory logging in with home

Salut tout le monde,

Alors voilà je me retrouve avec un problème que je n'arrive pas à résoudre, si vous avez une idée c'est cool smile:
Donc je suis sous Ubuntu Gnome 16.10, il était au poil, personnaliser comme je le souhaitais (hormis un problème récurrent avec "plymouthd" à chaque démarrage), mais la en le démarrant ce matin je me retrouve avec ça, en théorie il démarre directement sur ma session avec la connexion automatique:

1485167175.jpg
A noter que des fois le chargement s'arrête avant cette dernière ligne de commande

OK   Started User Manager for UID 1000

Un petit Alt+F3 plus tard, je tente un startx après m'être loggué en ligne de commande et il me revoie ça:
1485167265.jpg


Avec sudo il m'a ouvert la session root en mode graphique, tout fonctionnait jusqu'au moment ou j'ai essayé de changer de session pour la mienne et j'ai bloqué sur le gdm qui charge sans s'arrêter, sans rien lancer.


Voilà si vous avez une idée je suis preneur parce que de mon côté je sèche ... j'ai cherché sur le web et j'ai rien trouvé de bien concluant malheureusement.

Merci d'avance les gens wink


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix le permettent).

Edit: Désolé pour les images en effet c'est mieux de cette taille.

Edit : Merci !

Dernière modification par tcsevens (Le 23/01/2017, à 15:15)

Hors ligne

#2 Le 23/01/2017, à 12:32

sinbad83

Re : [Résolu]Aucune interface graphique/ No directory logging in with home

Bonjour,
il est rare que sudo startx résolve le problème et c'est même plutôt déconseillé.
Passe en console TTY (Ctl+Alt+F1), réponds à la demande de mot de passe (La console n'est pas en graphique).
Arrête l'affichage graphique

sudo service gdm stop

Tu le reconfigures ensuite

sudo dpkg --configure -a

Repasse enfin en mode graphique (Ctl+Alt+F7)

Dernière modification par sinbad83 (Le 23/01/2017, à 12:33)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop  8x AMD FX-8120, RAM 8GB, Ubuntu 17.04 et Ten,   HP Pavillon G6 U16.04 et Ten, Samsung N150 U16.04 et Seven, Serveurs Ubuntu 16.04 et 14.04

Hors ligne

#3 Le 23/01/2017, à 12:43

inbox

Re : [Résolu]Aucune interface graphique/ No directory logging in with home

Salut,

Le message "no directory, logging in with home=/" indique que l'utilisateur Thomas n'a pas de répertoire "/home". Je ne sais pourquoi cela est arrivé, mis c'est un fait.

Soit tu as créé cet utilisateur manuellement et tu as oublié de lui créer ce dossier, soit il a été supprimé malencontreusement. Vérifie tout de même que ce n'est pas un problème de droit sur ce dossier. Une autre possibilité est que tu aurais modifié la table de montage de partitions en oubliant celle contenant /home.

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

En ligne

#4 Le 23/01/2017, à 13:18

tcsevens

Re : [Résolu]Aucune interface graphique/ No directory logging in with home

Tout d'abord, je vous remercie de m'aider, vraiment !

sinbad83 a écrit :

Bonjour,
il est rare que sudo startx résolve le problème et c'est même plutôt déconseillé.
Passe en console TTY (Ctl+Alt+F1), réponds à la demande de mot de passe (La console n'est pas en graphique).
Arrête l'affichage graphique

sudo service gdm stop

Tu le reconfigures ensuite

sudo dpkg --configure -a

Repasse enfin en mode graphique (Ctl+Alt+F7)

Malheureusement ça n'a rien donné, hormis que maintenant au démarrage j'ai un message:

dev/sda5 clean blocks ...

Apparemment le message n'a pas d'importance, le problème vient d'ailleurs.

sinbad83 a écrit :

Salut,

Le message "no directory, logging in with home=/" indique que l'utilisateur Thomas n'a pas de répertoire "/home". Je ne sais pourquoi cela est arrivé, mis c'est un fait.

Soit tu as créé cet utilisateur manuellement et tu as oublié de lui créer ce dossier, soit il a été supprimé malencontreusement. Vérifie tout de même que ce n'est pas un problème de droit sur ce dossier. Une autre possibilité est que tu aurais modifié la table de montage de partitions en oubliant celle contenant /home.

A+

Mais en effet, tu as raisons, ça vient tout juste de me revenir je suis bête ... C'est probablement de ma faute suite à une mauvaise manip', j'ai modifié dans l'utilitaire gnome-disk-utility il y a une bonne semaine le montage automatique (ne redémarrant mon pc qu'une fois par semaine ...), étant donné que ma /home est sur un autre disque ça doit venir de cela

1485170101.png

J'ai passé le paramétrage en Option de montage automatique, une idée pour le désactiver du coup pour réparer ma bourde ?

Dernière modification par tcsevens (Le 23/01/2017, à 13:21)

Hors ligne

#5 Le 23/01/2017, à 14:27

tcsevens

Re : [Résolu]Aucune interface graphique/ No directory logging in with home

Alors euh, en montant manuellement mon dossier utilisateur "thomas "dans /home et en lançant un

sudo startx

je suis bien arrivé sur ma session en effet, après j'ai changé le point de montage et les paramètres dans gnome-disk-utility et en effet ça remarche comme au début.

Je vous remercie, une fois sur la bonne voie c'est tout de suite plus simple ! Merci encore une fois !

Dernière modification par tcsevens (Le 23/01/2017, à 15:10)

Hors ligne