Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/01/2020, à 10:53

tropa

[Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

bonjour,
Ubuntu 18,04 LTS 64bits = Brother HL-2130 (le pilote que j'avais installé à l'origine était celui de la HL-2030 semble-t-il me souvenir).

Mon problème a commencé quand j’ai voulu imprimer 2 A5 sur une feuille A4 :
Je ne pouvais pas accéder à changer les paramètres "dimensions du support (A4, A5...)" ni "orientation "portrait, paysage"
j'ai entrepris de suivre le scriptde demonipuch pour réinstaller mon imprimante :

J’ai 2 paquets cassés :
hl2130lpr:i386  2.1.0.1 Brother HL-2130 CUPS LPR driver
cupswrapperhl2130:i386  2.0.4.2  Brother HL2130 CUPS wrapper driver

Mon imprimante ne fonctionne plus. S'il vous plaît, Quelqu'un peut-il me guider soit pour remettre des paquets pas cassés, soit pour annuler le script de demonipuch, soit m'indiquer une imprimante qui fonctionne avec ubuntu sans avoir besoin de lire des centaines de page de forum pour pouvoir utiliser toutes ses fonctions?
Merci beaucoup par avance.

Modération : ton message a été scindé dans un fil autonome.

Dernière modification par tropa (Le 02/03/2020, à 11:19)

Hors ligne

#2 Le 26/01/2020, à 18:34

xubu1957

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Bonjour,

Tu peux donner plus d'infos, en utilisant le > Tuto : les Informations utiles à donner lorsque j'ai un problème. ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 26/01/2020, à 22:21

eric63

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

merci ayral pour avoir scinder le message

@tropa si tu as installé ton imprimante avec le script de demonipuch il doit y avoir dans ton dossier perso un dossier demonopuchxxxxxx et dedans un fichier brprinterinstall.log peut tu nous copier coller tout le texte de ce fichier


Kubuntu 19.10 - 64 bits + backports = plasma 5.18.3 KDE 5.67.0 Qt 5.12.4 et noyau 5.3.0-40 4* intel i5-4570 3.2 Ghz 12 Go nvidia gtx 750
pour installer une brother
N'oubliez pas les balises codes
J’utilise le clavier french AFNOR c‘est fort

Hors ligne

#4 Le 31/01/2020, à 19:12

tropa

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

OOps désolé pour le fil "pas autonome"!

Bonjour et merci pour vos réponses.
Je commence par le texte du fichier brprinterinstall.log demandé par eric63 :

# Ubuntu Codename : bionic
# Architecture : x86_64
# Modèle de l'imprimante : HL-2130
# Connexion : USB
# Fichier d'informations : http://www.brother.com/pub/bsc/linux/infs/HL2130
- Paquet trouvé : hl2130lpr-2.1.0-1.i386.deb
- Paquet trouvé : cupswrapperHL2130-2.0.4-2.i386.deb

# Téléchargement du paquet : hl2130lpr-2.1.0-1.i386.deb
--2020-01-19 15:10:03--  http://www.brother.com/pub/bsc/linux/pa … 1.i386.deb
Résolution de www.brother.com (www.brother.com)… 104.85.54.217
Connexion à www.brother.com (www.brother.com)|104.85.54.217|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 35812 (35K) [application/x-troff-man]
Enregistre : «/home/benoit/demonipuch-brprinter-installer-6e4cce8c163b/./packages/hl2130lpr-2.1.0-1.i386.deb»

     0K .......... .......... .......... ....                 100% 89,2K=0,4s

2020-01-19 15:10:04 (89,2 KB/s) - «/home/benoit/demonipuch-brprinter-installer-6e4cce8c163b/./packages/hl2130lpr-2.1.0-1.i386.deb» enregistré [35812/35812]


# Téléchargement du paquet : cupswrapperHL2130-2.0.4-2.i386.deb
--2020-01-19 15:10:04--  http://www.brother.com/pub/bsc/linux/pa … 2.i386.deb
Résolution de www.brother.com (www.brother.com)… 104.85.54.217
Connexion à www.brother.com (www.brother.com)|104.85.54.217|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 13272 (13K)
Enregistre : «/home/benoit/demonipuch-brprinter-installer-6e4cce8c163b/./packages/cupswrapperHL2130-2.0.4-2.i386.deb»

     0K .......... ..                                         100% 92,1K=0,1s

2020-01-19 15:10:05 (92,1 KB/s) - «/home/benoit/demonipuch-brprinter-installer-6e4cce8c163b/./packages/cupswrapperHL2130-2.0.4-2.i386.deb» enregistré [13272/13272]

# Vérification des pré-requis
- Paquet 'multiarch-support' installé
- Paquet 'lib32stdc++6' non installé
# Installation de 'lib32stdc++6'
Sélection du paquet libc6-i386 précédemment désélectionné.
(Lecture de la base de données...
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 218963 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libc6-i386_2.27-3ubuntu1_amd64.deb ...
Dépaquetage de libc6-i386 (2.27-3ubuntu1) ...
Sélection du paquet lib32gcc1 précédemment désélectionné.
Préparation du dépaquetage de .../lib32gcc1_1%3a8.3.0-6ubuntu1~18.04.1_amd64.deb ...
Dépaquetage de lib32gcc1 (1:8.3.0-6ubuntu1~18.04.1) ...
Sélection du paquet lib32stdc++6 précédemment désélectionné.
Préparation du dépaquetage de .../lib32stdc++6_8.3.0-6ubuntu1~18.04.1_amd64.deb ...
Dépaquetage de lib32stdc++6 (8.3.0-6ubuntu1~18.04.1) ...
Paramétrage de libc6-i386 (2.27-3ubuntu1) ...
Paramétrage de lib32gcc1 (1:8.3.0-6ubuntu1~18.04.1) ...
Paramétrage de lib32stdc++6 (8.3.0-6ubuntu1~18.04.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
- Paquet 'lib32stdc++6' installé
- Paquet 'cups' installé

# Installation du paquet : hl2130lpr-2.1.0-1.i386.deb
Sélection du paquet hl2130lpr:i386 précédemment désélectionné.
(Lecture de la base de données... 219277 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../hl2130lpr-2.1.0-1.i386.deb ...
Dépaquetage de hl2130lpr:i386 (2.1.0-1) ...
dpkg: hl2130lpr:i386 : problèmes de dépendances, mais configuration comme demandé :
hl2130lpr:i386 dépend de libc6 (>= 2.3.4-1).

Paramétrage de hl2130lpr:i386 (2.1.0-1) ...

# Installation du paquet : cupswrapperHL2130-2.0.4-2.i386.deb
Sélection du paquet cupswrapperhl2130:i386 précédemment désélectionné.
(Lecture de la base de données... 219294 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../cupswrapperHL2130-2.0.4-2.i386.deb ...
Dépaquetage de cupswrapperhl2130:i386 (2.0.4-2) ...
dpkg: cupswrapperhl2130:i386 : problèmes de dépendances, mais configuration comme demandé :
cupswrapperhl2130:i386 dépend de libc6 (>= 2.3.4-1).

Paramétrage de cupswrapperhl2130:i386 (2.0.4-2) ...
Restarting cups (via systemctl): cups.service.

# Recherche d'un fichier PPD
- Fichier PPD : /usr/share/cups/model/HL2130.ppd

# Ajout de l'imprimante HL-2130
- Backup du fichier /etc/cups/printers.conf.O
- Arret du service CUPS
lpinfo: Connexion ré-initialisée par le correspondant
- Restauration du fichier printers.conf
lpinfo: Mauvais descripteur de fichier
- Redémarrage du service CUPS
lpadmin: Unable to connect to server: Mauvais descripteur de fichier
- Restauration du fichier printers.conf.O

Maintenant la réponse à Xubu1957 avec les balises-code :

benoit@rafal:~$  cat /etc/lsb-release && uname -i && groups && lsusb
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.3 LTS"
x86_64
benoit adm cdrom sudo dip plugdev lpadmin sambashare vboxusers
Bus 002 Device 004: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 002 Device 009: ID 04f9:003f Brother Industries, Ltd 
Bus 002 Device 007: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 002 Device 006: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 002 Device 005: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 002 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 002 Device 008: ID 04b8:0121 Seiko Epson Corp. GT-F500/GT-F550 [Perfection 2480/2580 PHOTO]
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dpkg -l | grep brother ne donne aucune réponse ci-dessous

benoit@rafal:~$ dpkg -l | grep brother
benoit@rafal:~$ 
benoit@rafal:~$ dpkg -l | grep cups
ii  bluez-cups                                    5.48-0ubuntu3.2                                 amd64        Bluetooth printer driver for CUPS
ii  cups                                          2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - PPD/driver support, web interface
ii  cups-browsed                                  1.20.2-0ubuntu3.1                               amd64        OpenPrinting CUPS Filters - cups-browsed
ii  cups-bsd                                      2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - BSD commands
ii  cups-client                                   2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - client programs (SysV)
ii  cups-common                                   2.2.7-1ubuntu2.7                                all          Common UNIX Printing System(tm) - common files
ii  cups-core-drivers                             2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - driverless printing
ii  cups-daemon                                   2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - daemon
ii  cups-filters                                  1.20.2-0ubuntu3.1                               amd64        OpenPrinting CUPS Filters - Main Package
ii  cups-filters-core-drivers                     1.20.2-0ubuntu3.1                               amd64        OpenPrinting CUPS Filters - Driverless printing
ii  cups-ipp-utils                                2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - IPP developer/admin utilities
ii  cups-pk-helper                                0.2.6-1ubuntu1.2                                amd64        PolicyKit helper to configure cups with fine-grained privileges
ii  cups-ppdc                                     2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - PPD manipulation utilities
ii  cups-server-common                            2.2.7-1ubuntu2.7                                all          Common UNIX Printing System(tm) - server common files
ii  cupswrapperhl2130:i386                        2.0.4-2                                         i386         Brother HL2130 CUPS wrapper driver
ii  libcups2:amd64                                2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - Core library
ii  libcupscgi1:amd64                             2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - CGI library
ii  libcupsfilters1:amd64                         1.20.2-0ubuntu3.1                               amd64        OpenPrinting CUPS Filters - Shared library
ii  libcupsimage2:amd64                           2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - Raster image library
ii  libcupsmime1:amd64                            2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - MIME library
ii  libcupsppdc1:amd64                            2.2.7-1ubuntu2.7                                amd64        Common UNIX Printing System(tm) - PPD manipulation library
ii  printer-driver-hpcups                         3.17.10+repack0-5                               amd64        HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
ii  python3-cups                                  1.9.73-2                                        amd64        Python3 bindings for CUPS
ii  python3-cupshelpers                           1.5.11-1ubuntu2                                 all          Python utility modules around the CUPS printing system
benoit@rafal:~$ lpstat -t
scheduler is running
system default destination: HL-2130
matériel pour HL-2130 : usb://dev/usb/lp0
matériel pour HL-2130-series : usb://Brother/HL-2130%20series?serial=J1N709494
HL-2130 accepte des requêtes depuis dim. 19 janv. 2020 16:33:28 CET
HL-2130-series accepte des requêtes depuis ven. 31 janv. 2020 17:31:45 CET
printer HL-2130 is idle.  enabled since dim. 19 janv. 2020 16:33:28 CET
printer HL-2130-series is idle.  enabled since ven. 31 janv. 2020 17:31:45 CET
benoit@rafal:~$ /usr/sbin/lpinfo -v
network http
file cups-brf:/
network https
serial serial:/dev/ttyS0?baud=115200
network ipps
network ipp
direct hp
direct usb://Brother/HL-2130%20series?serial=J1N709494
network beh
network socket
network lpd
direct hpfax
benoit@rafal:~$ cat /var/log/cups/error_log
E [31/Jan/2020:17:31:26 +0100] [cups-deviced] PID 6617 (gutenprint52+usb) stopped with status 1!
E [31/Jan/2020:17:53:05 +0100] [cups-deviced] PID 6851 (gutenprint52+usb) stopped with status 1!
benoit@rafal:~$ dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                           Version                                         Architecture Description
+++-=============================================-===============================================-============-=============================================================================================================================================================================================================================================================================
rc  linux-image-4.15.0-29-generic                 4.15.0-29.31                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-38-generic                 4.15.0-38.41                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-39-generic                 4.15.0-39.42                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-42-generic                 4.15.0-42.45                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-43-generic                 4.15.0-43.46                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-44-generic                 4.15.0-44.47                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-45-generic                 4.15.0-45.48                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-46-generic                 4.15.0-46.49                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-47-generic                 4.15.0-47.50                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-48-generic                 4.15.0-48.51                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-50-generic                 4.15.0-50.54                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-51-generic                 4.15.0-51.55                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-52-generic                 4.15.0-52.56                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-54-generic                 4.15.0-54.58                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-55-generic                 4.15.0-55.60                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-58-generic                 4.15.0-58.64                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-60-generic                 4.15.0-60.67                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-62-generic                 4.15.0-62.69                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-64-generic                 4.15.0-64.73                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-65-generic                 4.15.0-65.74                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-66-generic                 4.15.0-66.75                                    amd64        Signed kernel image generic
rc  linux-image-4.15.0-70-generic                 4.15.0-70.79                                    amd64        Signed kernel image generic
rc  linux-modules-4.15.0-29-generic               4.15.0-29.31                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-38-generic               4.15.0-38.41                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-39-generic               4.15.0-39.42                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-42-generic               4.15.0-42.45                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-43-generic               4.15.0-43.46                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-44-generic               4.15.0-44.47                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-45-generic               4.15.0-45.48                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-46-generic               4.15.0-46.49                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-47-generic               4.15.0-47.50                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-48-generic               4.15.0-48.51                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-50-generic               4.15.0-50.54                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-51-generic               4.15.0-51.55                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-52-generic               4.15.0-52.56                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-54-generic               4.15.0-54.58                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-55-generic               4.15.0-55.60                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-58-generic               4.15.0-58.64                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-60-generic               4.15.0-60.67                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-62-generic               4.15.0-62.69                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-64-generic               4.15.0-64.73                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-65-generic               4.15.0-65.74                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-66-generic               4.15.0-66.75                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-70-generic               4.15.0-70.79                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-29-generic         4.15.0-29.31                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-38-generic         4.15.0-38.41                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-39-generic         4.15.0-39.42                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-42-generic         4.15.0-42.45                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-43-generic         4.15.0-43.46                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-44-generic         4.15.0-44.47                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-45-generic         4.15.0-45.48                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-46-generic         4.15.0-46.49                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-47-generic         4.15.0-47.50                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-48-generic         4.15.0-48.51                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-50-generic         4.15.0-50.54                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-51-generic         4.15.0-51.55                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-52-generic         4.15.0-52.56                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-54-generic         4.15.0-54.58                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-55-generic         4.15.0-55.60                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-58-generic         4.15.0-58.64                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-60-generic         4.15.0-60.67                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-62-generic         4.15.0-62.69                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-64-generic         4.15.0-64.73                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-65-generic         4.15.0-65.74                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-66-generic         4.15.0-66.75                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-70-generic         4.15.0-70.79                                    amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP

Voilà, j'espère avoir suivi vos conseils sans fautes.
La commande concernant le pilote qui ne donne rien serait sans doute en rapport avec la fenêtre qui s'est ouverte quand j'ai allumé mon imprimante : " recherche du pilote" puis rien.
merci de votre guidage parfait pour mon niveau.

Hors ligne

#5 Le 31/01/2020, à 19:26

xubu1957

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Bonjour,

Tu peux aussi mettre les balises pour :

# Ubuntu Codename : bionic
# Architecture : x86_64
# Modèle de l'imprimante : HL-2130
# Connexion : USB
# Fichier d'informations : http://www.brother.com/pub/bsc/linux/infs/HL2130
- Paquet trouvé : hl2130lpr-2.1.0-1.i386.deb
- Paquet trouvé : cupswrapperHL2130-2.0.4-2.i386.deb

# Téléchargement du paquet : hl2130lpr-2.1.0-1.i386.deb
--2020-01-19 15:10:03--  http://www.brother.com/pub/bsc/linux/pa … 1.i386.deb
Résolution de www.brother.com (www.brother.com)… 104.85.54.217
Connexion à www.brother.com (www.brother.com)|104.85.54.217|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 35812 (35K) [application/x-troff-man]
Enregistre : «/home/benoit/demonipuch-brprinter-installer-6e4cce8c163b/./packages/hl2130lpr-2.1.0-1.i386.deb»

     0K .......... .......... .......... ....                 100% 89,2K=0,4s

2020-01-19 15:10:04 (89,2 KB/s) - «/home/benoit/demonipuch-brprinter-installer-6e4cce8c163b/./packages/hl2130lpr-2.1.0-1.i386.deb» enregistré [35812/35812]


# Téléchargement du paquet : cupswrapperHL2130-2.0.4-2.i386.deb
--2020-01-19 15:10:04--  http://www.brother.com/pub/bsc/linux/pa … 2.i386.deb
Résolution de www.brother.com (www.brother.com)… 104.85.54.217
Connexion à www.brother.com (www.brother.com)|104.85.54.217|:80… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 13272 (13K)
Enregistre : «/home/benoit/demonipuch-brprinter-installer-6e4cce8c163b/./packages/cupswrapperHL2130-2.0.4-2.i386.deb»

     0K .......... ..                                         100% 92,1K=0,1s

2020-01-19 15:10:05 (92,1 KB/s) - «/home/benoit/demonipuch-brprinter-installer-6e4cce8c163b/./packages/cupswrapperHL2130-2.0.4-2.i386.deb» enregistré [13272/13272]

# Vérification des pré-requis
- Paquet 'multiarch-support' installé
- Paquet 'lib32stdc++6' non installé
# Installation de 'lib32stdc++6'
Sélection du paquet libc6-i386 précédemment désélectionné.
(Lecture de la base de données...
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 218963 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libc6-i386_2.27-3ubuntu1_amd64.deb ...
Dépaquetage de libc6-i386 (2.27-3ubuntu1) ...
Sélection du paquet lib32gcc1 précédemment désélectionné.
Préparation du dépaquetage de .../lib32gcc1_1%3a8.3.0-6ubuntu1~18.04.1_amd64.deb ...
Dépaquetage de lib32gcc1 (1:8.3.0-6ubuntu1~18.04.1) ...
Sélection du paquet lib32stdc++6 précédemment désélectionné.
Préparation du dépaquetage de .../lib32stdc++6_8.3.0-6ubuntu1~18.04.1_amd64.deb ...
Dépaquetage de lib32stdc++6 (8.3.0-6ubuntu1~18.04.1) ...
Paramétrage de libc6-i386 (2.27-3ubuntu1) ...
Paramétrage de lib32gcc1 (1:8.3.0-6ubuntu1~18.04.1) ...
Paramétrage de lib32stdc++6 (8.3.0-6ubuntu1~18.04.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
- Paquet 'lib32stdc++6' installé
- Paquet 'cups' installé

# Installation du paquet : hl2130lpr-2.1.0-1.i386.deb
Sélection du paquet hl2130lpr:i386 précédemment désélectionné.
(Lecture de la base de données... 219277 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../hl2130lpr-2.1.0-1.i386.deb ...
Dépaquetage de hl2130lpr:i386 (2.1.0-1) ...
dpkg: hl2130lpr:i386 : problèmes de dépendances, mais configuration comme demandé :
hl2130lpr:i386 dépend de libc6 (>= 2.3.4-1).

Paramétrage de hl2130lpr:i386 (2.1.0-1) ...

# Installation du paquet : cupswrapperHL2130-2.0.4-2.i386.deb
Sélection du paquet cupswrapperhl2130:i386 précédemment désélectionné.
(Lecture de la base de données... 219294 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../cupswrapperHL2130-2.0.4-2.i386.deb ...
Dépaquetage de cupswrapperhl2130:i386 (2.0.4-2) ...
dpkg: cupswrapperhl2130:i386 : problèmes de dépendances, mais configuration comme demandé :
cupswrapperhl2130:i386 dépend de libc6 (>= 2.3.4-1).

Paramétrage de cupswrapperhl2130:i386 (2.0.4-2) ...
Restarting cups (via systemctl): cups.service.

# Recherche d'un fichier PPD
- Fichier PPD : /usr/share/cups/model/HL2130.ppd

# Ajout de l'imprimante HL-2130
- Backup du fichier /etc/cups/printers.conf.O
- Arret du service CUPS
lpinfo: Connexion ré-initialisée par le correspondant
- Restauration du fichier printers.conf
lpinfo: Mauvais descripteur de fichier
- Redémarrage du service CUPS
lpadmin: Unable to connect to server: Mauvais descripteur de fichier
- Restauration du fichier printers.conf.O

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#6 Le 31/01/2020, à 20:44

tropa

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Ah oui, merci Xubu1957, j'utiliserai désormais toujours les balises, puisque ça marche.
Bonne soirée

Hors ligne

#7 Le 31/01/2020, à 20:45

xubu1957

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Voir règles du forum > balises BB code

Balise CODE :

C'est la balise à utiliser pour donner de longs messages d'erreurs, des contenus de fichiers de configuration, des commandes à taper, etc … Elle permet des messages plus "compacts", et est moins ambiguë que d'autres polices sur certains caractères.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#8 Le 31/01/2020, à 21:49

eric63

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

re
il y a dans le script de demonipuch
un problème avec cups

# Ajout de l'imprimante HL-2130
- Backup du fichier /etc/cups/printers.conf.O
- Arret du service CUPS
lpinfo: Connexion ré-initialisée par le correspondant
- Restauration du fichier printers.conf
lpinfo: Mauvais descripteur de fichier
- Redémarrage du service CUPS
lpadmin: Unable to connect to server: Mauvais descripteur de fichier
- Restauration du fichier printers.conf.O

a mon avis il y a un truc qui se passe mal à ce niveau
mais j'ai aucune idée pour y remédier
et c'est pas le script de demonipuch qui créer le problème , il le révèle

Dernière modification par eric63 (Le 31/01/2020, à 21:50)


Kubuntu 19.10 - 64 bits + backports = plasma 5.18.3 KDE 5.67.0 Qt 5.12.4 et noyau 5.3.0-40 4* intel i5-4570 3.2 Ghz 12 Go nvidia gtx 750
pour installer une brother
N'oubliez pas les balises codes
J’utilise le clavier french AFNOR c‘est fort

Hors ligne

#9 Le 02/02/2020, à 12:38

tropa

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Bonjour,
Dans le gestionnaire de paquets synaptic, je vois le paquet :
cupswrapperhl2130:i386 Brother HL2130 CUPS wrapper driver
"état : cassé" (avec un point d'exclamation rouge) et "La liste des fichiers installés n'est pas disponible. Elle s'affichera après l'installation du paquet".
Je précise que les 2 paquets cassés que je mentionne dans mon premier message sont apparus à la suite du script de demonipuch...

Dans ma logithèque Ubuntu il y a un bouton "installer" pour cupswrapperhl2130. Est-ce qu'un clic dessus aggraverait le problème?

Hors ligne

#10 Le 02/02/2020, à 23:01

eric63

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

tu peux essayer d'installer cupswrapperhl2130 mais comme il y a des paquets cassés tu risque de tourner en boucle sur le défaut

il faudra peut être passer par une réparation avec aptitude des paquets "laissé en l'état"

je te met le lien https://forum.kubuntu-fr.org/viewtopic.php?id=1915001

Dernière modification par eric63 (Le 03/02/2020, à 00:56)


Kubuntu 19.10 - 64 bits + backports = plasma 5.18.3 KDE 5.67.0 Qt 5.12.4 et noyau 5.3.0-40 4* intel i5-4570 3.2 Ghz 12 Go nvidia gtx 750
pour installer une brother
N'oubliez pas les balises codes
J’utilise le clavier french AFNOR c‘est fort

Hors ligne

#11 Le 03/02/2020, à 00:19

tropa

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

impossible d'accéder à aptitude parceque ma 'liste de logiciels est corrompue"
puis :

benoit@rafal:~$ sudo apt-get install -f
E: Impossible d'obtenir le verrou /var/lib/dpkg/lock-frontend - open (11: Ressource temporairement non disponible)
E: Impossible d'obtenir le verrou de dpkg (/var/lib/dpkg/lock-frontend). Il est possible qu'un autre processus l'utilise.

Du coup je ne sais pas réparer mes paquets.

Hors ligne

#12 Le 03/02/2020, à 00:54

eric63

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

heu non c'est que tu veux utiliser deux instance de gestionnaire de paquets donc il crie et c'est normal
tu dois avoir synaptic encore ouvert et tu sollicites par terminal une install

je te  mets le lien
https://forum.kubuntu-fr.org/viewtopic.php?id=1915001

Dernière modification par eric63 (Le 03/02/2020, à 00:57)


Kubuntu 19.10 - 64 bits + backports = plasma 5.18.3 KDE 5.67.0 Qt 5.12.4 et noyau 5.3.0-40 4* intel i5-4570 3.2 Ghz 12 Go nvidia gtx 750
pour installer une brother
N'oubliez pas les balises codes
J’utilise le clavier french AFNOR c‘est fort

Hors ligne

#13 Le 03/02/2020, à 09:38

jibel

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

eric63 a écrit :

heu non c'est que tu veux utiliser deux instance de gestionnaire de paquets donc il crie et c'est normal
tu dois avoir synaptic encore ouvert et tu sollicites par terminal une install

je te  mets le lien
https://forum.kubuntu-fr.org/viewtopic.php?id=1915001

Salut eric63,
J'ai +/- le même ennui avec mon multifonctions(4) d'une brother MFC7460DN? Impossible d'installer les paquets qui sont "obsolètes" ce qui fait que la connexion USB correctement faite avec le PC est kaput pour scanner un doc. C'est drôle ta belle astuce date de 2015, merci @+ roll

Dernière modification par jibel (Le 03/02/2020, à 09:40)


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur. Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit et toc !

Avec Mint.17.3, Xub 16.04, Voyager X2 et X8, Debian 9.9 stretch, MX-linux, Hybryde 14.04, Arco .PC medion akira  DD 1T + 2 .

Hors ligne

#14 Le 03/02/2020, à 13:59

tropa

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

cette fois-ci j'ai fermé synaptic pour essayer ton lien.
D'abord je ne sais pas comment "ne garder que le PPA qui vous intéresse". Donc je passe et je passe au terminal:

benoit@rafal:~$ sudo apt install cupswrapperhl2130:i386
[sudo] Mot de passe de benoit : 
Désolé, essayez de nouveau.
[sudo] Mot de passe de benoit : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
cupswrapperhl2130:i386 est déjà la version la plus récente (2.0.4-2).
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 cupswrapperhl2130:i386 : Dépend: libc6:i386 (>= 2.3.4-1) mais ne sera pas installé
 hl2130lpr:i386 : Dépend: libc6:i386 (>= 2.3.4-1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
benoit@rafal:~$ <pre>sudo apt install hl2130pr:i386
bash: pre: Aucun fichier ou dossier de ce type
benoit@rafal:~$ sudo apt install hl2130lpr:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
hl2130lpr:i386 est déjà la version la plus récente (2.1.0-1).
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 cupswrapperhl2130:i386 : Dépend: libc6:i386 (>= 2.3.4-1) mais ne sera pas installé
 hl2130lpr:i386 : Dépend: libc6:i386 (>= 2.3.4-1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
benoit@rafal:~$ sudo apt-get install aptitude
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 aptitude : Dépend: aptitude-common (= 0.8.10-6ubuntu1) mais ne sera pas installé
            Dépend: libcwidget3v5 mais ne sera pas installé
 cupswrapperhl2130:i386 : Dépend: libc6:i386 (>= 2.3.4-1) mais ne sera pas installé
 hl2130lpr:i386 : Dépend: libc6:i386 (>= 2.3.4-1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

Je n'ai pas osé "apt --fix-broken install" de peur de casser encore plus.
J'aime bien (ou indiquez une solution) hmm

Hors ligne

#15 Le 10/02/2020, à 14:22

tropa

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

bonjour,
Comme personne ne répond, je continue à tâtons :

benoit@rafal:~$ sudo apt install cupswrapperhl2130:i386
[sudo] Mot de passe de benoit : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
cupswrapperhl2130:i386 est déjà la version la plus récente (2.0.4-2).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libjpeg-progs libjpeg9 libllvm7 libllvm8
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 20 non mis à jour.
benoit@rafal:~$ sudo apt autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  libjpeg-progs libjpeg9 libllvm7 libllvm8
0 mis à jour, 0 nouvellement installés, 4 à enlever et 20 non mis à jour.
Après cette opération, 129 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 220643 fichiers et répertoires déjà installés.)
Suppression de libjpeg-progs (1:9b-2) ...
Suppression de libjpeg9:amd64 (1:9b-2) ...
Suppression de libllvm7:amd64 (1:7-3~ubuntu0.18.04.1) ...
Suppression de libllvm8:amd64 (1:8-3~ubuntu18.04.2) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2ubuntu0.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ..

Ah, ben suite à ça, je n'ai plus de pquets cassés qui figurent dans synaptic!
C'est déja positif, je vais essayer de remettre en route mon imprimante.

Hors ligne

#16 Le 10/02/2020, à 14:49

jibel

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

@tropa,
C'est d'une complication incroyable pour ton imprimante.... Pourtant avec Wintruc, il ne devrait pas y avoir d'ennui! Les vrais raisons sont celles du "gagne-petit" Ce même ennui remonte a  plus de 20 ans au State .. Richard Stallman a eu le même souci, il a "râlè" au gars qui devait réparer son imprimante...Il fallait "régler" quelque chose pour que les codes devraient être casqués/réparés.. et hop la ...De nos jours rien a changé... hélas  roll  mad


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur. Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit et toc !

Avec Mint.17.3, Xub 16.04, Voyager X2 et X8, Debian 9.9 stretch, MX-linux, Hybryde 14.04, Arco .PC medion akira  DD 1T + 2 .

Hors ligne

#17 Le 14/02/2020, à 13:25

tropa

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Ben oui jibel,
Quand je suis passé à Ubuntu 18.04 j'en ai profité pour fêter mes 15 ans de divorce avec winchose, j'ai supprimé le double boot que je n'utilisais pratiquement plus jamais.
Je n'ai pas du tout envie de revenir en arrière, mais avec l'âge je fatigue et ça m'est très pénible de devoir batailler pour tout. C'est pour ça que je pose aussi la question sur ce forum: quelqu'un peut-il me dire s'il existe aujourd'hui  une imprimante dont TOUTES les fonctions (pilotes, interfaces, m-à-j...) sont accessibles sur Ubuntu avec autant d'aisance que sur winchose. Si ça n'existe pas, je vais sérieusement réfléchir : les services publics disparaissent (merci machin!) sans ordi perso on ne peut plus s'en sortir! alors, baisser les armes?

Hors ligne

#18 Le 14/02/2020, à 15:59

jibel

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Ho que oui !
C'est sur que le "modernisme" en arrive a devoir acheter une imprimante 4 fonctions. Voila le super cas de profit. Quand beaucoup de membres sont arrivés a installer une Brother avec le tuto de Demonipuch. Il n'y a vraiment pas eu de gros ennui. Sauf sur certains points, a chaque changement des nouvelles versions S.E libres, la, il y a eu de gros ennui. Des modifs de ceci ou cela font que les nouveaux y vont a fond la caisse avec les versions temporaires, style 16.10 ou 18.10 ou 19.10 non LTS.
Pour ton sujet , j'ai aussi une brother MFC 7460DN5 ans d'age ! Parfait, super matos ! Sauf pour les installes paquets de scan de cupwrapper etc . Mais il y a QQs années j'avais, ce que j'ai toujours des outils de HP deskjet 3652 et HP scanjet 3670 (qui est obsolète) mais fonctionne toujours. Voila ce qui m'est arrivé en voulant être le plus chic Alors pourquoi casser sa tirelire pour avoir une printer de haut de gamme? Je n'ose même pas dire ce prix pour les deux achats de HP .... Il y a plus de 10 ans ! big_smile  big_smile


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur. Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit et toc !

Avec Mint.17.3, Xub 16.04, Voyager X2 et X8, Debian 9.9 stretch, MX-linux, Hybryde 14.04, Arco .PC medion akira  DD 1T + 2 .

Hors ligne

#19 Le 14/02/2020, à 19:24

eric63

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

par ordre de préférence
ce sont HP puis brother les mieux renseignés pour utiliser linux
il ne faut pas vouloir non plus la dernière imprimante sortie
les constructeurs d'imprimante sortent tous des pilotes sur CD avec l'imprimante pour windows pourquoi ne le font ils pas avec linux ?
@jibel tu aurais eu le même problème en passant d'une 16.04 LTS à une 18.04 LTS avec ton imprimante brother puisque les paquets brother n'ont pas pris en compte le changement de structure de l'architecture d'ubuntu à partir de 17.10


Kubuntu 19.10 - 64 bits + backports = plasma 5.18.3 KDE 5.67.0 Qt 5.12.4 et noyau 5.3.0-40 4* intel i5-4570 3.2 Ghz 12 Go nvidia gtx 750
pour installer une brother
N'oubliez pas les balises codes
J’utilise le clavier french AFNOR c‘est fort

Hors ligne

#20 Le 14/02/2020, à 20:18

jibel

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

@eric63,
Tu as raison sur certains points! Perso , j'ai eu cette chance d'avoir fait un remplacement de cette Brother, ou mais chez le SAV en Belgique avec le spécialiste des S.E. libre. Que faire des S.E. temporaires en "oubliant" de publier les modifs de tel ou tel chose en non LTS! Croit-on que c'est un avantage de créer un S.E. libre non LTS ?
Personnellement a Bruxelles, j'ai eu cette chance de connaître dans les install party de ceci ou cela ! Les intérêts financiers sont de certains fabricants des printers ! Si j'avais eu le talent de Bill Gates ou de Steve Jobs, je serais devenu le plus riche du monde entier ....
Mais ces deux gaillards ont attaqués les ceusses qui refusait de "payer" tout !
D'ailleurs quelques années plus tard est arrivé ce gars qui se nomme Richard Stallman qui a hurlé auprès du "réparateur" de sa printer ...Qui lui a répondu qu'il fallait "casquer" il a crée SON MIS au state que les intérêts du fric ne devait être attribué qu'au géniteur de conception non-libre.... Et voila...Le pognon est avant tout le 1er motif.... Pour le reste? mon commentaire pourrait être diriger ===> a la poubelle    Quoique ? roll


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur. Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit et toc !

Avec Mint.17.3, Xub 16.04, Voyager X2 et X8, Debian 9.9 stretch, MX-linux, Hybryde 14.04, Arco .PC medion akira  DD 1T + 2 .

Hors ligne

#21 Le 14/02/2020, à 21:24

eric63

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

@tropa

0 mis à jour, 0 nouvellement installés, 4 à enlever et 20 non mis à jour.

faut faire la mise à jour si tu veux une base saine

sudo apt update

Dernière modification par eric63 (Le 14/02/2020, à 21:24)


Kubuntu 19.10 - 64 bits + backports = plasma 5.18.3 KDE 5.67.0 Qt 5.12.4 et noyau 5.3.0-40 4* intel i5-4570 3.2 Ghz 12 Go nvidia gtx 750
pour installer une brother
N'oubliez pas les balises codes
J’utilise le clavier french AFNOR c‘est fort

Hors ligne

#22 Le 14/02/2020, à 21:46

jibel

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Peut-être qu'il risque d'avoir aucune à MàJ  ?? Par contre utiliser cette commande :
sudo dpkg --configure -a il serait possible d'avoir des ajouts de sa version ? Puis ensuite de taper cette commande dans le terminal: apt upgrade..... Va savoir : Ou bien sudo apt autoremove concernant les paquets d'app's a virer ? hmm hmm


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur. Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit et toc !

Avec Mint.17.3, Xub 16.04, Voyager X2 et X8, Debian 9.9 stretch, MX-linux, Hybryde 14.04, Arco .PC medion akira  DD 1T + 2 .

Hors ligne

#23 Le 14/02/2020, à 22:04

eric63

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libjpeg-progs libjpeg9 libllvm7 libllvm8
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 20 non mis à jour.
benoit@rafal:~$ sudo apt autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  libjpeg-progs libjpeg9 libllvm7 libllvm8
0 mis à jour, 0 nouvellement installés, 4 à enlever et 20 non mis à jour.
Après cette opération, 129 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
jibel a écrit :

Peut-être qu'il risque d'avoir aucune à MàJ

  la console

20 non mis à jour.

dit le contraire donc ça c'est à faire

apt upgrade

pourquoi vouloir changer de version avec une commande tronquée du sudo qui ne marchera pas alors que les 20 mises à jour ne sont pas faites ?

sudo dpkg --configure -a 

comprend pas le motif de ça sauf si tu l'as lu explicitement dans la console de tropa !!!

Dernière modification par eric63 (Le 14/02/2020, à 22:37)


Kubuntu 19.10 - 64 bits + backports = plasma 5.18.3 KDE 5.67.0 Qt 5.12.4 et noyau 5.3.0-40 4* intel i5-4570 3.2 Ghz 12 Go nvidia gtx 750
pour installer une brother
N'oubliez pas les balises codes
J’utilise le clavier french AFNOR c‘est fort

Hors ligne

#24 Le 14/02/2020, à 22:19

jibel

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Ça sera OK automatiquement... Y-a pas de raison de douter d'une typing dans sa console ou terminal... Tout sera foutu a la trash avec la commande :sudo apt autoremove
pourquoi tu te compliques la vie ? Faire le plus simple des commandes devrait être respectées.... C'est tout.... Est-ce bien? J'espère que oui wink
1581714511.png
Here is my last one screenshot avec cet S.E. studio ubuntu 18.04 lts... Est-ce nul ?


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur. Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit et toc !

Avec Mint.17.3, Xub 16.04, Voyager X2 et X8, Debian 9.9 stretch, MX-linux, Hybryde 14.04, Arco .PC medion akira  DD 1T + 2 .

Hors ligne

#25 Le 14/02/2020, à 22:57

eric63

Re : [Résolu]18,04 LTS 64bits = Brother HL-2130 ne fonctionne plus

Faire le plus simple des commandes devrait être respectées

Les paquets suivants seront ENLEVÉS :
  libjpeg-progs libjpeg9 libllvm7 libllvm8
0 mis à jour, 0 nouvellement installés, 4 à enlever et 20 non mis à jour.
Après cette opération, 129 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 220643 fichiers et répertoires déjà installés.)
Suppression de libjpeg-progs (1:9b-2) ...
Suppression de libjpeg9:amd64 (1:9b-2) ...
Suppression de libllvm7:amd64 (1:7-3~ubuntu0.18.04.1) ...
Suppression de libllvm8:amd64 (1:8-3~ubuntu18.04.2) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2ubuntu0.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ..

la plus simple des commandes quand rien n'indique autre chose
c'est

 sudo apt update

et pas

sudo dpkg --configure -a 

Kubuntu 19.10 - 64 bits + backports = plasma 5.18.3 KDE 5.67.0 Qt 5.12.4 et noyau 5.3.0-40 4* intel i5-4570 3.2 Ghz 12 Go nvidia gtx 750
pour installer une brother
N'oubliez pas les balises codes
J’utilise le clavier french AFNOR c‘est fort

Hors ligne