Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 24/01/2019, à 13:52

Le Ché

Défaillance du Nas ou du système ... Récupération de données ? Help

Bonjour à tous les spécialistes du NAS et de la ligne de commande
J'ai cherché dans le forum mais mon problème est bien bizarre ou alors je n'ai pas  bien utilisé les ressources que je j'ai trouvées dans les nombreux posts que j'ai lus
Je possède plusieurs Mac (MacAddict depuis 1989), un PC sous Ubuntu 18-04 (parce que je voulais une machine performante, ouverte et évolutive pas comme le Mac Pro poubelle ou l'iMacPro) et un NAS synology DS413J
J'ai eu un problème il y a un mois, le NAS disparaissait du réseau, se mettait en dégradé, redémarrait en tournant en boucle, et il a finalement disparu
Je pensais à un problème de carte réseau sur le NAS ou une corruption du DSM mais je ne pouvais me connecter au NAS
Pas grave, je vais sortir les disques du NAS et les accoupler au PC sous Ubuntu : mais tout ne se passe pas comme prévu
- Le boitier NAS remarche mais bien sûr la partition du NAS a disparu
- Les 4 disques sont montés sous ubuntu avec l'utilitaire disque mais je n'arrive pas à accéder à la partition RAID (ce sont les 4 derniers dans la liste, les deux premiers sont juste là pour faire tourner ubuntu)
http://free-pictures-hosting.org/upload … -24-23.png


Et mdadm ne voit presque rien non plus
http://free-pictures-hosting.org/upload … -29-04.png


J'ai bien fait d'autres tentatives en lignes de commade (smartctrl, ...) mais les résultats ne me parlent pas beaucoup
http://free-pictures-hosting.org/upload … -45-51.png

Avec cette commande
http://free-pictures-hosting.org/upload … -59-41.png


J'avoue que je suis plus à l'aise avec le GUI des Mac et que je ne mets pas trop les mains dans le cambouis du Linux mais là je sèche
J'hésite à racheter un nouveau boîtier du NAS si je peux remettre en marche le 413J, je voudrais bien récupérer les données que bien sûr je n'ai pas sauvegardées, bref je doute
En tout cas, je vais mettre en place un système de sauvegarde du NAS soit avec l'ancien boîtier soit avec un nouveau boitier deux baies en Raid 0
Merci d'avance pour votre aide


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix le permettent).

Dernière modification par Le Ché (Le 24/01/2019, à 19:37)

Hors ligne

#2 Le 24/01/2019, à 16:08

lejurassien40

Re : Défaillance du Nas ou du système ... Récupération de données ? Help

Salut
Démonte tous les disques avec le stop à gauche de la roue cranté puis clic sur un espèce de play triangulaire à gauche de la roue cranté pour monter raid6 dev/md127  (dans  la première capture que tu as envoyé on le voit ) , c'est le raid en lui même .
mais il faut que touts les volumes soient démonté avant de monter raid6 dev/md127

Dernière modification par lejurassien40 (Le 24/01/2019, à 16:18)


"De tous ceux qui n'ont rien à dire, les plus agréables sont ceux qui se taisent !" (Desproges)  Ubuntu 18.04,16.04,14.04,Debian 9.5,Manjaro 17-Deepin,W10 pour jouer. Config: Dark Base Pro 900, Intel i7-8700K, Asrock Z370 Taïchi,GigaByte WindForce GTX 970 4GB, G.Skill Trident Z 2x8 Go 4133MHz, Samsung NVME 960EVO 250Go, OCZ 120Go, Crucial MX500, WD 2x 2To, Samsung HD103sj, H150i Water,Alim RM850X

Hors ligne

#3 Le 24/01/2019, à 16:16

Le Ché

Re : Défaillance du Nas ou du système ... Récupération de données ? Help

Merci pour ta réponse Lejurassien, c'est bien évidemment la première chose que j'ai faite mais il ne se passe rien
Je suis en train de créer une image disque des partitions de Raid Unix sur mon dique de bureau et je vais voir ce que je peux en tirer
Ensuite je referai une photo miniature de l'utilitaire disque sur dev/md127 car je n'ai aucune option de choix avec la palette d'actions
Merci encore

Hors ligne

#4 Le 25/01/2019, à 05:11

Le Ché

Re : Défaillance du Nas ou du système ... Récupération de données ? Help

Bonjour a tous, eh oui j’ai 3 heures d'avance sur vous
Le bilan de la nuit
La création d'une image disque n'a pas marché, mais je m'en doutais un peu
Un redémarrage et je relance l'utilitaire disque et miracle car il apparaît un nouveau volume en plus des 4 disques Raid plus le volume Raid 6, je vous présente "Périphérique bloc 4To" dev/vg1/volume 1 que je peux monter et que je peux copier vers mon disque de PC (à un rythme de sénateur endormi)
1548388361.png

et puis tout le reste
1548388677.png

Et le Raid pour lequel je n'ai toujours pas d'options
1548388787.png


Pour monter sur le bureau ça
1548389058.png

Alors, c'est très lent (en Ko/s) mais ça marche
Je suis très heureux de cette réussite même si je ne me l'explique pas, en tout cas la nuit porte conseil
Merci à tous, je vous ferai une photo de la récupération complète et de mon nouveau montage : ils ont raison les types qui disent qu'un NAS ce n'est pas une solution de sauvegarde. A méditer
ce qui me permet de copier

Dernière modification par cqfd93 (Le 25/01/2019, à 09:08)

Hors ligne

#5 Le 25/01/2019, à 05:16

Le Ché

Re : Défaillance du Nas ou du système ... Récupération de données ? Help

Bon, ça risque de prendre du temps mais je ne vais pas faire la fine bouche
est-ce qu'avec un logiciel de cloneur comme luckyBackup ce serait plus rapide ?
1548389654.png



Sur Toile Libre ou TDCT'Pix, choisir le lien « Insérer la miniature dans un forum : »

           1469894479.png

Dernière modification par cqfd93 (Le 25/01/2019, à 09:07)

Hors ligne