Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/11/2018, à 22:25

lan

lancement incessant du dialogue d'affichage (18.10)

Bonsoir,
C'est un bug que je rencontre sur un portable un peu vieux (Athlon 2 cores).
Dès l'installation, un menu des préférences d'affichage est lancé toutes 15-30 secondes et ce comportement continue en utilisation normale.
J'ai donc modifié le nom de la petite appli, donc  le processus qui la lance ne la trouve pas, m'envoie une petite boîte de dialogue une fois après la connexion puis me fiche la paix.
Par contre, je ne peux plus utiliser  un deuxième écran...
Des idées ?

Hors ligne

#2 Le 17/11/2018, à 20:47

ares

Re : lancement incessant du dialogue d'affichage (18.10)

lan a écrit :

un menu des préférences d'affichage est lancé toutes 15-30 secondes et ce comportement continue en utilisation normale.

Tu peux faire une copie d'écran.

lan a écrit :

J'ai donc modifié le nom de la petite appli, donc  le processus qui la lance ne la trouve pas, m'envoie une petite boîte de dialogue une fois après la connexion puis me fiche la paix.

Tu peux donner le nom de cette « petite appli » ?

Quelle version Xubuntu ?

@+


Religion rime avec désolation ! >>> ICI

Hors ligne

#3 Le 17/11/2018, à 20:56

lan

Re : lancement incessant du dialogue d'affichage (18.10)

Merci de ta réponse.
Xubuntu 18-10.  J'ai eu le même soucis à l'installe avec  Lunbutu 18-04.
L'appli est

xfce4-display-settings

Je ne peux pas faire de capture pour l’instant (ordinateur distant avec connexion en ssh) mais c'est le même truc que sur le lien suivant appli
C'est pas l'appli en elle-même qui bogue, c'est « un truc » qui la lance en permanence.

Hors ligne

#4 Le 17/11/2018, à 22:18

ares

Re : lancement incessant du dialogue d'affichage (18.10)

Comme tu sembles maîtriser, en faisant un

ps -aux

Tu devrais découvrir le « truc » qui lance "xfce4-display-settings"

Tu n'as pas d'erreur avec :

dmesg | grep Error

Regarde aussi avec x86/mm, vga

Avec cette commande :

lspci | grep VGA

on aura le type de carte vidéo

@+


Religion rime avec désolation ! >>> ICI

Hors ligne

#5 Le 17/11/2018, à 22:41

lan

Re : lancement incessant du dialogue d'affichage (18.10)

Pour l'instant, un de mes enfants utilise le pc, donc ps me renvoie plein de trucs.
Comme truc qui pourrait correspondre, j'aurais

xfsettingsd

mais la doc sur sa config n'est pas très bavarde :
doc
Pour les erreurs :

dmesg |grep Error

[    2.469785] RAS: Correctable Errors collector initialized.
[   19.521849] ACPI Error: Field [D128] at bit offset/length 16/1024 exceeds size of target Buffer (160 bits) (20170831/dsopcode-235)
[   19.521887] ACPI Error: Method parse/execution failed \_SB.WMID.HWMC, AE_AML_BUFFER_LIMIT (20170831/psparse-550)
[   19.521900] ACPI Error: Method parse/execution failed \_SB.WMID.WMAD, AE_AML_BUFFER_LIMIT (20170831/psparse-550)
[   19.521963] ACPI Error: Field [D128] at bit offset/length 16/1024 exceeds size of target Buffer (160 bits) (20170831/dsopcode-235)
[   19.521988] ACPI Error: Method parse/execution failed \_SB.WMID.HWMC, AE_AML_BUFFER_LIMIT (20170831/psparse-550)
[   19.521997] ACPI Error: Method parse/execution failed \_SB.WMID.WMAD, AE_AML_BUFFER_LIMIT (20170831/psparse-550)
[   19.522057] ACPI Error: Field [D128] at bit offset/length 16/1024 exceeds size of target Buffer (160 bits) (20170831/dsopcode-235)
[   19.522081] ACPI Error: Method parse/execution failed \_SB.WMID.HWMC, AE_AML_BUFFER_LIMIT (20170831/psparse-550)
[   19.522090] ACPI Error: Method parse/execution failed \_SB.WMID.WMAD, AE_AML_BUFFER_LIMIT (20170831/psparse-550)
[   19.529903] ACPI Error: Field [D128] at bit offset/length 16/1024 exceeds size of target Buffer (160 bits) (20170831/dsopcode-235)
[   19.529939] ACPI Error: Method parse/execution failed \_SB.WMID.HWMC, AE_AML_BUFFER_LIMIT (20170831/psparse-550)
[   19.529952] ACPI Error: Method parse/execution failed \_SB.WMID.WMAD, AE_AML_BUFFER_LIMIT (20170831/psparse-550)
[   19.530015] ACPI Error: Field [D128] at bit offset/length 16/1024 exceeds size of target Buffer (160 bits) (20170831/dsopcode-235)
[   19.530040] ACPI Error: Method parse/execution failed \_SB.WMID.HWMC, AE_AML_BUFFER_LIMIT (20170831/psparse-550)
[   19.530050] ACPI Error: Method parse/execution failed \_SB.WMID.WMAD, AE_AML_BUFFER_LIMIT (20170831/psparse-550)
dmesg |grep x86
[    0.000000] x86/fpu: x87 FPU will use FXSAVE
[    0.000000] x86/PAT: Configuration [0-7]: WB  WC  UC- UC  WB  WP  UC- WT  
[    0.032000] x86: Booting SMP configuration:
[    0.032104] x86/mm: Memory block size: 128MB
[    2.526689] x86/mm: Checked W+X mappings: passed, no W+X pages found.
[    8.178224] systemd[1]: Detected architecture x86-64.

dmesg |grep vga
[    0.152073] pci 0000:01:05.0: vgaarb: setting as boot VGA device
[    0.152073] pci 0000:01:05.0: vgaarb: VGA device added: decodes=io+mem,owns=io+mem,locks=none
[    0.152073] pci 0000:02:00.0: vgaarb: VGA device added: decodes=io+mem,owns=none,locks=none
[    0.152073] pci 0000:02:00.0: vgaarb: bridge control possible
[    0.152073] pci 0000:01:05.0: vgaarb: bridge control possible
[    0.152073] vgaarb: loaded
[    2.839230] vga_switcheroo: detected switching method \_SB_.PCI0.AGP_.VGA_.ATPX handle
[    4.757126] vga_switcheroo: enabled
[   19.564166] snd_hda_intel 0000:02:00.1: Handle vga_switcheroo audio client
[   30.417414] radeon 0000:02:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[   30.417423] radeon 0000:01:05.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem

Donc pour moi, pas de problème

lspci |grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] (rev ff)

Bonne soirée,

Hors ligne

#6 Le 17/11/2018, à 23:32

ares

Re : lancement incessant du dialogue d'affichage (18.10)

Salut,

Bon je suis pas spécialiste... pas frapper merci smile
À faire :

1 - Pour les erreurs "ACPI" regarde dans la documentation pour désactiver cette fonctionnalité...

2 - Il faut peut-être installé un "module" non free pour cette carte vidéo... voir dans les paramètres Xubuntu (pilotes additionnels).

3 - Cela peut provenir de la mauvaise sélection écran au moment de l'initialisation, puisque :

vga_switcheroo: detected switching method

4 - Que renvoie la commande : (je suis pas sûr de cette commande, désolé)

grep -i switcheroo / boot / config- *

@+


Religion rime avec désolation ! >>> ICI

Hors ligne

#7 Le 17/11/2018, à 23:40

lan

Re : lancement incessant du dialogue d'affichage (18.10)

3 - Cela peut provenir de la mauvaise sélection écran au moment de l'initialisation, puisque :

vga_switcheroo: detected switching method

Je pense que tu as mis le doigt sur l'endroit qui fait mal... Là, je vais me coucher, mais je vais investiguer demain.
Merci beaucoup.

Hors ligne

#8 Le 17/11/2018, à 23:43

Naziel

Re : lancement incessant du dialogue d'affichage (18.10)

Ah il est chiant ce bug! J'ai eu le même sur un hp dv6.
Je suis le fil

Hors ligne