Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/06/2018, à 18:20

Alpo

[Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

Bonjour,
j'essaie d'installer ubuntu sur un nouvel ordi (un dell XPS, avec Windows 10 pré-installé). Je voudrais supprimer Windows et mettre ubuntu à la place.
J'utilise une clé usb sur laquelle j'ai installé l'iso d'installation avec UNetbootin.
Malheureusement, au début de l'installation, après avoir choisi la langue et paramétré la connexion à internet, j'arrive sur page suivante :

https://zupimages.net/up/18/24/d4nd.jpg

Si je cliques sur "modifier", l'installation plante.
Et si je cliques sur "continuer", j'obtiens ceci :

https://zupimages.net/up/18/24/nj3l.jpg

Je précises que j'ai essayé avec deux versions d'ubuntu : 18.04 et 16.04 et que dans les deux cas, le problème est le même. Par contre, la session live fonctionne bien.
Est-ce que quelqu'un saurait m'aider à résoudre le problème?
Merci d'avance!


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre, TDCT'Pix le permettent).

Dernière modification par Alpo (Le 17/06/2018, à 19:04)

Hors ligne

#2 Le 14/06/2018, à 18:49

malbo

Re : [Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

Depuis la session live de la 18.04, fais un Boot-Info et donne l'URL de ce Boot-Info dans ta réponse.
Donne le nom complet du modèle de ton dell XPS. Je sais qu'ils sont très chiants chez Dell parce que pour un même nom de modèle, il y a des différences importantes sous le capot mais fais quand même un effort. Parce que Dell XPS, ça ne veut rien dire. Regarde tout ce qu'il y a sous cette désignation : dans la "Liste des portables « Dell »" : https://doc.ubuntu-fr.org/liste_portables_dell#xps

Dernière modification par malbo (Le 14/06/2018, à 18:52)

Hors ligne

#3 Le 14/06/2018, à 18:51

lucmars

Re : [Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

L'installateur ne voit pas le disque-dur car en général sur les XPS le disque est en mode RAID (ou autre).

Il te faut entrer dans le bios et passer le disque en mode AHCI et tu sauvegardes.

Mais comme le laisse entendre Malbo, mon idée n''est p'tete pas suffisante.

Dernière modification par lucmars (Le 14/06/2018, à 18:54)

Hors ligne

#4 Le 14/06/2018, à 19:03

malbo

Re : [Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

lucmars a écrit :

Il te faut entrer dans le bios et passer le disque en mode AHCI et tu sauvegardes.

Tu dois avoir raison quand tu écris qu'il faut enlever le mode RAID. C'est ce qui a dû être fait pour le XPS 13 9370 dans ce fil : https://forum.ubuntu-fr.org/viewtopic.p … #p21893826

Hors ligne

#5 Le 14/06/2018, à 19:10

Alpo

Re : [Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

Merci pour vos réponses. Je vais essayer en mode AHCI.
En attendant, voici le rapport du boot-info :
http://paste.ubuntu.com/p/yw4DRNBB9t/

Hors ligne

#6 Le 14/06/2018, à 19:31

lucmars

Re : [Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

Alpo a écrit :

Merci pour vos réponses. Je vais essayer en mode AHCI.
En attendant, voici le rapport du boot-info :
http://paste.ubuntu.com/p/yw4DRNBB9t/

Meme le boot-info ne voit pas ton DD (ou bien c'est moi smile)

À noter un autre impair avec les XPS, le démarrage rapide à la sauce Intel aka l'IRST, désactive le dans le bios, a-priori

Mais t'as toujours pas donner le modèle EXACT de ton dell XPS, car si t'as le dernier venu sur le marché, y-a p'tete de nouvelles surprises !

Hors ligne

#7 Le 14/06/2018, à 19:31

Alpo

Re : [Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

Yes c'est bon, en mode AHCI ça marche. Je ne suis pas encore allé au bout de l'installation mais au moins j'ai dépassé le blocage auquel j'étais confronté...
Merci les gars!!! big_smile

Hors ligne

#8 Le 14/06/2018, à 20:11

malbo

Re : [Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

Ton Boot-Info est là :

 Boot Info Script 8f991e4 + Boot-Repair extra info      [Boot-Info 25oct2017]


============================= Boot Info Summary: ===============================

 => Syslinux MBR (5.00 and higher) is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  SYSLINUX 6.03 20151222............................................@.....2....0............A20 gate n
    Boot sector info:  Syslinux looks at sector 3281916 of /dev/sda1 for its 
                       second stage. SYSLINUX is installed in the  directory. 
                       No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /boot/grub/grub.cfg /syslinux.cfg /casper/vmlinuz.efi 
                       /EFI/BOOT/grubx64.efi /ldlinux.sys

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________
Disk /dev/sda: 15 GiB, 16093544448 bytes, 31432704 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1                   4    31,432,703    31,432,700   c W95 FAT32 (LBA)


"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/loop0                                              squashfs   
/dev/sda1        0D7F-0986                              vfat       

========================= "ls -l /dev/disk/by-id" output: ======================

total 0
lrwxrwxrwx 1 root root  9 Jun 14 17:07 usb-Sony_Storage_Media_5A0903040022296-0:0 -> ../../sda
lrwxrwxrwx 1 root root 10 Jun 14 17:07 usb-Sony_Storage_Media_5A0903040022296-0:0-part1 -> ../../sda1

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/loop0       /rofs                    squashfs   (ro,noatime)
/dev/sda1        /cdrom                   vfat       (ro,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)


=========================== sda1/boot/grub/grub.cfg: ===========================

--------------------------------------------------------------------------------

if loadfont /boot/grub/font.pf2 ; then
	set gfxmode=auto
	insmod efi_gop
	insmod efi_uga
	insmod gfxterm
	terminal_output gfxterm
fi

set menu_color_normal=white/black
set menu_color_highlight=black/light-gray

menuentry "Try Ubuntu without installing" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---
	initrd	/casper/initrd.lz
}
menuentry "Install Ubuntu" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash ---
	initrd	/casper/initrd.lz
}
menuentry "OEM install (for manufacturers)" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash oem-config/enable=true ---
	initrd	/casper/initrd.lz
}
menuentry "Check disc for defects" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  boot=casper integrity-check quiet splash ---
	initrd	/casper/initrd.lz
}
--------------------------------------------------------------------------------

============================== sda1/syslinux.cfg: ==============================

--------------------------------------------------------------------------------
default menu.c32
prompt 0
menu title UNetbootin
timeout 100

label unetbootindefault
menu label Default
kernel /ubnkern
append initrd=/ubninit file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---

label ubnentry0
menu label ^Help
kernel /ubnkern
append initrd=/ubninit 

label ubnentry1
menu label ^Try Ubuntu without installing
kernel /casper/vmlinuz.efi
append initrd=/casper/initrd.lz file=/cdrom/preseed/ubuntu.seed boot=casper  quiet splash ---

label ubnentry2
menu label ^Install Ubuntu
kernel /casper/vmlinuz.efi
append initrd=/casper/initrd.lz file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity  quiet splash ---

label ubnentry3
menu label ^Check disc for defects
kernel /casper/vmlinuz.efi
append initrd=/casper/initrd.lz boot=casper integrity-check  quiet splash ---

label ubnentry4
menu label Test ^memory
kernel /install/mt86plus
append initrd=/ubninit 

label ubnentry5
menu label ^Boot from first hard disk
kernel /ubnkern
append initrd=/ubninit 

label ubnentry6
menu label Try Ubuntu without installing
kernel /casper/vmlinuz.efi
append initrd=/casper/initrd.lz file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---

label ubnentry7
menu label Install Ubuntu
kernel /casper/vmlinuz.efi
append initrd=/casper/initrd.lz file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash ---

label ubnentry8
menu label OEM install (for manufacturers)
kernel /casper/vmlinuz.efi
append initrd=/casper/initrd.lz file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash oem-config/enable=true ---

label ubnentry9
menu label Check disc for defects
kernel /casper/vmlinuz.efi
append initrd=/casper/initrd.lz boot=casper integrity-check quiet splash ---

--------------------------------------------------------------------------------

=================== sda1: Location of files loaded by Grub: ====================

           GiB - GB             File                                 Fragment(s)

            ?? = ??             boot/grub/grub.cfg                             1

================= sda1: Location of files loaded by Syslinux: ==================

           GiB - GB             File                                 Fragment(s)

            ?? = ??             syslinux.cfg                                   1
            ?? = ??             ldlinux.sys                                    1
            ?? = ??             ldlinux.c32                                    1
            ?? = ??             libcom32.c32                                   1
            ?? = ??             libutil.c32                                    1
            ?? = ??             menu.c32                                       1

============== sda1: Version of COM32(R) files used by Syslinux: ===============

 ldlinux.c32                        :  not a COM32/COM32R module
 libcom32.c32                       :  not a COM32/COM32R module
 libutil.c32                        :  not a COM32/COM32R module
 menu.c32                           :  not a COM32/COM32R module

=============================== StdErr Messages: ===============================

File descriptor 9 (/proc/5698/mounts) leaked on lvs invocation. Parent PID 10027: bash
File descriptor 63 (pipe:[37819]) leaked on lvs invocation. Parent PID 10027: bash

ADDITIONAL INFORMATION :
=================== log of boot-info 20180614_1707 ===================
boot-info version : 4ppa65
boot-sav version : 4ppa65
boot-sav-extra version : 4ppa65
glade2script version : 3.2.3~ppa4
boot-info is executed in live-session (Ubuntu 16.04.4 LTS, xenial, Ubuntu, x86_64)
CPU op-mode(s):        32-bit, 64-bit
BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---
ls: cannot access '/home/usr/.config': No such file or directory

=================== os-prober:


=================== blkid:
/dev/sda1: UUID="0D7F-0986" TYPE="vfat" PARTUUID="04030201-01"
/dev/loop0: TYPE="squashfs"


=================== efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000
Boot0000* Windows Boot Manager	HD(1,GPT,66ad845b-af00-40d7-816c-69158c3f96e6,0x800,0x145000)/File(EFIMicrosoftBootbootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...r~...............
Boot0001* UEFI: Sony Storage Media 1.00, Partition 1	PciRoot(0x0)/Pci(0x14,0x0)/USB(2,0)/HD(1,MBR,0x1,0x4,0x1df9ffc)..BO

=================== UEFI/Legacy mode:
BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.
SecureBoot disabled. (maybe sec-boot, Please report this message to boot.repair@gmail.com)


=================== PARTITIONS & DISKS:



=================== parted -lm:

BYT;
/dev/sda:16.1GB:scsi:512:512:msdos:Sony Storage Media:;
1:2048B:16.1GB:16.1GB:fat32::lba;

=================== lsblk:
KNAME TYPE FSTYPE    SIZE LABEL
loop0 loop squashfs  1.5G
sda   disk            15G
sda1  part vfat       15G

KNAME ROTA RO RM STATE   MOUNTPOINT
loop0    1  1  0         /rofs
sda      1  0  1 running
sda1     1  0  1         /cdrom


=================== mount:
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=8051684k,nr_inodes=2012921,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=1613884k,mode=755)
/dev/sda1 on /cdrom type vfat (ro,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on /rofs type squashfs (ro,noatime)
aufs on / type aufs (rw,noatime,si=ed24b7476b3e93db)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=33,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=18019)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
tracefs on /sys/kernel/debug/tracing type tracefs (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,relatime)
tmpfs on /run/user/999 type tmpfs (rw,nosuid,nodev,relatime,size=1613884k,mode=700,uid=999,gid=999)
gvfsd-fuse on /run/user/999/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=999,group_id=999)


=================== ls:
/sys/block/sda (filtered):  alignment_offset bdi capability dev device discard_alignment events events_async events_poll_msecs ext_range holders inflight integrity power queue range removable ro sda1 size slaves stat subsystem trace uevent
/dev (filtered):  acpi_thermal_rel autofs block bsg btrfs-control bus char console core cpu cpu_dma_latency cuse disk dri drm_dp_aux0 drm_dp_aux1 drm_dp_aux2 drm_dp_aux3 ecryptfs fb0 fb1 fd full fuse hidraw0 hidraw1 hpet hugepages hwrng i2c-0 i2c-1 i2c-2 i2c-3 i2c-4 i2c-5 i2c-6 i2c-7 i2c-8 initctl input kmsg kvm lightnvm log mapper mcelog mei0 mem memory_bandwidth mqueue net network_latency network_throughput null port ppp psaux ptmx pts random rfkill rtc rtc0 sda sda1 serial sg0 shm snapshot snd stderr stdin stdout tpm0 tpmrm0 uhid uinput urandom userio vfio vga_arbiter vhci vhost-net vhost-vsock zero
ls /dev/mapper:  control

=================== df -Th:

Filesystem     Type      Size  Used Avail Use% Mounted on
udev           devtmpfs  7.7G     0  7.7G   0% /dev
tmpfs          tmpfs     1.6G  9.7M  1.6G   1% /run
/dev/sda1      vfat       15G  1.6G   14G  11% /cdrom
/dev/loop0     squashfs  1.5G  1.5G     0 100% /rofs
aufs           aufs      7.7G   99M  7.6G   2% /
tmpfs          tmpfs     7.7G  125M  7.6G   2% /dev/shm
tmpfs          tmpfs     5.0M  4.0K  5.0M   1% /run/lock
tmpfs          tmpfs     7.7G     0  7.7G   0% /sys/fs/cgroup
tmpfs          tmpfs     7.7G  780K  7.7G   1% /tmp
tmpfs          tmpfs     1.6G   84K  1.6G   1% /run/user/999

=================== fdisk -l:
Disk /dev/loop0: 1.5 GiB, 1564921856 bytes, 3056488 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 15 GiB, 16093544448 bytes, 31432704 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x04030201

Device     Boot Start      End  Sectors Size Id Type
/dev/sda1           4 31432703 31432700  15G  c W95 FAT32 (LBA)


Error: no partitions
/usr/share/boot-sav/gui-tab-other.sh: line 93: _checkbutton_repairfilesystems: command not found


=================== Suggested repair
The default repair of the Boot-Repair utility would not act on the MBR.
Additional repair would be performed:  repair-filesystems


=================== User settings
The settings chosen by the user will not act on the boot.

Effectivement, on ne voit dans ce Boot-Info que la LiveUSB 16 Go.
Mais comme tu viens de passer en mode AHCI, ça devrait marcher. Donne des nouvelles.

Hors ligne

#9 Le 15/06/2018, à 12:08

Alpo

Re : [Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

Mon modèle c'est le Dell 9575, qui peut passer en mode tablette, avec une carte graphique AMD.
Pour les nouvelles, l'installation s'est bien passée. Ubuntu 18.04 tourne bien. Je suis juste un peu surpris d'avoir dû installer un programme pour utiliser le clic droit de ma souris! Et puis je trouve que l'écran UHD n'est pas du tout bien géré. Ça c'est assez décevant, j'espère que ça va évoluer, mais pour l'instant je pense que je vais réduire à la définition à du FHD, c'était bien la peine...

Hors ligne

#10 Le 15/06/2018, à 13:54

malbo

Re : [Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

Bonjour,
Sauf erreur ton modèle est décrit dans cet article très récent "Dell XPS 15 2-in-1 (9575) review" : https://www.windowscentral.com/dell-xps-15-9575-review
Je pense que ce modèle a dû sortir début 2018 parce que le couple processeur + carte graphique qui équipe ce modèle est sorti en janvier 2018 (source). C'est donc de l'ultra-frais et moi ça ne m'étonne pas que la version 18.04 ne soit pas capable de gérer aux petites oignons ton modèle. Tu as raison d'espérer que ça va évoluer. Je ne suis pas certain qu'il y ait dès à présent une possibilité d'améliorer la gestion de l'affichage mais tu peux toujours créer une nouvelle discussion dans la rubrique spécialisée du forum "Affichage et cartes graphiques".
Cela dit, ton problème d'installation étant réglé, je te propose de passer la discussion en "résolu" en procédant comme suit :
1) te connecter sur le forum
2) cliquer sur "Modifier" en bas à droite de ton PREMIER post
3) modifier le titre de la discussion pour qu'il devienne :

[Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine" 

EDIT : comme on ne sait jamais avec Dell ce qu'il y a sous le capot, ce serait utile que tu précises si ton processeur est le i5-8305G ou bien le i7-8705G

Dernière modification par malbo (Le 15/06/2018, à 14:08)

Hors ligne

#11 Le 17/06/2018, à 19:04

Alpo

Re : [Résolu] Erreur "aucun système de fichiers n'a été choisi comme racine

Mon processeur est le i7-8705G, et en effet je vais lancer un sujet concernant l'affichage.
Merci de ton aide!

Hors ligne