Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/06/2018, à 15:31

Piteur

GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Bonjour.

Question très simple : est-il possible d'installer la version 2.10 de GIMP sur une version 16.04 LTS de (x)Ubuntu ? Flatpak ne semble pas disponible dans les dépôts Canonical pour cette version de l'OS. Pour cause d'incompatibilité ?

Merci pour toute réponse.


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#2 Le 14/06/2018, à 17:00

f.x0

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Bonjour Piteur,

La Doc indique pourtant l'inverse : ici


SOPI

Hors ligne

#3 Le 14/06/2018, à 17:21

GammaDraconis

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Si Flatpak est utilisable en 16.04 mais ce n'est pas très pratique sur cette version car comme il n'est pas dans les dépots officiels, ça t'oblige à ajouter un PPA uniquement pour avoir Flatpak qui lui te permet d'avoir Gimp (un peu tiré par les cheveux...).

Quitte à avoir la dernière version de Gimp, le plus simple sur la 16.04 c'est donc d'utiliser le paquet snap puisque c'est intégré de base par défaut.


A noté qu'avec la 18.04 tu n'aurais pas non plus Flatpak par défaut puisque Ubuntu utilise leur solution (Snap) pour les paquets universels par contre il est installable directement sans PPA (dans les dépots officiels) contrairement à la 16.04.

Dernière modification par GammaDraconis (Le 14/06/2018, à 17:23)


PC1 perso (Xiaomi Air 13) : dualboot avec Archlinux/Xfce et Ubuntu 18.04LTS/Gnome
PC2 perso (Lenovo Legion Y520) : quadrupleboot avec Archlinux/Plasma, Ubuntu 18.10/Gnome, OpenSuSe Tumbleweed/Mate, Win10
PC3 pro : OpenSuSe Leap 15/Plasma
Besoin d'un script de post-install pour la 18.04 ? c'est ici : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#4 Le 14/06/2018, à 17:23

nam1962

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Pour flatpak sur 16.04 :

sudo add-apt-repository ppa:alexlarsson/flatpak
sudo apt update
sudo apt install flatpak
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak install https://flathub.org/repo/appstream/org.gimp.GIMP.flatpakref

Puis régulièrement penser à :

flatpak update

Dernière modification par nam1962 (Le 14/06/2018, à 17:26)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#5 Le 14/06/2018, à 17:27

GammaDraconis

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Précision Nam1962 :

Dans le cas ou tu ajoutes le dépots flathub comme tu l'a indiqué, tu n'es pas obligé de remettre le lien complet pour installer un logiciel dans ce dépot, tu peux directement faire alors :

flatpak install flathub org.gimp.GIMP

(donc pas besoin de préciser l'adresse du serveur et de mettre flatpakref à la fin).

La ligne complète que tu as indiqué n'est nécessaire que si le dépot flathub n'a pas été ajouté avant.


PC1 perso (Xiaomi Air 13) : dualboot avec Archlinux/Xfce et Ubuntu 18.04LTS/Gnome
PC2 perso (Lenovo Legion Y520) : quadrupleboot avec Archlinux/Plasma, Ubuntu 18.10/Gnome, OpenSuSe Tumbleweed/Mate, Win10
PC3 pro : OpenSuSe Leap 15/Plasma
Besoin d'un script de post-install pour la 18.04 ? c'est ici : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#6 Le 14/06/2018, à 17:39

nam1962

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Tu as raison, là j'ai fait ceinture et bretelles ! big_smile


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#7 Le 15/06/2018, à 15:57

Piteur

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

f.x0 a écrit :

Bonjour Piteur,

La Doc indique pourtant l'inverse : ici

Ce n'est pas ce que je comprends :

Capture sur la page indiquée

------------------

GammaDraconis a écrit :

Quitte à avoir la dernière version de Gimp, le plus simple sur la 16.04 c'est donc d'utiliser le paquet snap puisque c'est intégré de base par défaut.

Donc, s'il m'est permis d'insister, que faut-il écrire exactement dans le Terminal ?

Quelque chose comme ça ?

sudo snap install gimp

→ Si je comprends bien, exit Synaptic avec les fichiers installables avec Snap ?

Merci

--- EDIT ---

Pour ce qui est de l'installation, c'est bien la ligne de commande que j'ai écrite qu'il faut employer apparemment : l'installation s'est faite.

Mais je me retrouve du coup avec deux versions de GIMP : la 2.8 et la 2.10 ! Cela implique plusieurs questions :

  • la désinstallation de la version 2.8 se fait par sudo apt-get autoremove gimp ?
    → en principe, la version 2.10 installée par snap ne devrait pas être touchée... Ou bien ?

  • Comment installe-t-on les plugins installés initialement dans la version 2.8 avec Synaptic (exemples : gimp-data-extras, gimp-dcraw ou gimp-ufraw) ?

  • Où convient-il de placer les scripts qu'on avait mis dans des dossiers particuliers de la configuration de GIMP 2.8 ?

Merci.

Dernière modification par Piteur (Le 15/06/2018, à 16:57)


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#8 Le 15/06/2018, à 16:46

f.x0

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Tu postes une image qui indique la version PPA 2.8.22,
mais tu indiques dans ton message

est-il possible d'installer la version 2.10 de GIMP sur une version 16.04 LTS de (x)Ubuntu ? Flatpak ne semble pas disponible dans les dépôts Canonical pour cette version de l'OS. Pour cause d'incompatibilité ?

or c'est possible

nam1962 a écrit :

Pour flatpak sur 16.04 :

sudo add-apt-repository ppa:alexlarsson/flatpak
sudo apt update
sudo apt install flatpak
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak install https://flathub.org/repo/appstream/org.gimp.GIMP.flatpakref

Puis régulièrement penser à :

flatpak update

ou

GammaDraconis a écrit :

Dans le cas ou tu ajoutes le dépots flathub comme tu l'a indiqué, tu n'es pas obligé de remettre le lien complet pour installer un logiciel dans ce dépot, tu peux directement faire alors :

flatpak install flathub org.gimp.GIMP

(donc pas besoin de préciser l'adresse du serveur et de mettre flatpakref à la fin).

ou encore avec snap comme indiqué également dans la Doc.

Dernière modification par f.x0 (Le 15/06/2018, à 16:47)


SOPI

Hors ligne

#9 Le 15/06/2018, à 17:15

Piteur

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Bonjour.

Merci, f.x0

j'ai utilisé SNAP en faisant :

sudo snap install gimp

Mais, comme dit plus haut (partie EDIT), je me retrouve du coup avec deux versions de GIMP : la 2.8 et la 2.10 ! Cela implique plusieurs questions :

  • la désinstallation de la version 2.8 se fait par sudo apt-get autoremove gimp ?
        → en principe, la version 2.10 installée par snap ne devrait pas être touchée... Ou bien ?

  • Comment installe-t-on les plugins installés initialement dans la version 2.8 avec Synaptic (exemples : gimp-data-extras, gimp-dcraw ou gimp-ufraw) ?

  • Où convient-il de placer les scripts qu'on avait mis dans des dossiers particuliers de la configuration de GIMP 2.8 ?


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#10 Le 15/06/2018, à 17:32

moko138

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Piteur a écrit :

la désinstallation de la version 2.8 se fait par sudo apt-get autoremove gimp ?

NON, tu fais bien de poser la question !

Cette erreur ne suffit pas à créer une catastrophe, mais
elle peut y contribuer !     Donc,


/!\  Soit tu confies au système le choix automatique des paquets périmés à désinstaller,
et tu emploies    autoremove    SANS nom de paquet ;

  Soit tu choisis le paquet à désinstaller, périmé ou pas,
et tu emploies remove   avec nom de paquet et   SANS "auto".


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#11 Le 15/06/2018, à 17:38

nam1962

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Attention : une appli snap n'a pas les mêmes permissions qu'une appli installée normalement.
Tu peux très bien te retrouver avec impossibilité d'accéder à ou de modifier certains fichier (pour illustrer : un thunderbird contaireurisé ne peut plus joindre une pièce venant de l'ordi).
Pour les plugins, si l'empaqueteur ne les a pas inclus, j'ai de fortes craintes que ce soit impossible.

Perso, il ne me viendrait pas à l'idée d'installer via snap ou flatpak (flatpak en fait car j'évite snap) des applications open source directement disponibles. Par contre du skype, du whatsapp, du discord, oui !


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#12 Le 15/06/2018, à 17:42

moko138

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

+1


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#13 Le 15/06/2018, à 17:49

Piteur

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

nam1962 a écrit :

Perso, il ne me viendrait pas à l'idée d'installer via snap ou flatpak (flatpak en fait car j'évite snap) des applications open source directement disponibles. Par contre du skype, du whatsapp, du discord, oui !

Sauf que GIMP 2.10 n'est pas disponible en DEB pour Xubuntu 16.04 LTS, ou je ne l'ai pas localisé... Je n'ai accès qu'à la version 2.8.22. D'où snap...


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#14 Le 15/06/2018, à 17:51

f.x0

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Pour les plugins regardes ici


SOPI

Hors ligne

#15 Le 15/06/2018, à 19:41

nam1962

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Piteur a écrit :

(...)
Sauf que GIMP 2.10 n'est pas disponible en DEB pour Xubuntu 16.04 LTS, ou je ne l'ai pas localisé... Je n'ai accès qu'à la version 2.8.22. D'où snap...


Dans tous les cas, un paquet classique en container c'est pour regarder, pas pour bosser : le lien que t'indique f.x0 est très clair : peut-être possible mais bricolo

Pourquoi ce besoin crucial ?

Si c'est vraiment crucial, bascule en 18.04 ou sur Arch et dérivées !


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#16 Le 16/06/2018, à 17:06

Piteur

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Bien compris, nam1962 ! Merci smile

C'est dommage quand même que, un peu paresseux pour "updater" Xubuntu (16.04 LTS → 18 LTS), j'en sois contraint à utiliser GIMP 2.10 sous... Windows (où l'installation et l'utilisation ne posent AUCUN problème)... Mais loin de moi l'idée d'allumer une polémique : je ne suis ni geek ni partisan d'un système ou d'un autre. La philosophie du libre me plaisant, j'ai fait l'effort de passer à (x)Ubuntu, et ai choisi une version LTS pour ne pas avoir à me préoccuper de mise à jour majeure pendant plus de 2 ans : j'ai comme l'impression, en béotien que je suis, qu'on me punit d'avoir cru ça en me faisant miroiter une version améliorée d'un des logiciels que j'aime beaucoup (GIMP), mais auquel je n'ai pas accès sans nouvel effort (mise à jour majeure)...

La paresse est-elle un vrai défaut ? big_smile


Newbie parfait avec (x)Ubuntu : soyez patient(e). Grand merci !
PC de bureau - Carte MSI B150M PRO-VDH - Core I5 6500 - Ram 16 Go - Windows 10 Famille / Xubuntu 16.04 LTS (dual boot par Grub)
Acer Aspire 5733Z - Xubuntu 18.04 LTS rétrogradé 16.04 LTS

Hors ligne

#17 Le 16/06/2018, à 18:34

nam1962

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Tout est toujours question d'investissement.
Tu payes pour l'OS, tu payes pour le protéger, tu télécharges et tu mets à jour à la main -> W$
Tu ne payes pas pour l'OS et tu fais une mise à niveau tous les 2 ans pour rester sur des versions récentes : Ubuntu
Tu ne payes pas pour l'OS qui est toujours à jour mais de temps à autres tu soulèves le capot : Manjaro


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#18 Le 16/06/2018, à 19:38

GammaDraconis

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Si vous voulez des logiciels récent sur Ubuntu dans les dépôts officiels, il faut utiliser la dernière version (18.04).
Si vous voulez avoir des logiciels récent tout en restant sur une même version d'un système sans le mettre à niveau alors Ubuntu n'est pas fait pour vous, il y a d'autres distribs linux pour ça.

Mais la version snap de Gimp ne pose pas de problème en 16.04.


PC1 perso (Xiaomi Air 13) : dualboot avec Archlinux/Xfce et Ubuntu 18.04LTS/Gnome
PC2 perso (Lenovo Legion Y520) : quadrupleboot avec Archlinux/Plasma, Ubuntu 18.10/Gnome, OpenSuSe Tumbleweed/Mate, Win10
PC3 pro : OpenSuSe Leap 15/Plasma
Besoin d'un script de post-install pour la 18.04 ? c'est ici : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#19 Le 09/07/2018, à 01:22

Coeur Noir

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

[message initial du 16/06/2018] …pour les plugins : ici j'ai un Gimp 2.10 sous 18.04 installé via .deb ( le ppa d'otto ) et je ne suis pas parvenu à y faire fonctionner des plugins que j'utilise abondamment sous Gimp 2.8 ( guide-lab et layer-fx entre autres )

De plus - même si ça a l'air de progresser - la qualité actuelle des filtres par défaut sous 2.10 laisse à désirer en comparaison des résultats obtenus avec les mêmes « fonctions » sous 2.8 voir https://forum.ubuntu-fr.org/viewtopic.php?id=2025818

À cause de ces 2 gros écueils pour l'instant, dans un contexte de production / boulot, je conseillerais de rester sous 2.8 encore une bonne année…

[edit] bon je corrige sur un point - le plugin layer-fx qui fonctionne sous 2.8 fonctionne aussi sous 2.10. Je sèche toujours pour guide-lab…

Hors ligne

#20 Le 09/07/2018, à 18:19

kevlar

Re : GIMP 2.10 : l'installer sur (x)Ubuntu 16.04 ?

Bonsoir.
J'utilise Gimp 2.8 en production, mais à titre d'essai, j'ai installé la version 2.10 en paquet ... appimage, et c'est fonctionnel, et je en suis qu'en 14.04 ...
Je n'ai pas été pousser les tests pour les plugins, mais c'est jouable. Appimage est le 3e système de paquets avec Flatpack et Snap. L'installation est, par certains côté, entre Mac et Windows, dans le sens où l'on télécharge le paquet "à la main" on le rend exécutable, et on le lance lui-même par double-clic.
Si çà peut aider ...

Hors ligne