Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/05/2018, à 14:09

gen2

Ni gdm3 ni lightdm ne fonctionnent

Bonjour

après la mise à niveau 18.04 LTS plus rien ne fonctionne

GDM3 restait bloqué à "started gnome display manager" alors en regardant sur internet j'ai tenté pas mal de trucs : réparer les paquets cassés avec recovery, toujours pareil, puis réinstaller gdm3 avec une console (Ctrl+alt+F2). De là l'écran avec le login apparu mais je sais pas pourquoi je devais rentrer mon mot de passe 2 fois d'affilés.. avant d'avoir le droit à un écran totalement noir. Et désormais ça reste bloqué sur la page de login, lorsque je rentre mon mot de passe ça fait comme une loop et ça revient ici comme si je ne l'avais pas entré : http://image.noelshack.com/fichiers/201 … g-0658.jpg , je peux rentrer mon mot de passe une infinité de fois qu'il ne se passera rien


J'ai tenté d'installer lightdm avec une console et tenter de boot dessus... (en faisant sudo lightdm ou en faisant sudo dkgp-reconfigure lightdm puis reboot) mais lightdm ne m'a jamais rien renvoyé à part un.. écran noir et un curseur blanc qui clignote : http://image.noelshack.com/fichiers/201 … g-0664.jpg

Lorsque je tente de faire startx dans une console : http://image.noelshack.com/fichiers/201 … titare.png + http://image.noelshack.com/fichiers/201 … g-0657.jpg

Une idée ?

Hors ligne

#2 Le 06/05/2018, à 14:57

LukePerp

Re : Ni gdm3 ni lightdm ne fonctionnent

Bonjour, je crois que tu l'as déjà fait, bien que c'est mal expliqué, mais peux tu démarrer ton système et nous donner le retour complet de :

sudo apt update && sudo dpkg --configure -a && sudo apt install -fy && sudo apt autoremove --purge -y && sudo apt-get install lightdm -y && sudo dpkg-reconfigure lightdm

puis redémarres

Dernière modification par LukePerp (Le 06/05/2018, à 14:58)


Desktop : Ubuntu Mate 18.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Laptop de 1993 : Lubuntu 14.04 - Pentium M - 432 Mo
Regardez ces thèmes pour Linux : ici

En ligne

#3 Le 06/05/2018, à 15:15

gen2

Re : Ni gdm3 ni lightdm ne fonctionnent

Bien sûr, voilà : http://image.noelshack.com/fichiers/201 … g-0674.jpg

Je mets juste le "sudo dpkg-reconfigure lightdm" à part car ça m'efface ce qui est affiché : http://image.noelshack.com/fichiers/201 … g-0675.jpg

Rien d'anormal on dirait ?

Par ailleurs j'ai l'impression que ce problème est similaire au mien https://forum.ubuntu-fr.org/viewtopic.php?id=963731

Hors ligne

#4 Le 06/05/2018, à 15:27

LukePerp

Re : Ni gdm3 ni lightdm ne fonctionnent

des pistes ici :
https://askubuntu.com/questions/641642/ … art/641961
essaye celle concernant xserver xorg


Desktop : Ubuntu Mate 18.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop ASUS : Ubuntu Mate 16.04 - Intel i3 - 4 Go
Laptop de 1993 : Lubuntu 14.04 - Pentium M - 432 Mo
Regardez ces thèmes pour Linux : ici

En ligne

#5 Le 06/05/2018, à 16:15

gen2

Re : Ni gdm3 ni lightdm ne fonctionnent

Ok c'est résolu

Après avoir consulté le log : sudo less (blabla)/xorg/Xorg.0.log

https://image.noelshack.com/fichiers/20 … g-0676.jpg
https://image.noelshack.com/fichiers/20 … g-0677.jpg
https://image.noelshack.com/fichiers/20 … g-0678.jpg
https://image.noelshack.com/fichiers/20 … g-0679.jpg

j'ai repéré quelques lignes qui disent qu'il manque le module nvidia ce qui m'a mis la puce à l'oreille

ayant une geforce-gt-630m j'ai lancé
sudo apt-get install nvidia-352 (après coup j'ai aussi fait sudo ubuntu-drivers autoinstall)

Après avoir reboot ça marche.. même si d'emblé ça m'a mis que "ubuntu a rencontré un problème... machin Xorg (signaler le problème)"

Voilà

Hors ligne