Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/04/2018, à 09:16

Jarodd

[Résolu] Monter le NAS au démarrage

Bonjour,

J'ai un NAS Synology, et j'aimerais qu'il soit monté automatiquement au démarrage d'Ubuntu (16.04). Or actuellement cela ne se fait pas automatiquement, j'ai bien le NAS qui apparaît dans Nemo (section Réseau) mais quand je clique dessus, j'ai l'erreur "error 13 (Permission denied) opening credential file /root/.smbcredentials".

Le fichier /root/.smbcredentials :

$ sudo ls -alt /root/.smbcredentials
[sudo] Mot de passe de jarodd : 
-rw-r--r-- 1 root root 32 mars   4 20:36 /root/.smbcredentials

Avec ce contenu :

username=xxx
password=xxx

Je tente le montage auto avec cette ligne dans /etc/fstab (copiée depuis la doc Ubuntu) :

//192.168.1.100/Disque   /media/jarodd/nas  cifs    credentials=/root/.smbcredentials,rw,iocharset=utf8,gid=1000,uid=1000,file_mode=0777,dir_mode=0777,_netdev,user,auto 0	0

Le NAS est bien connecté, les logins sont bons, je m'y connecte déjà manuellement par un raccourci SFTP créée dans Nemo.

Sur un vieux sujet, il est indiqué que le problème vient de /root, qui est en 700. Mais je n'ai pas compris si je devais les changer (il me semble que non puisque /root ne doit être accessible qu'à l'utilisateur root, mais je me trompe peut-être).

Je sollicite votre aide car j'ai beau tout vérifier, je ne vois pas ce qui cloche. Merci pour vos réponses.

Edit : résolu en ajoutant "vers=1.0" en fin de ligne, et en déplaçant le fichier des identifiants dans le répertoire utilisateur au lieu de /root

//192.168.1.100/Disque   /media/jarodd/nas  cifs    credentials=/home/jarodd/.smbcredentials,rw,iocharset=utf8,gid=1000,uid=1000,file_mode=0777,dir_mode=0777,_netdev,user,auto,vers=1.0	0	0

Dernière modification par Jarodd (Le 15/04/2018, à 09:29)


16.04 LTS (32 bits + 64 bits)

Hors ligne

#2 Le 14/04/2018, à 10:07

bruno

Re : [Résolu] Monter le NAS au démarrage

Bonjour,

Tu devrais mettre ton fichier de mot de passe dans ton dossier personnel.

Hors ligne

#3 Le 14/04/2018, à 11:50

Jarodd

Re : [Résolu] Monter le NAS au démarrage

Oui peut-être, mais alors pourquoi la doc conseille de le mettre dans /root ? C'est une question de sécurité peut-être ?


16.04 LTS (32 bits + 64 bits)

Hors ligne

#4 Le 14/04/2018, à 12:00

bruno

Re : [Résolu] Monter le NAS au démarrage

Logiquement le fichier de mot de passe devrait être dans le dossier personnel de celui à qui appartient le point de montage.

La doc d'ubuntu-fr est rédigée ar des bénévoles, elle n'est pas forcément juste ni à jour.

Dernière modification par bruno (Le 14/04/2018, à 12:00)

Hors ligne

#5 Le 14/04/2018, à 12:08

Jarodd

Re : [Résolu] Monter le NAS au démarrage

J'ai déplacé le fichier et modifié le chemin dans /etc/fstab.

Ensuite quand je fais "mount -a", j'ai cette erreur :

$ sudo mount -a
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Pourtant le NAS est bien branché, et accessible (en SFTPou Samba).


16.04 LTS (32 bits + 64 bits)

Hors ligne

#6 Le 14/04/2018, à 13:20

bruno

Re : [Résolu] Monter le NAS au démarrage

Pourtant « Host is down » cela veut bien dire que 192.168.1.100 n'est pas accessible.

Tu peux aussi essayer en ligne de commande  (chemin à ajuster)

sudo mount -t cifs //192.168.1.100/Disque   /media/jarodd/nas  -o credentials=/home/toto/.smbcredentials,rw,iocharset=utf8,gid=1000,uid=1000,file_mode=0777,dir_mode=0777,_netdev,user,auto

Hors ligne

#7 Le 14/04/2018, à 15:17

Jarodd

Re : [Résolu] Monter le NAS au démarrage

Ca me redonne la même erreur, "Host is down". Pourtant j'attends le ventilo du NAS qui accélère, c'est bien qu'il a reçu une connexion ! Et s'il dormait, pourquoi j'y accèderait bien en SFTP ? Je viens de refaire des transferts de fichier, je n'ai pas eu d'erreur.


16.04 LTS (32 bits + 64 bits)

Hors ligne

#8 Le 14/04/2018, à 15:53

bruno

Re : [Résolu] Monter le NAS au démarrage

Retour de :

ping -c 3 192.168.1.100

Hors ligne

#9 Le 14/04/2018, à 16:15

Jarodd

Re : [Résolu] Monter le NAS au démarrage

$ ping -c 3 192.168.1.100
PING 192.168.1.100 (192.168.1.100) 56(84) bytes of data.
64 bytes from 192.168.1.100: icmp_seq=1 ttl=64 time=5.70 ms
64 bytes from 192.168.1.100: icmp_seq=2 ttl=64 time=0.185 ms
64 bytes from 192.168.1.100: icmp_seq=3 ttl=64 time=0.191 ms

--- 192.168.1.100 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2011ms
rtt min/avg/max/mdev = 0.185/2.028/5.708/2.602 ms

16.04 LTS (32 bits + 64 bits)

Hors ligne

#10 Le 14/04/2018, à 16:39

bruno

Re : [Résolu] Monter le NAS au démarrage

Bon c'est bien la bonne adresse IP wink

C'est peut-être un problème de version avec le protocole SMB. Essaie en ajoutant aux options de montage vers=1.0

sudo mount -t cifs //192.168.1.100/Disque   /media/jarodd/nas  -o credentials=/home/toto/.smbcredentials,rw,iocharset=utf8,gid=1000,uid=1000,file_mode=0777,dir_mode=0777,_netdev,user,auto,vers=1.0

Hors ligne

#11 Le 14/04/2018, à 17:11

Jarodd

Re : [Résolu] Monter le NAS au démarrage

Avec vers=1.0, je n'ai pas eu d'erreur avec la commande, et le raccourci Réseau est bien fonctionnel !

Je teste avec /etc/fstab pour voir si cela fonctionne aussi au démarrage.

Merci bruno !

Edit :
Dans /etc/fstab, j'ai "  0  0" à la fin de la ligne. Faut-il que je les enlève ? (en plus d'ajouter le vers=1.0)

Dernière modification par Jarodd (Le 14/04/2018, à 17:13)


16.04 LTS (32 bits + 64 bits)

Hors ligne

#12 Le 15/04/2018, à 08:43

bruno

Re : [Résolu] Monter le NAS au démarrage

Non il faut les laisser (cf man fstab 5° et 6° champs).

Hors ligne

#13 Le 15/04/2018, à 09:27

Jarodd

Re : [Résolu] Monter le NAS au démarrage

Très bien je te remercie !


16.04 LTS (32 bits + 64 bits)

Hors ligne

#14 Le 15/04/2018, à 09:53

??

Re : [Résolu] Monter le NAS au démarrage

Jarodd a écrit :

Oui peut-être, mais alors pourquoi la doc conseille de le mettre dans /root ? C'est une question de sécurité peut-être ?

Bonjour.

Tu pourrais faire un ajout dans la doc que tu as lue pour indiquer comment tu as fais


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic

Hors ligne

#15 Le 15/04/2018, à 10:23

Jarodd

Re : [Résolu] Monter le NAS au démarrage

Je dois mettre quoi exactement ? De placer le fichier dans le répertoire utilisateur plutôt que /root ? Je ne sais pas pourquoi c'était conseillé de le mettre dans /root. Je ne me sens pas très légitime pour changer la doc... hmm


16.04 LTS (32 bits + 64 bits)

Hors ligne