Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/04/2018, à 16:30

Skrachen

[Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Bonjour,

Je me suis retrouvé il n'y a pas longtemps avec ma partition système de 23 Go pleine. Après avoir regardé les différents dossiers dans cette partition, il se trouve que /usr et /var avaient une taille anormalement grande.
D'après ce que j'ai compris il faut éviter de toucher à /usr (qui fait quand même 12,4 Go chez moi), donc j'ai regardé dans /var, où j'avais un dossier /var/log très lourd. J'ai nettoyé le dossier en supprimant les anciens logs, mais j'aimerais éviter que ces fichiers se remettent à grossir (kern.log et syslog faisaient plusieurs Go).

Du coup j'ai regardé le contenu de ces fichiers, les deux contiennent une majorité de lignes identiques à celle-ci:

rtlwifi:rtl_op_ampdu_action():<0-0> IEEE80211_AMPDU_ERR!!!!:

et qui sont émises à la suite avec un intervalle de quelques secondes.

J'aimerais bien savoir:
1) Ce que signifie ce message d'erreur
2) Comment empêcher ce message d'être émis et de me bouffer de l'espace disque


Je précise que mon wifi fonctionne très bien.
Ma carte réseau est une Realtek RTL8723be avec un pilote trouvé ici

Dernière modification par Skrachen (Le 08/04/2018, à 17:19)

Hors ligne

#2 Le 06/04/2018, à 16:45

xubu1957

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Bonjour,

Ta carte wifi RTL8723BE a une ou deux antennes ?

Voir > [Résolu] WIFI RTL8723BE à nouveau très faible

_ _ _

Montre :

modinfo 8723be | grep -i version

et :

iw dev
on 16 Feb, lwfinger a écrit :

 
That Ubuntu link looks to to be what I have been telling you to do. As to setting debug options, I would not know what to debug. That is mainly for the Realtek experts.
Ce lien Ubuntu semble être ce que je vous ai dit de faire. En ce qui concerne les options de débogage, je ne saurais pas quoi déboguer. C'est principalement pour les experts de Realtek.
That AMPDU_ERR indicates that you are getting a faulty ampdu action command from upstream. I have never seen that one.
AMPDU_ERR indique que vous obtenez une commande d'action ampdu défectueuse en amont. Je n'ai jamais vu celui-là.
Just to verify that the scans are looking at the correct device, pleas post the results for 'iw dev'.
Juste pour vérifier que les scans regardent le bon appareil, veuillez afficher les résultats pour'iw dev'.

lwfinger/rtlwifi_new/issues/317  Low speed on RTL8723BE

_ _ _

#7, on 2018-03-18, actionparsnip a écrit :

   
Not BIOS, kernel. Sorry
Pas le BIOS, le noyau. Désolé

dans > answers.launchpad.net/ubuntu/+question/665874

Dernière modification par xubu1957 (Le 06/04/2018, à 17:22)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne

#3 Le 06/04/2018, à 17:18

Skrachen

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Elle est censée en avoir 2 au niveau logiciel il me semble, mais j'ai démonté mon PC une fois et je n'avais vu qu'un fil sortant du composant avec les antennes (après je m'y connais pas trop en hardware ^^' ).
J'avais déjà eu un problème de wifi très faible que j'avais réglé en changeant l'antenne sélectionnée. En ce moment dans mon fichier rtl8723be.conf, j'ai l'option ant_sel=2 et le wifi fonctionne correctement (à part qu'il génère cette erreur dans les logs).

Voilà le résultat des 2 commandes

chataignon@chataignon-HP-Notebook:~$ modinfo 8723be | grep -i version
modinfo: ERROR: Module 8723be not found.
chataignon@chataignon-HP-Notebook:~$ iw dev
phy#0
        Interface wlo1
                ifindex 3
                wdev 0x1
                addr 54:8c:a0:7e:fa:8d
                type managed
                channel 11 (2462 MHz), width: 20 MHz, center1: 2462 MHz
chataignon@chataignon-HP-Notebook:~$ 

Hors ligne

#4 Le 06/04/2018, à 17:24

xubu1957

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

J'ai édité mon message #2.

Fournis aussi le noyau actif :

uname -a

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne

#5 Le 06/04/2018, à 17:25

Skrachen

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

chataignon@chataignon-HP-Notebook:~$ uname -a
Linux chataignon-HP-Notebook 4.4.0-119-generic #143-Ubuntu SMP Mon Apr 2 16:08:24 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
chataignon@chataignon-HP-Notebook:~$ 

Hors ligne

#6 Le 06/04/2018, à 17:32

xubu1957

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Dans un autre message :

le 21/02/2018, Larry Finger a écrit :

The RTL8723BE NIC was not well supported in kernel 4.4.0. That is the reason I told you to update to 4.15.3, where the support is much better.

La carte réseau RTL8723BE n'était pas bien prise en charge dans le noyau 4.4.0. C'est la raison pour laquelle je vous ai dit de mettre à jour en 4.15.3, où le support est beaucoup mieux.

Question subsidiaire, tu te sers du Bluetooth ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne

#7 Le 06/04/2018, à 17:38

Skrachen

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Je ne m'en sers quasiment jamais, pourquoi?

Si j'ai bien compris, mettre le noyau à jour pourrait régler le problème?

Hors ligne

#8 Le 06/04/2018, à 17:44

xubu1957

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Nous avons une discussion sur le Bluetooth pour la carte RTL8723BE et un passage sur un noyau 4.14.5 > bluetooth très instable ubuntu 16.04

géré par Naziel, qui possède cette carte.

Il faudrait tester.

Pour les logs, j'y connais rien.

_ _ _

Il y avait eu cette discussion >
[RÉSOLU] Fichier SYSLOG : Problème WIFI pour une carte wifi Ralink.

Dernière modification par xubu1957 (Le 06/04/2018, à 18:35)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne

#9 Le 06/04/2018, à 21:27

Naziel

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Bonjour,

Tu peux donner les messages qui se répètent? J'ai trouvé https://ubuntuforums.org/showthread.php?t=2188067 sur lequel il y a plus de messages que rtlwifi:rtl_op_ampdu_action():<0-0> IEEE80211_AMPDU_ERR!!!!: , donc s'il y en a d'autres, tu peux les donner.
Tu peux donner

cat /etc/modprobe.d/rtl8723be.conf

afin de savoir exactement les paramètres utilisés.

Le bluetooth fonctionne chez toi?

Dernière modification par Naziel (Le 06/04/2018, à 21:27)

Hors ligne

#10 Le 06/04/2018, à 21:34

metalux

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Bonsoir,
J'ai eu le même problème, après différent test j'ai résolu le problème: https://forum.ubuntu-fr.org/viewtopic.p … #p21573542
A tester.

Hors ligne

#11 Le 06/04/2018, à 22:20

Skrachen

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Le wifi et le bluetooth fonctionnent parfaitement.

Le fichier config:

chataignon@chataignon-HP-Notebook:~$ cat /etc/modprobe.d/rtl8723be.conf
options rtl8723be fwlps=N ips=N ant_sel=2

C'est toujours la même erreur qui s'affiche, sauf quand je coupe le wifi, auquel cas on a
le résultat de la commande tail sur syslog:

chataignon@chataignon-HP-Notebook:~$ tail /var/log/syslog
Apr  6 22:12:39 chataignon-HP-Notebook kernel: [  805.712785] rtlwifi:rtl_op_ampdu_action():<0-0> IEEE80211_AMPDU_ERR!!!!:
Apr  6 22:12:45 chataignon-HP-Notebook kernel: [  812.401894] rtlwifi:rtl_op_ampdu_action():<0-0> IEEE80211_AMPDU_ERR!!!!:
Apr  6 22:12:49 chataignon-HP-Notebook kernel: [  815.753380] rtlwifi:rtl_op_ampdu_action():<0-0> IEEE80211_AMPDU_ERR!!!!:
Apr  6 22:12:57 chataignon-HP-Notebook kernel: [  823.750309] rtlwifi:rtl_op_ampdu_action():<0-0> IEEE80211_AMPDU_ERR!!!!:
Apr  6 22:13:06 chataignon-HP-Notebook kernel: [  832.517669] rtlwifi:rtl_op_ampdu_action():<0-0> IEEE80211_AMPDU_ERR!!!!:
Apr  6 22:14:05 chataignon-HP-Notebook systemd-timesyncd[709]: Timed out waiting for reply from 91.189.89.198:123 (ntp.ubuntu.com).
Apr  6 22:14:05 chataignon-HP-Notebook systemd-timesyncd[709]: Synchronized to time server 91.189.91.157:123 (ntp.ubuntu.com).
Apr  6 22:14:16 chataignon-HP-Notebook systemd[1]: Starting Cleanup of Temporary Directories...
Apr  6 22:14:16 chataignon-HP-Notebook systemd-tmpfiles[4941]: [/usr/lib/tmpfiles.d/var.conf:14] Duplicate line for path "/var/log", ignoring.
Apr  6 22:14:16 chataignon-HP-Notebook systemd[1]: Started Cleanup of Temporary Directories.
 

Sinon entre temps, après un redémarrage mes fichiers de logs se sont mis à exploser avec la ligne "PCIe Bus error severity=Corrected", mais j'ai réglé le problème (ici). Ca n'a apparemment rien à voir mais ca affectait les mêmes fichiers.

Dernière modification par Skrachen (Le 06/04/2018, à 22:23)

Hors ligne

#12 Le 06/04/2018, à 22:27

metalux

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

options rtl8723be fwlps=N ips=N ant_sel=2

As-tu lu le lien que je t'ai indiqué? Il faut ajouter msi=1 comme option.

Hors ligne

#13 Le 06/04/2018, à 22:42

Skrachen

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Metalux j'ai essayé, après redémarrage ca ne marche toujours pas...

Hors ligne

#14 Le 06/04/2018, à 22:48

metalux

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Comment as-tu ajouté l'option?
Le résultat de cat /etc/modprobe.d/rtl8723be.conf ne la faisait pas apparaître, mais peut-être l'as-tu posté après avoir retiré l'option d'où mon interrogation.
Si tu doutes, donne moi le résultat de systool -v -m rtl8723be après avoir ajouté l'option et relancé le module (ou redémarrage, ça revient au même).

Dernière modification par metalux (Le 06/04/2018, à 22:50)

Hors ligne

#15 Le 06/04/2018, à 22:50

Skrachen

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Oui je l'ai ajoutée après, là j'ai bien

chataignon@chataignon-HP-Notebook:~$ cat /etc/modprobe.d/rtl8723be.conf
options rtl8723be fwlps=N ips=N ant_sel=2 msi=1

Hors ligne

#16 Le 06/04/2018, à 23:00

metalux

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

.....alors tente l'upgrade du noyau

Hors ligne

#17 Le 07/04/2018, à 11:11

Skrachen

Re : [Résolu]Une erreur wifi génère une très (trop) grande quantité de logs

Je l'ai fait ce matin, ça a l'air de fonctionner je n'ai plus d'erreur de wifi dans les logs. Je vais surveiller ça les prochains jours pour vérifier que ça ne recommence pas, avant de passer le sujet en résolu...

En tout cas merci à vous tous smile

Dernière modification par Skrachen (Le 07/04/2018, à 11:12)

Hors ligne