Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 26/02/2018, à 19:42

GammaDraconis

Re : [Résolu] Stellarium sous Ubuntu

Il n'y a aucun soucis pour installer Stellarium ! aucun ! tout fonctionne très bien, si vous avez un soucis, c'est entre la chaise et le clavier !

La preuve en capture vidéo (télecharger si le stream direct ne fonctionne pas) : https://framadrive.org/s/CA79Jft4jKka8RS


PC1 (Xiaomi Air 13) : dualboot avec Ubuntu 18.04LTS/Gnome et ArchLinux/Xfce (rolling)
PC2 (Lenovo Legion Y520) : quadrupleboot avec ArchLinux/Plasma, Ubuntu 18.04LTS/Gnome, OpenSuSe Tumbleweed/Plasma (rolling), win10
Besoin d'un script de post-install pour la 18.04 ? c'est ici : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#27 Le 27/02/2018, à 00:11

Philke

Re : [Résolu] Stellarium sous Ubuntu

J'ai suivi votre procédure et cela ne fonctionne pas non pas à cause de Ubuntu, ni de l'individu qui est assis sur la chaise mais bien d'une configuration matérielle de ma bécane. Il vous suffit de lire ci-après:

philke@philke-Aspire-7736:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.4 LTS
Release:	16.04
Codename:	xenial
philke@philke-Aspire-7736:~$ sudo apt install stellarium
[sudo] Mot de passe de philke : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants vont être installés :
  stellarium-data
Les NOUVEAUX paquets suivants seront installés :
  stellarium stellarium-data
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/105 Mo dans les archives.
Après cette opération, 164 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Sélection du paquet stellarium-data précédemment désélectionné.
(Lecture de la base de données... 227636 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../stellarium-data_0.14.3-1_all.deb ...
Dépaquetage de stellarium-data (0.14.3-1) ...
Sélection du paquet stellarium précédemment désélectionné.
Préparation du dépaquetage de .../stellarium_0.14.3-1_amd64.deb ...
Dépaquetage de stellarium (0.14.3-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5.1) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Paramétrage de stellarium-data (0.14.3-1) ...
Paramétrage de stellarium (0.14.3-1) ...
philke@philke-Aspire-7736:~$ stellarium
 -------------------------------------------------------
[ This is Stellarium 0.14.3 - http://www.stellarium.org ]
[ Copyright (C) 2000-2016 Fabien Chereau et al.         ]
 -------------------------------------------------------
Writing log file to: "/home/philke/.stellarium/log.txt"
File search paths:
  0 .  "/home/philke/.stellarium"
  1 .  "/usr/share/stellarium"
Config file is:  "/home/philke/.stellarium/config.ini"
Detected: OpenGL "2.1"
Driver version string: "2.1 Mesa 17.2.8"
GL vendor is "Intel Open Source Technology Center"
GL renderer is "Mesa DRI Mobile Intel® GM45 Express Chipset "
GL Shading Language version is "1.20"
MESA Version Number detected:  17.2
Mesa version is fine, we should not see a graphics problem.
GLSL Version Number detected:  1.2
This is not enough: we need GLSL1.30 or later.
You should update graphics drivers, graphics hardware, or use the --mesa-mode option.
Else, please try to use an older version like 0.12.5, and try there with --safe-mode
You can try to run in an unsupported degraded mode by ignoring the warning and continuing.
But more than likely problems will persist.
Aborting due to OpenGL/GLSL version problems.
Erreur de segmentation (core dumped)
philke@philke-Aspire-7736:~$ 

Hors ligne

#28 Le 27/02/2018, à 09:59

cqfd93

Re : [Résolu] Stellarium sous Ubuntu

Bonjour,

Tu as essayé de le lancer avec l'option --safe-mode ?

stellarium --safe-mode

cqfd93

En ligne

#29 Le 27/02/2018, à 12:17

Philke

Re : [Résolu] Stellarium sous Ubuntu

Bonjour,

Oui bien sûr mais rien n'y fait. Je n'ai pas le bon OpenGL.

1519726515.png

1519726825.png

Dernière modification par Philke (Le 27/02/2018, à 12:21)

Hors ligne

#30 Le 27/02/2018, à 16:19

ylag

Re : [Résolu] Stellarium sous Ubuntu

Salut,

Pourrais-tu donner le retour de :

glxinfo | grep OpenGL

...ainsi que de :

dpkg -l | grep -v ^ii

A+

Hors ligne

#31 Le 28/02/2018, à 15:10

ylag

Re : [Résolu] Stellarium sous Ubuntu

Salut,

Peut-être tenter d'utiliser ce ppa (qui me semble maintenu de façon sérieuse): https://launchpad.net/~oibaf/+archive/u … ter=xenial

Voir cette discussion (en anglais, par contre...) :
https://ubuntu-mate.community/t/stellar … 6-04/13112

Pour ce faire :

sudo add-apt-repository ppa:oibaf/graphics-drivers

...suivi de:

sudo apt update

...et de :

sudo apt full-upgrade

Redémarrer et tenter de lancer stellarium.

A+

Dernière modification par ylag (Le 02/08/2018, à 15:13)

Hors ligne

#32 Le 01/08/2018, à 19:29

Philke

Re : [Résolu] Stellarium sous Ubuntu

Comme j'ai changé de portable avec une carte graphique plus récente, Stellarium fonctionne maintenant parfaitement.

Hors ligne