Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

Heure d'hiver: N'oubliez pas de décochez l'heure d'été dans votre profil.

#1 Le 27/01/2018, à 19:19

jjaaccqquueess

[RESOLU??] l'impression sous libreOffice plante instantanément mon ord

bonjour,

depuis ce matin, l'impression d'un document sur libreOffice Writer fait planter directement ma session
je me retrouve sur la page de connexion de Kubuntu et il faut que je reboote complètement, car il n'accepte pas mon mot de passe...


Kubuntu 14.04.5 LTS
libreOffice Version: 4.2.8.2
Build ID: 420m0(Build:2)

une idée??

merci

Dernière modification par jjaaccqquueess (Le 10/11/2018, à 15:40)

Hors ligne

#2 Le 28/01/2018, à 22:07

michcauch

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

Bonsoir,
L'impression du même document ou de tout document ?
Dans tous les cas tu peux renommer le dossier de configuration de libreoffice et relancer libreoffice.
Cette méthode résout de nombreux problèmes avec libreoffice.


Cordialement
Michel
___
Ubuntu 18.04 sur Lenovo ThinkPad Edge E320 et Xubuntu 16.04 sur Ordinateur de bureau Materiel.net Elite (Processeur Intel Core i3 6100, Intel HD Graphics, SSD 120 Go, 4 Go DDR4)

Hors ligne

#3 Le 31/01/2018, à 19:08

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

bonsoir et merci,

justement, je me demandais :
j'ai complètement purgé libreOffice (desinstallation complète) puis reinstallation, pensant que ça allait résoudre le problème.
ça ne l'a pas résolu, et j'ai bien vu qu'il y avait aussi un lien avec l'installation précédente (certainement ces fichiers de configuration, par exemple il y avait toujours l'historique des documents récents)
d'où ma question :
est-ce bien ce qu'il y a dans ~/.config/libreoffice ?
puis-je les supprimer complètement?
et re-installer libreoffice, pour en recréer?
quelle la solution la plus simple? et la meilleure?

merci
jacques

Hors ligne

#4 Le 01/02/2018, à 09:32

michcauch

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

Bonjour,
Purger ne supprime pas les dossiers de configuration personnels mais tout ce qui est lié à l'installation.

est-ce bien ce qu'il y a dans ~/.config/libreoffice ?

Oui c'est bien ~/.config/libreoffice.

puis-je les supprimer complètement?

Oui/non
- oui si tu n'as rien à récupérer.
- non si tu as modifié/créé les dictionnaires, les autotextes, les modéles et les autocorrections d'une part et qui sont récupérables (~/.config/libreoffice contient aussi les raccourcis claviers personnels, l'organisation des barre d'outils, les extensions installées par toi pour toi, mais ça c'est difficilement récupérable).

Ferme LibreOffice.
Si tu n'as rien à récupérer tu supprimes le dossier libreoffice de ~/.config puis tu ouvres LibreOffice, il s'en créera un tout neuf tout seul.
Si tu as des éléments à récupérer de ~/.config/libreoffice tu le renommes et tu ouvres LibreOffice, il s'en créera un tout neuf tout seul.


Cordialement
Michel
___
Ubuntu 18.04 sur Lenovo ThinkPad Edge E320 et Xubuntu 16.04 sur Ordinateur de bureau Materiel.net Elite (Processeur Intel Core i3 6100, Intel HD Graphics, SSD 120 Go, 4 Go DDR4)

Hors ligne

#5 Le 01/02/2018, à 16:13

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

merci encore,
mais en fait j'ai résolu le problème :
j'avais changé de police sur plusieurs textes, et  c'est probablement le changement de police qui a fichu le bazar : attention donc (peut-être) à la police gargi.
pourtant, j'ai refait un essai ensuite en créant un nouveau texte uniquement en gargi, et il n'y a pas eu de souci.
je n'ai donc pas eu à supprimer les config.

merci
jacques

Hors ligne

#6 Le 02/02/2018, à 08:30

michcauch

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

Bonjour,
Tant mieux si ton problème est résolu !
Pense, s'il te plaît, à ajouter [RÉSOLU] au titre du fil en modifiant ton premier message.


Cordialement
Michel
___
Ubuntu 18.04 sur Lenovo ThinkPad Edge E320 et Xubuntu 16.04 sur Ordinateur de bureau Materiel.net Elite (Processeur Intel Core i3 6100, Intel HD Graphics, SSD 120 Go, 4 Go DDR4)

Hors ligne

#7 Le 31/03/2018, à 14:17

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

bonjour à tous,

finalement, mon problème n'est toujours pas résolu :

parfois (et je ne sais pas ce qui déclenche ce phénomène) l'impression d'un document libre-office par CTRL P ou par le menu "imprimer" ferme brutalement ma session, me met sur l'écran de connexion, avec en plus le clavier en qwerty (ce qui explique que je croyais qu'il ne reconnaissait pas mon mot de passe, comme je l'explique dans le post n°1)

que se passe-t-il donc?

merci de votre aide

Hors ligne

#8 Le 02/04/2018, à 17:11

corrigo

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

Salut.

Essaye sur une version plus récente de LibreOffice, ça a peut-être été corrigé depuis.

Tente déjà avec une version appimage qui n'installe rien sur ton ordinateur: https://doc.ubuntu-fr.org/libreoffice#a … t_appimage

Si c'est bon, installe en dur dans ton système via le PPA de la branche qui t'intéresse : https://doc.ubuntu-fr.org/libreoffice#avec_les_ppa

Hors ligne

#9 Le 02/04/2018, à 17:25

PPdM

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

Quelle version de libre office et comment tu l'a installé?

Hors ligne

#10 Le 08/09/2018, à 16:47

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

bonjour,

j'ai de nouveau ce phénomène étrange :

quand j'essaye d'imprimer par CTRL+P ou par le menu Fichier - Imprimer sous libre office
cela déconnecte ma session immédiatement.
je me retrouve sur l'écran de connexion, et je dois démarrer une nouvelle session.
je suis allé voir le journal du système, et au moment de l'évènement, il se passe ceci :

08/09/2018 17:38:51	kub	kernel	[ 9059.088213] soffice.bin[8704]: segfault at 605f1200 ip 00007f3b5c35510d sp 00007ffee27b6120 error 4 in libc-2.19.so[7f3b5c319000+1be000]
08/09/2018 17:38:51	kub	colord	Automatic remove of icc-bc00686d1ac24d88ab11acd161251be4 from xrandr-Philips Consumer Electronics Company-Philips 224C-UHB104700506
08/09/2018 17:38:51	kub	colord	Profile removed: icc-bc00686d1ac24d88ab11acd161251be4
08/09/2018 17:38:51	kub	colord	Profile removed: icc-9d61dda9c35e487e05382f97f22c8ea2
08/09/2018 17:38:51	kub	colord	device removed: xrandr-Philips Consumer Electronics Company-Philips 224C-UHB104700506
08/09/2018 17:38:51	kub	acpid	client 4478[0:0] has disconnected
08/09/2018 17:38:51	kub	acpid	client connected from 8862[0:0]
08/09/2018 17:38:51	kub	acpid	1 client rule loaded
08/09/2018 17:39:07	kub	colord	Profile added: icc-bc00686d1ac24d88ab11acd161251be4
08/09/2018 17:39:07	kub	colord	Profile added: icc-9d61dda9c35e487e05382f97f22c8ea2
08/09/2018 17:39:07	kub	colord	Device added: xrandr-Philips Consumer Electronics Company-Philips 224C-UHB104700506
08/09/2018 17:39:08	kub	dbus[637]	[system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
08/09/2018 17:39:08	kub	org.kde.powerdevil.backlighthelper	QDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.
08/09/2018 17:39:08	kub	dbus[637]	[system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
08/09/2018 17:39:10	kub	rtkit-daemon[1876]	Successfully made thread 9254 of process 9254 (n/a) owned by '1000' high priority at nice level -11.
08/09/2018 17:39:10	kub	rtkit-daemon[1876]	Supervising 1 threads of 1 processes of 1 users.
08/09/2018 17:39:10	kub	rtkit-daemon[1876]	Successfully made thread 9291 of process 9254 (n/a) owned by '1000' RT at priority 5.
08/09/2018 17:39:10	kub	rtkit-daemon[1876]	Supervising 2 threads of 1 processes of 1 users.
08/09/2018 17:39:10	kub	rtkit-daemon[1876]	Successfully made thread 9292 of process 9254 (n/a) owned by '1000' RT at priority 5.
08/09/2018 17:39:10	kub	rtkit-daemon[1876]	Supervising 3 threads of 1 processes of 1 users.
08/09/2018 17:39:10	kub	rtkit-daemon[1876]	Successfully made thread 9294 of process 9294 (n/a) owned by '1000' high priority at nice level -11.
08/09/2018 17:39:10	kub	rtkit-daemon[1876]	Supervising 4 threads of 2 processes of 1 users.
08/09/2018 17:39:10	kub	pulseaudio[9294]	[pulseaudio] pid.c: Daemon already running.
08/09/2018 17:39:10	kub	rtkit-daemon[1876]	Successfully made thread 9298 of process 9298 (n/a) owned by '1000' high priority at nice level -11.
08/09/2018 17:39:10	kub	rtkit-daemon[1876]	Supervising 4 threads of 2 processes of 1 users.
08/09/2018 17:39:10	kub	pulseaudio[9298]	[pulseaudio] pid.c: Daemon already running.

je pense que la première ligne est importante, mais évidememnt je ne sais pas ce qu'elle veut dire.
sur ce journal, je me reconnecte juste après, vers 17:39:07

quelqu'un peut m'aider?
je précise que je ne sais pas si tous les fichiers sont concernés par ce "bug", je vais faire des test

merci!

Hors ligne

#11 Le 08/09/2018, à 16:52

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

re bonjour,

je viens de faire quelques essais, il semble que seulement quelques fichiers soient touchés par ce phénomène (plantage lors de l'impression) mais pas tous.
peut-être les plus gros?

merci

Hors ligne

#12 Le 08/09/2018, à 17:00

PPdM

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

commente as tu installé ton libre office ?

Hors ligne

#13 Le 08/09/2018, à 18:08

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

j'ai dû l'installer par muon ou synaptic, je ne me souviens plus bien...

Hors ligne

#14 Le 08/09/2018, à 18:18

PPdM

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

sudo add-apt-repository ppa:libreoffice/ppa
sudo apt update && sudo apt install libreoffice libreoffice-l10n-fr libreoffice-help-fr hyphen-fr libreoffice-gtk -y

Tu aura toujours la dernière version stable et sans bug de LO

Dernière modification par PPdM (Le 08/09/2018, à 18:21)

Hors ligne

#15 Le 09/09/2018, à 07:05

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

salut,

j'essaye d'ajouter le PPA et je lis

This PPA might contain the release candidate that is assumed to become the final release even before it is declared so by the Document Foundation (e.g. usually release candidate 2 for minor updates).

Most of the packages in this PPA have only experienced minor testing -- in fact it is the place to enable a wider audience to test packages before they are published into the distro proper. In general, this PPA is _not_ for the average user to install without a closer look (if it would be, its packages would be in the main repositories). OTOH, it is _way_ _better_ to use packages from this PPA than using the *.deb files that The Document Foundation provides upstream, which are intentionally build against a very old baseline for maximum compatibility. So, _if_ you want to be on the bleeding edge, do it here, not with upstream *.debs.

j'en conclus que ce PPA n'est pas pour moi, et que pour avoir une version stable et sans bugs, je préfère rester sur le dépôt principal.

Hors ligne

#16 Le 09/09/2018, à 07:46

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

re,

après avoir re-essayer de vider ma config (en renommant le fichier ~/.config/libreoffice)
le problème persiste, et en regardant de plus près dans le journal système, cette fois ci on a :

09/09/2018 08:33:39	kub	kernel	[ 3444.121793] SelectionManage[7774]: segfault at 586f62b0 ip 00007f201fe2a10d sp 00007f1ffa0a2970 error 4 in libc-2.19.so[7f201fdee000+1be000]
09/09/2018 08:33:39	kub	colord	Automatic remove of icc-bc00686d1ac24d88ab11acd161251be4 from xrandr-Philips Consumer Electronics Company-Philips 224C-UHB104700506
09/09/2018 08:33:39	kub	colord	Profile removed: icc-bc00686d1ac24d88ab11acd161251be4
09/09/2018 08:33:39	kub	colord	Profile removed: icc-9d61dda9c35e487e05382f97f22c8ea2
09/09/2018 08:33:39	kub	colord	device removed: xrandr-Philips Consumer Electronics Company-Philips 224C-UHB104700506
09/09/2018 08:33:39	kub	acpid	client 6381[0:0] has disconnected
09/09/2018 08:33:39	kub	acpid	client connected from 7801[0:0]
09/09/2018 08:33:39	kub	acpid	1 client rule loaded

donc plus de référence à office...

mais pourquoi il me parle de mon écran qui est bien défini comme Philips Consumer Electronics Company dans "configuration du système"?

Hors ligne

#17 Le 09/09/2018, à 08:12

JBF

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

Et si tu imprimes un gros PDF depuis Okular ça marche ?


LibreOffice : http://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://ask.libreoffice.org/fr/

Hors ligne

#18 Le 09/09/2018, à 08:15

PPdM

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

Tu a quelle versio de Ubuntu ?

Jai fait cette manip des dizaines de fois c'est la première fois que je vois ces message.

Essayes ceci

sudo apt-get purge libreoffice* && sudo apt-get install libreoffice libreoffice-nlpsolver libreoffice-help-fr libreoffice-l10n-fr

Hors ligne

#19 Le 09/09/2018, à 08:35

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

pas de souci pour l'instant avec les PDF


Kubuntu 14.04.5 LTS
libreoffice (1:4.2.8-0ubuntu5.3)

et pour le message, il faut juste le lire quand on fait

sudo add-apt-repository ppa:libreoffice/ppa

et avant d'accepter....

Hors ligne

#20 Le 09/09/2018, à 09:04

moko138

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

jjaaccqquueess a écrit :

après avoir re-essayer de vider ma config (en renommant le fichier ~/.config/libreoffice)
le problème persiste, et en regardant de plus près dans le journal système, cette fois ci on a :

09/09/2018 08:33:39	kub	kernel	[ 3444.121793] SelectionManage[7774]: segfault at 586f62b0 ip 00007f201fe2a10d sp 00007f1ffa0a2970 error 4 in libc-2.19.so[7f201fdee000+1be000]

Une "segfault", ou "erreur de segmentation", a, à ma connaissance, deux causes possibles :
  soit le logiciel est bugué - et alors, prendre une autre version présente de grandes chances de solution ;
  soit le disque est matériellement abîmé à l'endroit où le logiciel est installé.

Donc, pour la deuxième piste, montre

echo; dmesg | grep -EiC1 "sector|lba|error|inode" ; echo; echo "                ============="; sudo lsblk -o name,fstype,size,label,mountpoint | grep -Ei "/|type" 

AJOUT : c'est une suite de commandes purement descriptives ; elles ne changeront rien à ton système, mais nous renseigneront.

Dernière modification par moko138 (Le 09/09/2018, à 09:45)


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#21 Le 09/09/2018, à 11:50

PPdM

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

jjaaccqquueess a écrit :

pas de souci pour l'instant avec les PDF


Kubuntu 14.04.5 LTS
libreoffice (1:4.2.8-0ubuntu5.3)

et pour le message, il faut juste le lire quand on fait

sudo add-apt-repository ppa:libreoffice/ppa

et avant d'accepter....

Comment cela se fait il que je ne l'ai jamais vu ?
Je dois etre bigleux plus que je ne crois !! lol

Hors ligne

#22 Le 12/09/2018, à 05:02

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

voici la réponse à

echo; dmesg | grep -EiC1 "sector|lba|error|inode" ; echo; echo "                ============="; sudo lsblk -o name,fstype,size,label,mountpoint | grep -Ei "/|type"
jacques@kub:~$ echo; dmesg | grep -EiC1 "sector|lba|error|inode" ; echo; echo "                ============="; sudo lsblk -o name,fstype,size,label,mountpoint | grep -Ei "/|type"
                                                                                                                                                                                                                                                                               
[    0.022397] Dentry cache hash table entries: 1048576 (order: 11, 8388608 bytes)                                                                                                                                                                                             
[    0.023290] Inode-cache hash table entries: 524288 (order: 10, 4194304 bytes)
[    0.023673] Mount-cache hash table entries: 16384 (order: 5, 131072 bytes)                                                                                                                                                                                                  
--
[    0.834296] [drm] Driver supports precise vblank timestamp query.                                                                                                                                                                                                           
[    0.842745] i915_bpo 0000:00:02.0: Direct firmware load for i915/kbl_dmc_ver1.bin failed with error -2
[    0.842748] i915_bpo 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/intel-linux-graphics-firmwares], disabling runtime power management.                                                                                                           
--
[    1.147841] ata1.00: ATA-9: Samsung SSD 850 EVO 250GB, EMT03B6Q, max UDMA/133                                                                                                                                                                                               
[    1.147843] ata1.00: 488397168 sectors, multi 1: LBA48 NCQ (depth 31/32), AA
[    1.148353] ata2.00: ATAPI: HL-DT-ST DVDRAM GH24NSD1, LG00, max UDMA/133                                                                                                                                                                                                    
--
[    1.197711] ata3.00: ATA-8: MD03200-AVDW-RO, 11.01A11, max UDMA/133                                                                                                                                                                                                         
[    1.197713] ata3.00: 625140335 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[    1.200538] ata3.00: ACPI cmd ef/10:06:00:00:00:00 (SET FEATURES) succeeded                                                                                                                                                                                                 
--
[    2.351664] random: nonblocking pool is initialized                                                                                                                                                                                                                         
[    2.373121] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[    2.393391] systemd-udevd[373]: starting version 204                                                                                                                                                                                                                        
--
[   23.611801] usbcore: registered new interface driver usblp                                                                                                                                                                                                                  
[   32.774100] audit_printk_skb: 39 callbacks suppressed
[   32.774103] audit: type=1400 audit(1536724216.559:24): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=2677 comm="apparmor_parser"                                                                             

                =============
NAME   FSTYPE   SIZE LABEL      MOUNTPOINT
├─sda1 ext4    29,3G slash      /
├─sda2 ext4   194,6G home       /home
└─sda4 vfat       1G            /boot/efi
└─sdb1 ext3   298,1G sauvegarde /mnt/sync
jacques@kub:~$ 

Hors ligne

#23 Le 12/09/2018, à 06:30

Jérome38

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

Pour essayer de résoudre ton problème, tu pourrais aussi installer Libreoffice au format appimage
pour l'appimage c'est ici
https://www.libreoffice.org/download/appimage/
Et voir ensuite si tu arrives à imprimer avec cette version sans plantage.


Ubuntu 18.04

Hors ligne

#24 Le 08/11/2018, à 15:34

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

au secours!

ça recommence,

j'avais un fichier qui marchait bien, que je pouvais imprimer par CTRL+P , et maintenant, tout d'un coup, l'impression (par le menu fichier - imprimer ET par CTRL+P) me fait sauter ma session et me remets sur l'écran de connexion.
je suis obligé d'utiliser l'icône "impression rapide" , là, ça marche, mais plus de possibilité de paramétrer l'impression.

que faire!!

merci

Hors ligne

#25 Le 09/11/2018, à 10:25

jjaaccqquueess

Re : [RESOLU??] l'impression sous libreOffice plante instantanément mon ord

hello,

j'ai l'impression que ça a à voir avec les marges d'impression, quand on les réduit trop (parcequ'en fait c'est la seule chose que j'ai faite de particulier)
mais même si je les re-agrandis, ça plante toujours

une idée??

Hors ligne