Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 17/01/2018, à 13:10

grandtoubab

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

il peut y avoir d'autres pistes

- tu es passé en session Wayland sans t'en apercevoir et celle-ci ne fonctionne pas => avant de saisir le mot de passe utilisateur, sélectionner la session xorg

- la mise a jour a casser le driver graphique  => Ctrl +Alt +F2 puis se connecter en root et verifier

 lspci -nnk | grep -i vga -A2

Dernière modification par grandtoubab (Le 17/01/2018, à 13:39)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#27 Le 17/01/2018, à 13:19

LoïsR

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

Merci pour ces nouvelles pistes.

grandtoubab a écrit :

- tu es passé en session Wayland sans t'en apercevoir et celle-ci ne fonctionne pas => avant de saisir le mot de passe utilisateur, sélectionner la session xorg

je n'ai pas le choix de la session sur laquelle je veux me connecter dans le menu de log in.
Edit : ma version d'ubuntu utilise lightDM comme gestionnaire de session, qui, si j'ai bien compris, n'est pas compatible avec Wayland. Peut être changer de gestionnaire changera quelque chose (GDM ?) mais je ne pense pas que wayland soit installé sur ma machine.

grandtoubab a écrit :

- la mise a jour a casser le driver graphique  => Ctrl +Alt +F2 puis se connecter en root et verifier lspci --nnk

ça ne me donne rien qui ressemble à une erreur. J'ai déjà réinstallé les drivers de la carte graphique hier sans résultat.

Dernière modification par LoïsR (Le 17/01/2018, à 13:35)

Hors ligne

#28 Le 17/01/2018, à 13:21

LoïsR

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

À ce stade je commence à envisager sérieusement une réinstallation complète du système, pensez vous que ça puisse régler mon problème ?

Hors ligne

#29 Le 17/01/2018, à 13:42

grandtoubab

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

LoïsR a écrit :

À ce stade je commence à envisager sérieusement une réinstallation complète du système, pensez vous que ça puisse régler mon problème ?

c'est

 lspci -nnk | grep -i vga -A2

mais si tu dis que le driver a été réinstallé
réinstaller pourquoi pas si tu sais le faire en gardant ton /home, c'est rapide

tu peux voir si des erreurs apparaissent au boot

journalctl -xb -p err

Dernière modification par grandtoubab (Le 17/01/2018, à 13:43)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#30 Le 17/01/2018, à 14:17

LoïsR

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

grandtoubab a écrit :

c'est

lspci -nnk | grep -i vga -A2

ça donne ça :

lois_rancilhac@precision-Tower-7810:~$ lspci -nnk | grep -i vga -A2
03:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [NVS 310] [10de:107d] (rev a1)
             Subsystem: NVIDIA Corporation Device [10de:1154]
03:00.1 Audio Device [0403]: NVIDIA Corporation GF119 HDMI Audio Controller [10de:0e08] (rev a1)

tout semble en ordre non ?

grandtoubab a écrit :

tu peux voir si des erreurs apparaissent au boot

journalctl -xb -p err

Je n'ai pas Systemd (dont dépend cette commande si j'ai bien compris) installé sur ma machine (c'est installé par défaut seulement depuis 16.04), sais tu si il y a un équivalent sur 14.04 ?

Hors ligne

#31 Le 17/01/2018, à 14:31

grandtoubab

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

LoïsR a écrit :
grandtoubab a écrit :

c'est

lspci -nnk | grep -i vga -A2

ça donne ça :

lois_rancilhac@precision-Tower-7810:~$ lspci -nnk | grep -i vga -A2
03:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [NVS 310] [10de:107d] (rev a1)
             Subsystem: NVIDIA Corporation Device [10de:1154]
03:00.1 Audio Device [0403]: NVIDIA Corporation GF119 HDMI Audio Controller [10de:0e08] (rev a1)

tout semble en ordre non ?

grandtoubab a écrit :

tu peux voir si des erreurs apparaissent au boot

journalctl -xb -p err

Je n'ai pas Systemd (dont dépend cette commande si j'ai bien compris) installé sur ma machine (c'est installé par défaut seulement depuis 16.04), sais tu si il y a un équivalent sur 14.04 ?

il y a toujours  dmesg

dmesg | grep err 

ou

dmesg | grep failed

pour la carte je sais pas trop , on voit que tu as du Nvidia mais on ne voit pas précisement le driver
chez moi il apparait

lspci -nnk | grep -i vga -A2
01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250] [1002:9712]
    Subsystem: Hewlett-Packard Company RS880M [Mobility Radeon HD 4225/4250] [103c:1443]
    Kernel driver in use: radeon
--
02:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] [1002:68e0]
    Subsystem: Hewlett-Packard Company Park [Mobility Radeon HD 5430/5450/5470] [103c:1443]
    Kernel driver in use: radeon

que dit

dpkg -l | grep nvidia

Dernière modification par grandtoubab (Le 17/01/2018, à 14:41)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#32 Le 17/01/2018, à 15:01

LoïsR

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

grandtoubab a écrit :

que dit

dpkg -l | grep nvidia

lois_rancilhac@precision-Tower-7810:~$ dpkg -l | grep nvidia
ii nvidia-384                               384.111-0ubuntu0.14.04.1                        amd64           NVIDIA binary driver - version 384.111
ii nvidia-opencl-icd-384             384.111-0ubuntu0.14.04.1                        amd64            NVIDIA OpenCL ICD
ii nvida-prime                            0.6.2.1                                                       amd64            Tools to enable NVIDIA's Prime
ii nvidia-settings                        331.20-0ubuntu8                                      amd64             Tools for configuring the NVIDIA graphics driver

normalement j'ai tout mis à jour en faisant

sudo ubuntu-drivers autoinstall

Hors ligne

#33 Le 17/01/2018, à 19:49

LoïsR

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

Re-bonjour,

j'ai finalement ré-installé le système en remplacant mon ubuntu 14.04 LTS par un Xubuntu 16.04 LTS (j'ai conservé mon /home). L'installation s'est bien passée mais j'ai toujours le même problème à quelques détails près. Déjà je peux me connecter à la session invité en mode graphique (c'est déjà une avancée). Du coup j'ai essayé de refaire ça :

sudo rm .Xauthority
sudo rm .ICEauthority
sudo rm .xsession-errors*
sudo reboot

et cette fois ça a changé quelque-chose : ma session utilisateur ne s'ouvre toujours pas mais il m'affiche un message d'erreur :

Unable to load a failsafe session
Unable to determine failsafe session name. Possible cause : xfconfd isn't running (D-Bus setup problem); environment variable $XDG-CONFIG-DIRS is set incorrectly (must include "/etc"); or xfce4-session is installed incorrectly

des idées ?
faut-il que je déplace le post vers le forum XFCE maintenant ?

Hors ligne

#34 Le 17/01/2018, à 19:52

nam1962

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

Là ça semble provenir d'un souci de permissions ou de fichiers corrompus dans ton home
As-tu un message quand tu fermes le message d'erreur ?

Dernière modification par nam1962 (Le 17/01/2018, à 19:55)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#35 Le 17/01/2018, à 19:54

LoïsR

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

non rien du tout, ça m'affiche un écran noir quelques secondes puis retour à la case login

Hors ligne

#36 Le 17/01/2018, à 19:55

nam1962

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

Essaie :

mv ~/.cache ~/.cache-pourri

redémarre
Si toujours bloqué

mv ~/.config ~/.config-pourri

redémarre
Et dis-nous


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#37 Le 17/01/2018, à 20:05

LoïsR

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

!!! MIRACLE !!! ça fonctionne !! Un immense merci !
Si tu as 5 minutes, pourras-tu m'expliquer ce que contenait le fichier .config qui m'empechait de me connecter ?
je passe le post en résolu.

Hors ligne

#38 Le 17/01/2018, à 20:14

nam1962

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

La plupart des configurations de tes softs. Ils vont donc se comporter comme si tu venais de les installer.
Pour savoir exactement les softs concernés, comme on a gardé l'ancien, passe :

ls ~/.config
ls ~/.config-pourri

Si c'est gênant pour tel ou tel soft, tu peux recopier de l'ancien vers le nouveau. Si ça plante à nouveau tu auras trouvé un coupable tongue

(Si tu veux finaliser ta Xubuntu, jette un coup d’œil )

Dernière modification par nam1962 (Le 17/01/2018, à 20:17)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#39 Le 17/01/2018, à 20:34

LoïsR

Re : [Résolu] Impossible de me connecter en mode graphique depuis MAJ

Ok merci, l'ordi étant quasi neuf je n'avais pas installé grand chose dessus donc je n'ai pas de problème à tout réinstaller et reconfigurer.

Encore merci à tous ceux qui m'ont aidé ! smile

Hors ligne