Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 20/03/2017, à 00:10

Pandational

[Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Bonjour à tous,

Je me retrouve dans l'impossibilité d'écrire sur plusieurs de mes clés USB en fat32.
Ubuntu 16.04 me dit que le propriétaire est root, mais que je n'en suis pas le propriétaire (alors qu'il n'y a qu'un utilisateur sur mon poste et qu'il est administrateur).

Je ne comprends pas ce qu'il se passe. J'ai essayé de rajouter l'option rw au montage, mais cela ne fonctionne pas.
C'est un problème récurrent qui commence vraiment à me fatiguer... Je cherche dans la doc et sur le forum, mais j'ai du mal à trouver des réponses autres que 'il faut monter la clé différemment", ou des tutos avec udevinfo qui n'existe plus sur Xenial... Bref.

Please help.

Merci,

Dernière modification par Pandational (Le 21/03/2017, à 22:44)

Hors ligne

#2 Le 20/03/2017, à 06:50

moko138

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Pandational a écrit :

plusieurs de mes clés USB en fat32

Proviennent-elles d'un même fournisseur ?
As-tu pu, au moins une fois, y écrire plusieurs centaines de Mio ?
Le problème est-il identique avec windows ?
Sont-elles d'un même lot ?
  - -
Donne

lsb_release -d; printenv GDMSESSION ; uname -mr

  - -
D'abord, ferme gparted  (ou partitionmanager) et "Disques" s'ils étaient ouverts.

30 secondes après simple branchement d'une de ces clefs,
- dis quelle est sa marque,
- que donnent :

dmesg | grep -v 80211 | tail -n 20
mount | grep -Ev "devpts|none|proc|sys|tmpfs"
cat /etc/mtab | tail
ls -la /media/$USER

?
/!\  Ne cherche surtout pas à retaper ces lignes !
Utilise un triple clic gauche sur une ligne pour la sélectionner tout entière et la copier,
un clic milieu pour la coller.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#3 Le 20/03/2017, à 09:10

MicP

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Bonjour

…Ubuntu 16.04 me dit que le propriétaire est root…

Dans le cas d'un système de fichiers FAT (et autres NTFS, etc) le propriétaire du système de fichiers est celui qui a mounté le système de fichiers.
Tu avais donc sans doute utilisé le compte root pour pouvoir mounter ce système de fichiers.

=======

…il n'y a qu'un utilisateur sur mon poste et qu'il est administrateur …

Il y a au moins un compte utilisateur (que tu as oublié) et sans lequel ton système n'aurait pas pu démarrer : root
et beaucoup d'autres dont tu pourra avoir la liste dans le retour de la commande suivante :

sudo cut -d: -f1 /etc/passwd

=======

…J'ai essayé de rajouter l'option rw au montage…

Avec quelle commande et depuis quel compte utilisateur ?
La ligne de commande complète (avec le prompt) est indispensable pour qu'on puisse essayer de comprendre ce qui s'est passé.

=======
Si tu utilise ton compte utilisateur pour mounter ce type (FAT32) de système de fichiers, ton compte utilisateur sera le propriétaire de ce système de fichiers.

Dernière modification par MicP (Le 20/03/2017, à 10:09)

Hors ligne

#4 Le 20/03/2017, à 19:52

Pandational

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Merci pour vos réponses !
Alors :
- mes clés ne viennent pas du même fournisseur,il y a du lexar, du corsair, du nameless...
- elles ont toutes marché pendant des années, sans problème..
- elles fonctionnent impeccablement sur windows

Voici les résultats des diverses commandes:

lsb_release -d; printenv GDMSESSION ; uname -mr
Description:	Ubuntu 16.04.2 LTS
ubuntu
4.4.0-66-generic x86_64

- La lexar donne

 dmesg | grep -v 80211 | tail -n 20
[  298.917008] usb 1-3: new high-speed USB device number 5 using xhci_hcd
[  299.276675] usb 1-3: New USB device found, idVendor=05dc, idProduct=a815
[  299.276688] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  299.276695] usb 1-3: Product: USB Flash Drive
[  299.276701] usb 1-3: Manufacturer: Lexar
[  299.276706] usb 1-3: SerialNumber: AAN4MKBD963VFANW
[  299.278882] usb 1-3: ep 0x81 - rounding interval to 128 microframes, ep desc says 255 microframes
[  299.278901] usb 1-3: ep 0x2 - rounding interval to 128 microframes, ep desc says 255 microframes
[  299.279436] usb-storage 1-3:1.0: USB Mass Storage device detected
[  299.282986] scsi host3: usb-storage 1-3:1.0
[  300.750819] scsi 3:0:0:0: Direct-Access     Lexar    USB Flash Drive  1100 PQ: 0 ANSI: 4
[  300.752345] sd 3:0:0:0: Attached scsi generic sg1 type 0
[  300.754093] sd 3:0:0:0: [sdb] 15679488 512-byte logical blocks: (8.03 GB/7.48 GiB)
[  300.754896] sd 3:0:0:0: [sdb] Write Protect is off
[  300.754914] sd 3:0:0:0: [sdb] Mode Sense: 43 00 00 00
[  300.755754] sd 3:0:0:0: [sdb] No Caching mode page found
[  300.755769] sd 3:0:0:0: [sdb] Assuming drive cache: write through
[  300.762883]  sdb: sdb1
[  300.764994] sd 3:0:0:0: [sdb] Attached SCSI removable disk
[  301.199745] FAT-fs (sdb1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
 mount | grep -Ev "devpts|none|proc|sys|tmpfs"
/dev/sda7 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
mqueue on /dev/mqueue type mqueue (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
/dev/sda1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/sdb1 on /mnt/LEXAR type vfat (rw,nosuid,nodev,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
$ cat /etc/mtab | tail
systemd-1 /proc/sys/fs/binfmt_misc autofs rw,relatime,fd=27,pgrp=1,timeout=0,minproto=5,maxproto=5,direct 0 0
debugfs /sys/kernel/debug debugfs rw,relatime 0 0
mqueue /dev/mqueue mqueue rw,relatime 0 0
hugetlbfs /dev/hugepages hugetlbfs rw,relatime 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
/dev/sda1 /boot/efi vfat rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,relatime 0 0
tmpfs /run/user/1000 tmpfs rw,nosuid,nodev,relatime,size=383532k,mode=700,uid=1000,gid=1000 0 0
gvfsd-fuse /run/user/1000/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0
/dev/sdb1 /mnt/LEXAR vfat rw,nosuid,nodev,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 0
ls -la /media/$USER
total 8
drwxr-x---+ 2 root root 4096 mars  20 18:34 .
drwxr-xr-x  3 root root 4096 oct.  30 22:08 ..

MicP,

MicP a écrit :

Tu avais donc sans doute utilisé le compte root pour pouvoir mounter ce système de fichiers.

Ah, peut-être, mais je ne me souviens pas avoir changé quoi que ce soit à mon utilisation ordinaire et journalière de mon pc. Mais bon, ça ne veut pas dire grand chose.

MicP a écrit :

Il y a au moins un compte utilisateur (que tu as oublié) et sans lequel ton système n'aurait pas pu démarrer : root
et beaucoup d'autres dont tu pourra avoir la liste dans le retour de la commande suivante :

sudo cut -d: -f1 /etc/passwd

Ah, effectivement !

MicP a écrit :

Avec quelle commande et depuis quel compte utilisateur ?

J'ai rajouté l'option rw au montage en graphique dans "Disques", "modifier les options de montage"...

Merci encore pour vos réponses!

Hors ligne

#5 Le 20/03/2017, à 22:53

MicP

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Bonsoir

Je te recommande de dé-mounter le système de fichiers de la clef USB :

sudo umount /mnt/LEXAR

pour ensuite créer un LABEL (étiquette) différent pour chaque système de chaque clef FAT32 avec la commande suivante :

sudo MTOOLS_SKIP_CHECK=1 mlabel -i /dev/sdb1 ::MALEXAR

puis tu débranche la clef, tu connecte la suivante, et tu entre :

sudo MTOOLS_SKIP_CHECK=1 mlabel -i /dev/sdb1 ::MACORSAIR

etc.

Bien sûr, tu donne le nom de label que tu veux, mais évite les espaces, accentués et caractères spéciaux,
et comme il s'agit de FAT32, tout sera convertis en majuscule.
Ce nom de LABEL ne doit pas dépasser 11 octets.

Si le système de fichiers n'est pas FAT32, il faudra utiliser une autre ligne de commandes pour changer ou créer un LABEL.

=======
Une fois que chaque système de fichiers de chaque clef aura un LABEL spécifique,
tu n'aura plus qu'à connecter la clef sur un port USB pour que ce nom de LABEL apparaisse dans ton gestionnaire de fichiers,
et si tu n'a pas activé le mountage automatique, il te suffira de cliquer sur le nom du LABEL qui apparaît dans le gestionnaire de fichiers
pour qu'elle soit mountée et accessible depuis ton compte utilisateur.

Quand tu aura cliqué pour la mounter, le point de mountage sera automatiquement créé (et détruit au dé-mountage) dans /media/Pandational/MALEXAR ou /media/Pandational/MACORSAIR etc.
(en supposant que ton nom de login soit Pandational)

Dernière modification par MicP (Le 22/03/2017, à 02:43)

Hors ligne

#6 Le 21/03/2017, à 09:02

moko138

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Pandational a écrit :

- mes clés ne viennent pas du même fournisseur,il y a du lexar, du corsair, du nameless...
- elles ont toutes marché pendant des années, sans problème..
- elles fonctionnent impeccablement sur windows

Donc on peut exclure une contrefaçon inutilisable.  smile
  - -

[  300.750819] scsi 3:0:0:0: Direct-Access     Lexar    USB Flash Drive (...)
[  300.762883]  sdb: sdb1

La clef de marque est reconnue, sa partition unique aussi. Mais :

[  301.199745] FAT-fs (sdb1): Volume was not properly unmounted. (...)

Ce souci est classique.

1) À l'avenir,
sur ton ou tes windows, désactive tout ce qui ressemble de près ou de loin au "redémarrage rapide" et à l'hibernation. Comment ? Le sujet a été traité dans de nombreux fils du forum.
     Ou bien :
Prends la peine "d'éjecter en toute sécurité" tes clefs systématiquement, y compris avant d'éteindre windows.
Ce qui est d'ailleurs une précaution élémentaire depuis toujours.
  - -

Le Volume was not properly unmounted autorise néanmoins un montage manuel en "ro".
Mais...

Pandational a écrit :

J'ai rajouté l'option rw au montage en graphique dans "Disques", "modifier les options de montage"...

Tu as ainsi tenté de forcer le montage en rw d'un système de fichiers corrompu
- Erreur à ne jamais répéter ! Elle conduit à des pertes de données -
et obtenu

/dev/sdb1 /mnt/LEXAR vfat rw,nosuid,nodev,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 0

Heureusement, "Disques" a imposé errors=remount-ro.
  - -

2) Présentement,
- démonte la ou les clefs en fat ou en ntfs qui seraient montées,
- puis vérifie-les depuis windows.
/!\ Surtout ne leur applique pas le "fsck" préconisé dans le retour de dmesg :

tu trouveras toutes les explications dans Maintenance des supports....


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#7 Le 21/03/2017, à 12:34

MicP

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible


La clef de marque est reconnue, sa partition unique aussi. Mais :

[  301.199745] FAT-fs (sdb1): Volume was not properly unmounted. (...)

J'avais zappé ce message.

Hors ligne

#8 Le 21/03/2017, à 14:25

Pandational

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Merci !
1) clé lexar vérifiée sur windows
2) J'ai enlevé le rw que j'avais manuellement rajouté des options de montage
3) label créé pour le système en fat32 avec

sudo MTOOLS_SKIP_CHECK=1 mlabel -i /dev/sdb1 ::MALEXAR

sur ton ou tes windows, désactive tout ce qui ressemble de près ou de loin au "redémarrage rapide" et à l'hibernation. Comment ? Le sujet a été traité dans de nombreux fils du forum.
     Ou bien :
Prends la peine "d'éjecter en toute sécurité" tes clefs systématiquement, y compris avant d'éteindre windows.
Ce qui est d'ailleurs une précaution élémentaire depuis toujours.

Le redémarrage rapide est désactivé, donc j'avais dû "arracher" la clé un jour de disette roll

MicP a écrit :

Si le système de fichiers n'est pas FAT32, il faudra utiliser une autre ligne de commandes pour changer ou créer un LABEL.

Si une de mes clés a un système en NTFS, par exemple, que devient la commande?


Merci beaucoup pour l'aide. Je vérifie vite fait tout à l'heure que j'arrive à régler le souci avec mes autres clés et je marque le fil comme résolu.

Dernière modification par Pandational (Le 21/03/2017, à 14:26)

Hors ligne

#9 Le 21/03/2017, à 15:00

MicP

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Bonjour

…Si une de mes clés a un système en NTFS, par exemple, que devient la commande? …

sudo ntfslabel -f /dev/sdb1 MonNouveauLabelNTFSavecUnMaximumDe128CaractèresUnicodes

=======
Voir :

man ntfslabel

Dernière modification par MicP (Le 21/03/2017, à 15:05)

Hors ligne

#10 Le 21/03/2017, à 22:43

Pandational

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Merci !! smile

Hors ligne

#11 Le 21/03/2017, à 23:18

moko138

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

http://www.gnu.org/software/mtools/manual/mtools.html dit :

Global variables
Global flags may be set to 1 or to 0.

The following global flags are recognized:
MTOOLS_SKIP_CHECK
    If this is set to 1, mtools skips most of its sanity checks [saute les vérifications de la partition et de son système de fichiers]. This is needed to read some Atari disks which have been made with the earlier ROMs, and which would not be recognized otherwise.
(...)

Donc je conseille vigoureusement de ne pas utiliser cette option, sauf à savoir exactement ce qu'on fait...
  - -

Pour attribuer les très utiles étiquettes, on peut aussi passer (partition démontée) par gparted (ou par clic droit > "propriétés", dans l'explorateur windows).


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#12 Le 22/03/2017, à 00:21

MicP

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Clef USB 1GB avec partition de 100Mo formatée en FAT32

michel@ubu:~$ sudo fdisk -l /dev/sdb
Disque /dev/sdb : 984 MiB, 1031798272 octets, 2015231 secteurs
Unités : sectors of 1 * 512 = 512 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xb6f6a2df

Périphérique Amorçage Start    Fin Secteurs  Size Id Type
/dev/sdb1              2048 206847   204800  100M  b W95 FAT32
michel@ubu:~$ 
michel@ubu:~$ sudo mlabel -i /dev/sdb1 ::NOUVLABEL
Total number of sectors (204800) not a multiple of sectors per track (62)!
Add mtools_skip_check=1 to your .mtoolsrc file to skip this test
michel@ubu:~$ 

Même clef USB 1GB avec une partition de 983Mo (taille maximum sur cette clef) formatée en FAT32

michel@ubu:~$ sudo fdisk -l /dev/sdb
Disque /dev/sdb : 984 MiB, 1031798272 octets, 2015231 secteurs
Unités : sectors of 1 * 512 = 512 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xb6f6a2df

Périphérique Amorçage Start     Fin Secteurs  Size Id Type
/dev/sdb1              2048 2015230  2013183  983M  b W95 FAT32
michel@ubu:~$ 
michel@ubu:~$ sudo mlabel -i /dev/sdb1 ::NOUVLABEL
Total number of sectors (2013183) not a multiple of sectors per track (62)!
Add mtools_skip_check=1 to your .mtoolsrc file to skip this test
michel@ubu:~$ 

Oui mais voilà : une clef usb n'a pas de piste (track) ni de têtes de lectures, donc le retour d'informations à ce sujet (sans doute par l'int 13h) est incohérent sur toutes les clefs USB
Je ne suis pas allé démounter les sources de Gparted, mais je pense que l'option MTOOLS_SKIP_CHECK=1 est activée par défaut quand Gparted appelle la commande mlabel

Quand à windows, méfiez-vous, il pourrait très bien changer le système de fichiers FAT32 en exFAT sans vous prévenir : (C'est du vécu perso)

Dernière modification par MicP (Le 22/03/2017, à 03:59)

Hors ligne

#13 Le 22/03/2017, à 08:15

moko138

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Merci de ces retours, MicP !

MicP a écrit :

Quand à windows, méfiez-vous, il pourrait très bien changer le système de fichiers FAT32 en exFAT sans vous prévenir : (C'est du vécu perso)

L'info me semble suffisamment importante pour que tu en fasses un fil à part entière
et que tu y donnes un maximum de détails (version de windows; aspect de la partition avant/après; nature du support (clef ou HD ou SSD ou carte) etc.).

  - -

MicP a écrit :

une clef usb n'a pas de piste (track) ni de têtes de lectures

Réellement, non. Mais virtuellement, si.
Et je comprends que, dans ces conditions exactes, tu utilises :

sudo MTOOLS_SKIP_CHECK=1 mlabel...

Ce qui est préférable à la modification du fichier de configuration .mtoolsrc.

Mais
1)  je suis enclin à croire que tu n'aurais pas ce message d'erreur en alignant les partitions de tes clefs usb "sur les cylindres" ;

2) À quoi sert l'option "-i" que tu as employée derrière mlabel ???
je n'ai pas trouvé cette option, ni dans le man de Trusty (http://manpages.ubuntu.com/manpages/tru … bel.1.html),
ni dans le man de Wheezy
ni à leur source (http://www.gnu.org/software/mtools/manu … tml#mlabel).
  Merci d'avance !


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#14 Le 22/03/2017, à 12:24

MicP

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

bonjour

Je n'utilise pas windows, mais mon fils utilisait à cette époque (il y a quelques années) Windows 8.
Il m'avait demandé de lui transmettre des vidéos que j'ai mises sur un disque USB dans un système de fichiers FAT32 et je suis allé le voir.

Quand nous avons connecté le disque sur sa machine, un message d'erreur s'est affiché.
Pensant qu'il pouvait s'agir d'un défaut de connexion USB, nous avons changé le cordon USB qui reliait le boîtier USB de ce disque au port USB de sa machine.
Après 3 connexions/déconnexions avec messages d'erreurs, les fichiers étaient enfin accessibles.

Une fois de retour chez moi, j'ai constaté que le système de fichiers avait été modifié de FAT32 à exFAT
J'ai utilisé dd pour inscrire des zéro sur tout ce disque (dd if=/dev/zero of=/dev/sdx),
créé une table des partitions de type MSDOS et une partition de type FAT32
et je suis revenu chez lui pour refaire le test (sans changer de cordon USB) ce qui a donné le même résultat.

Désolé si je ne suis pas assez précis (manque N° de version Windows, contenu du message d'erreur, etc.)
mais comme je n'utilise pas windows et que j'avais d'autres soucis plus important à l'époque, je ne suis pas allé plus loin.

Du coup, je n'ouvre pas de fil car je n'ai pas d'information assez précises à donner
Si j'ai le temps, quand je repasserai à Paris, j'essayerai de reproduire le test sur la machine de mon fils.
Mais je crois qu'il est passé depuis à W10…

=======
À propos de l'option -i :

Effectivement, c'est assez mal documenté, et je n'ai trouvé une citation de l'option i que dans la commande mcopy
https://www.gnu.org/software/mtools/man … ve-letters
Je suppose que c'est dû au fait que sous Linux l'accès aux périphériques se fait par l'intermédiaire d'un fichier (de périphérique).

=======

je suis enclin à croire que tu n'aurais pas ce message d'erreur en alignant les partitions de tes clefs usb "sur les cylindres"

Il n'y a pas non plus de cylindres dans une clef USB,
mais sur ma clef USB, l'utilisation de l'option "Aligner sur Cylindre" a fonctionné => il n'est plus nécessaire d'activer l'option MTOOLS_SKIP_CHECK pour pouvoir utiliser la commande mlabel

Donc tu as parfaitement raison : l'alignement des partitions sur Cylindre permet d'éviter d'avoir à utiliser l'option MTOOLS_SKIP_CHECK

=======
NOTE : En regardant l'EBPB de la partition FAT32 de cette clef USB, je constate que si' l'on donne un label en caractères minuscules, il est bien inscrit en caractères minuscule (offset 0x047) même s'il est retourné en caractères majuscule dans /dev/disk/by-label/

Dernière modification par MicP (Le 25/03/2017, à 14:16)

Hors ligne

#15 Le 22/03/2017, à 17:57

moko138

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Merci beaucoup MicP !  smile


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#16 Le 22/03/2017, à 18:29

moko138

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Pour l'option "-i",
je viens de faire un test en session 14.04.1 live sur une partition FAT32 (non montée) d'un disque dur :

sudo mlabel -i /dev/sdb1 ::LABEL1

fonctionne parfaitement (l'étiquette est changée).

Mais quand je retire l'option -i, l'étiquette n'est pas changée. Voici le retour :

lubuntu@lubuntu:~$ sudo mlabel /dev/sda1 ::LABEL2
Mtools version 4.0.18, dated January 9th, 2013
Usage: mlabel [-vscVn]  [-N serial] drive:
lubuntu@lubuntu:~$ 

Donc l'option -i de mlabel, quoique non documentée, est indispensable au changement d'étiquette.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#17 Le 22/03/2017, à 19:23

MicP

Re : [Résolu] permissions clé-USB fat32 - root proprio- écriture impossible

Petit piège à cause d'un "mauvais caractère" :

D'après la documentation, on pourrait croire qu'il ne faudrait pas dépasser 11 caractères pour un LABEL FAT32.
Mais en fait :

michel@ubu:~$ sudo mlabel -i /dev/sdc1 ::RÉCUPÉRÉS
New label too long
michel@ubu:~$ 
michel@ubu:~$ wc -m <<< "RÉCUPÉRÉS"     # Pourtant, il n'y a bien que 9 caractères
9
michel@ubu:~$ 
michel@ubu:~$ wc -c <<< "RÉCUPÉRÉS"     # Mais voilà : les trois caractères accentués occupent deux octets chacuns
12
michel@ubu:~$ 

Donc, il ne s'agit pas de 11 caractères, mais bien de 11 octets.


man mlabel a écrit :

…The label is limited to 11 single-byte characters, …

=======

…sur une partition FAT32 (non montée)…

Ça fonctionne aussi même si le système de fichiers est mounté et qu'un ou plusieurs de ses fichiers sont en cours d'édition.

Il ne perdra pas le fil, car une fois le système de fichiers mounté, Linux n'utilise pas les noms, mais les inodes du système de fichiers Linux.
(mounté <=> attaché, gréffé par un point de mountage dans l'arborescence du système de fichiers du système Linux)

Tu peux même visualiser le changement de LABEL en Live par l'interface graphique du navigateur de fichier

Un petit résumé sur les inodes

Dernière modification par MicP (Le 25/03/2017, à 14:18)

Hors ligne