Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 17/03/2017, à 19:35

moko138

Le noyau 4.4.0-67 semble bogué : perte de réseau

Deux fils (au moins) font déjà état de la perte du réseau avec le noyau 4.4.0-67, et du réseau retrouvé en démarrant sur un noyau précédent :

./viewtopic.php?pid=21698397#p21698397 et
./viewtopic.php?pid=21698465#p21698465

D'ailleurs http://packages.ubuntu.com/search?keywo … rs-generic indique 4.4.0-66 comme dernier noyau stable. (Ajout : y compris en ce 21/3).

  - -

Toutes les machines ne sont pas concernées (merci cqfd93 et tarkan99 !)
Si votre machine est concernée, voici comment procéder :


Pour démarrer sur un noyau précédent :
tapoter la touche Majuscules en démarrant,
avec les flèches bas(haut), choisir Linux previous versions et valider par Entrée
choisir le noyau précédent et valider de nouveau.

Une fois le système lancé,
- vérifier par

uname -r

que le noyau utilisé n'est pas le 4.4.0-67,
- vérifier que les réseaux filaire et sans fil fonctionnent, et lancer :

sudo apt-get install --reinstall linux-image-extra-4.4.0-67-generic

- Redémarrer normalement (donc sur le noyau 4.4.0-67),
à présent le réseau devrait fonctionner.


Si le réseau ne fonctionne toujours pas,
- redémarrer sur un noyau précédent,
- enfin désinstaller le noyau 4.4.0-67 par la méthode de votre choix.

Dernière modification par moko138 (Le 21/03/2017, à 04:40)


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#2 Le 18/03/2017, à 08:55

CRIMA

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

Bonjour

Sur une machine équipée de Ubuntu 16.04 et connectée en Wifi, réglée en "pour les versions prises en charge sur le long terme", j'ai été contraint (vu la persistance de la demande du gestionnaire des mises à jour) d'effectuer une mise à niveau partielle.
Après l'éxécution, je n'ai plus que le noyau 4.4.0-67, tous les autres noyaux ayant été supprimés pendant la phase "nettoyage".
Au redémarrage, plus de connexion internet en Wifi, et, sauf à déplacer toute l'installation de la box, je n'ai pas de possibilité de vérifier si la connection filaire fonctionne .
Ma question est de savoir s'il est possible de réinstaller un noyau antérieur qui fonctionnait (4.4.0.66 je pense fonctionnait ou celui d'avant). et quelle serait la commande à éxécuter ?
Avec mes remerciements anticipés
Salutations

PRECISION : Sur un autre machine équipée de Ubuntu Studio et connectée en filaire, qui a éxécuté la meme mise à niveau partielle .... plus de démarrage . A chaque tentative on re tombe sur Grub !

Dernière modification par CRIMA (Le 18/03/2017, à 09:00)

Hors ligne

#3 Le 18/03/2017, à 09:35

tarkan99

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

j'ai eu la même proposition (que je n'avais encore jamais vu) mais j'ai répondu non pour le ménage des anciens noyaux.


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#4 Le 18/03/2017, à 11:03

moko138

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

CRIMA
Oui je vois une solution pour celle qui démarre de tes machines.
ouvre un fil et indiques-en le lien ici.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#5 Le 18/03/2017, à 11:29

CRIMA

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

moko138 a écrit :

CRIMA
Oui je vois une solution pour celle qui démarre de tes machines.
ouvre un fil et indiques-en le lien ici.

Merci, j'ouvre un fil  avec pour titre : Plus de Wifi avec 4.4.0-67

Salutations

Hors ligne

#6 Le 18/03/2017, à 12:42

moko138

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

CRIMA a écrit :

j'ouvre un fil  avec pour titre : Plus de Wifi avec 4.4.0-67

C'est là : ./viewtopic.php?id=2006778


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#7 Le 18/03/2017, à 17:23

xubu1957

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

et un nouvel abonné : forum.ubuntu-fr.org/viewtopic.php?pid=21699030#p21699030


jbyvosges a écrit :

Heureusement, il me reste le noyau 4.4.0-66 !
P.S. : j'ai supprimé le noyaau 67 et ça remarcche


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Aspire 9411ASWI - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de : Linux-Azur

Hors ligne

#8 Le 18/03/2017, à 17:36

tarkan99

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

Un autre :
https://forum.ubuntu-fr.org/viewtopic.php?id=2006785

Il a demandé la suppression des anciens noyaux, avec un disque chiffré,c'est mal engagé. ...


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#9 Le 20/03/2017, à 10:44

jbyvosges

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

Bonjour
Je vois sur https://bugs.launchpad.net/ubuntu/+sour … ug/1674109 que ce bogue n'affecte que 2 personnes !
Si personne ne signale le bogue,il ne sera jamais corrigé !


hp Pavilion ELite 020fr - Intel® Core™ i7 860 - 12Go RAM - Ubuntu 16.04 (et 16.10 sur un portable)
Mes sites : http://www.jbyorchid.fr
http://www.dolman.fr
http://www.sfola.fr

Hors ligne

#10 Le 20/03/2017, à 11:22

tarkan99

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

il semblerait quand dans la mise à jour .67 il manquerait linux-image-extra-4.4.0-67-generic ?


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#11 Le 20/03/2017, à 13:11

malbo

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

tarkan99 a écrit :

il semblerait quand dans la mise à jour .67 il manquerait linux-image-extra-4.4.0-67-generic ?

Il est possible que la situation se soit assainie tout récemment mais suite à ton post, je viens de faire la mise à jour de mon Ubuntu 16.04 en faisant comme je fais d'habitude  - en passant d'abord la commande "sudo apt update" puis la commande "sudo apt full-upgrade" - et j'ai obtenu le résultat suivant (extrait de /var/log/apt/histoty.log) :

Start-Date: 2017-03-20  11:59:58
Commandline: apt full-upgrade
Requested-By: malbo (1000)
Install: linux-headers-4.4.0-67:amd64 (4.4.0-67.88, automatic), linux-image-4.4.0-67-generic:amd64 (4.4.0-67.88, automatic), linux-image-extra-4.4.0-67-generic:amd64 (4.4.0-67.88, automatic), linux-headers-4.4.0-67-generic:amd64 (4.4.0-67.88, automatic)
Upgrade: linux-headers-generic:amd64 (4.4.0.66.70, 4.4.0.67.72), gnome-software:amd64 (3.20.1+git20161013.0.d77d6cf-0ubuntu2~xenial1, 3.20.1+git20170208.0.a34b091-0ubuntu1~xenial1), ubuntu-software:amd64 (3.20.1+git20161013.0.d77d6cf-0ubuntu2~xenial1, 3.20.1+git20170208.0.a34b091-0ubuntu1~xenial1), gnome-software-common:amd64 (3.20.1+git20161013.0.d77d6cf-0ubuntu2~xenial1, 3.20.1+git20170208.0.a34b091-0ubuntu1~xenial1)
Remove: linux-generic:amd64 (4.4.0.66.70)
End-Date: 2017-03-20  12:02:06

On y voit bien qu'il y a eu installation de linux-image-extra-4.4.0-67-generic comme il se doit.

Dernière modification par malbo (Le 20/03/2017, à 13:32)

Hors ligne

#12 Le 20/03/2017, à 14:11

tarkan99

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

faudrait comparer avec une installation qui a merdé (dans le sens réseau HS).

Quelle différence entre upgrade et full-upgrade ?


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#13 Le 20/03/2017, à 14:59

moissan

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

ce sujet m'inquiète : quand on a besoin d'un ordinateur faible , on n'a pas envie qu'une mise a jour mette tout en panne

je croyais que quand on choisissait une version lts on etait a l'abri des mise a jour scabreuse  et que les mise a jours diffusé aux version non lts permetait  de detecter les bug avant de les appliquer a tout le monde

ça merite quelques explication

En ligne

#14 Le 20/03/2017, à 16:48

erresse

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

tarkan99 a écrit :

faudrait comparer avec une installation qui a merdé (dans le sens réseau HS).

Quelle différence entre upgrade et full-upgrade ?

"upgrade" ne fait que les mises à jour des logiciels et du système installés, cette opération ne supprime ni n'installe de nouveaux logiciels.
"full-upgrade" ou "dist-upgrade" fait une mise à jour de la distribution, soit de logiciels et du système installés, mais en supprimant des logiciels obsolètes et en en installant de nouveaux suivant les besoins pour la distribution.


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

En ligne

#15 Le 20/03/2017, à 16:50

tarkan99

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

merci pour cette précision.


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#16 Le 21/03/2017, à 04:41

moko138

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

J'ai mis à jour le 1er message.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#17 Le 21/03/2017, à 05:03

moko138

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

moissan a écrit :

ce sujet m'inquiète : quand on a besoin d'un ordinateur faible , on n'a pas envie qu'une mise a jour mette tout en panne

je croyais que quand on choisissait une version lts on etait a l'abri des mise a jour scabreuse  et que les mise a jours diffusé aux version non lts permetait  de detecter les bug avant de les appliquer a tout le monde

ça merite quelques explication

Je suppose que tu veux dire "besoin d'un ordinateur fiable".  smile

Ces bogues de noyaux Ubuntu LTS sont exceptionnels mais ils existent (dans mes archives, j'en ai noté en 2015 et en 1013). C'est pour cette raison qu'on conseille de garder toujours l'avant-dernier noyau opérationnel.
Si tu continues de prendre cette précaution, tu resteras à l'abri de ce souci.  smile


De plus, on peut aussi :
- avoir un système d'exploitation de secours sur sa machine ;
- et, comme une compromission de grub, ou une panne de disque ou de machine, restent possibles, avoir une vieille machine de secours.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#18 Le 21/03/2017, à 07:20

tarkan99

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

@moko : c'est la 1° fois que je voyais une fenêtre proposer de supprimer tous les anciens noyaux après installation des mises à jour.
Mais j'ai évidement refusé mais celui qui ne met jamais les mains dans le cambouis peut se faire avoir.


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#19 Le 21/03/2017, à 07:44

tarkan99

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

@malbo

aucune trace du 67 dans history.log (je ne connaissais par ce log)

cat /var/log/apt/history.log | grep 67

ne donne rien.

pourtant

Linux proBK 4.4.0-67-generic #88-Ubuntu SMP Wed Mar 8 16:34:45 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#20 Le 21/03/2017, à 11:16

malbo

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

@tarkan99 : peut-être que ça se trouve dans le fichier compressé /var/log/apt/history.log.1.gz

Hors ligne

#21 Le 22/03/2017, à 23:34

tarkan99

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

Trouvé dans
/var/log/dist-upgrade/history.log


Start-Date: 2017-03-17  06:38:43
Requested-By: xxxx (1000)
Install: linux-headers-4.4.0-67:amd64 (4.4.0-67.88, automatic), linux-image-4.4.0-67-generic:amd64 (4.4.0-67.88, automatic), linux-image-extra-4.4.0-67-generic:amd64 (4.4.0-67.88, automatic), linux-headers-4.4.0-67-generic:amd64 (4.4.0-67.88, automatic)
Upgrade: linux-headers-generic:amd64 (4.4.0.66.70, 4.4.0.67.72), linux-libc-dev:amd64 (4.4.0-66.87, 4.4.0-67.88), libevent-core-2.0-5:amd64 (2.0.21-stable-2, 2.0.21-stable-2ubuntu0.16.04.1), imagemagick:amd64 (8:6.8.9.9-7ubuntu5.5, 8:6.8.9.9-7ubuntu5.6), libicu55:amd64 (55.1-7, 55.1-7ubuntu0.1), libicu55:i386 (55.1-7, 55.1-7ubuntu0.1), libmagickwand-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.5, 8:6.8.9.9-7ubuntu5.6), gnome-software:amd64 (3.20.1+git20161013.0.d77d6cf-0ubuntu2~xenial1, 3.20.1+git20170208.0.a34b091-0ubuntu1~xenial1), python3-pil:amd64 (3.1.2-0ubuntu1, 3.1.2-0ubuntu1.1), libevent-pthreads-2.0-5:amd64 (2.0.21-stable-2, 2.0.21-stable-2ubuntu0.16.04.1), imagemagick-6.q16:amd64 (8:6.8.9.9-7ubuntu5.5, 8:6.8.9.9-7ubuntu5.6), libmagickcore-6.q16-2-extra:amd64 (8:6.8.9.9-7ubuntu5.5, 8:6.8.9.9-7ubuntu5.6), network-manager-openvpn:amd64 (1.1.93-1ubuntu1, 1.1.93-1ubuntu1.1), libpurple-bin:amd64 (1:2.10.12-0ubuntu5.1, 1:2.10.12-0ubuntu5.2), libmagickcore-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.5, 8:6.8.9.9-7ubuntu5.6), libpurple0:amd64 (1:2.10.12-0ubuntu5.1, 1:2.10.12-0ubuntu5.2), libevent-2.0-5:amd64 (2.0.21-stable-2, 2.0.21-stable-2ubuntu0.16.04.1), pidgin-data:amd64 (1:2.10.12-0ubuntu5.1, 1:2.10.12-0ubuntu5.2), libicu-dev:amd64 (55.1-7, 55.1-7ubuntu0.1), imagemagick-common:amd64 (8:6.8.9.9-7ubuntu5.5, 8:6.8.9.9-7ubuntu5.6), icu-devtools:amd64 (55.1-7, 55.1-7ubuntu0.1), gnome-software-common:amd64 (3.20.1+git20161013.0.d77d6cf-0ubuntu2~xenial1, 3.20.1+git20170208.0.a34b091-0ubuntu1~xenial1)
Remove: linux-generic:amd64 (4.4.0.66.70)
End-Date: 2017-03-17  06:41:02

et
/var/log/dist-upgrade/apt.log

Log time: 2017-03-17 06:37:13.618286
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) linux-image-generic [ amd64 ] < 4.4.0.66.70 -> 4.4.0.67.72 > ( kernel )
Broken linux-image-generic:amd64 Casse on snapd [ amd64 ] < 2.22.6 > ( devel ) (< 2.23.1~)
  Considering snapd:amd64 5 as a solution to linux-image-generic:amd64 1
  Holding Back linux-image-generic:amd64 rather than change snapd:amd64
Investigating (0) linux-generic [ amd64 ] < 4.4.0.66.70 -> 4.4.0.67.72 > ( kernel )
Broken linux-generic:amd64 Dépend on linux-image-generic [ amd64 ] < 4.4.0.66.70 -> 4.4.0.67.72 > ( kernel ) (= 4.4.0.67.72)
  Considering linux-image-generic:amd64 1 as a solution to linux-generic:amd64 0
  Removing linux-generic:amd64 rather than change linux-image-generic:amd64
 Try to Re-Instate (1) linux-image-generic:amd64
Done
Log time: 2017-03-17 06:41:04.894037
  MarkDelete linux-image-extra-4.4.0-67-generic [ amd64 ] < 4.4.0-67.88 > ( kernel ) FU=1
  MarkDelete linux-image-generic [ amd64 ] < 4.4.0.66.70 -> 4.4.0.67.72 > ( kernel ) FU=1
  MarkDelete linux-image-4.4.0-62-generic [ amd64 ] < 4.4.0-62.83 > ( kernel ) FU=1
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) linux-image-extra-4.4.0-62-generic [ amd64 ] < 4.4.0-62.83 > ( kernel )
Broken linux-image-extra-4.4.0-62-generic:amd64 Dépend on linux-image-4.4.0-62-generic [ amd64 ] < 4.4.0-62.83 > ( kernel )
  Considering linux-image-4.4.0-62-generic:amd64 10001 as a solution to linux-image-extra-4.4.0-62-generic:amd64 0
  Removing linux-image-extra-4.4.0-62-generic:amd64 rather than change linux-image-4.4.0-62-generic:amd64
  MarkDelete linux-image-extra-4.4.0-62-generic [ amd64 ] < 4.4.0-62.83 > ( kernel ) FU=0
Done
  MarkDelete linux-headers-4.4.0-62-generic [ amd64 ] < 4.4.0-62.83 > ( devel ) FU=1
  MarkDelete linux-headers-4.4.0-62 [ amd64 ] < 4.4.0-62.83 > ( devel ) FU=1
  MarkDelete thermald [ amd64 ] < 1.5-2ubuntu2 > ( admin ) FU=1
  MarkDelete linux-headers-4.4.0-67 [ amd64 ] < 4.4.0-67.88 > ( devel ) FU=1
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) linux-headers-4.4.0-67-generic [ amd64 ] < 4.4.0-67.88 > ( devel )
Broken linux-headers-4.4.0-67-generic:amd64 Dépend on linux-headers-4.4.0-67 [ amd64 ] < 4.4.0-67.88 > ( devel )
  Considering linux-headers-4.4.0-67:amd64 10001 as a solution to linux-headers-4.4.0-67-generic:amd64 1
  Removing linux-headers-4.4.0-67-generic:amd64 rather than change linux-headers-4.4.0-67:amd64
  MarkDelete linux-headers-4.4.0-67-generic [ amd64 ] < 4.4.0-67.88 > ( devel ) FU=0
Investigating (0) linux-headers-generic [ amd64 ] < 4.4.0.67.72 > ( devel )
Broken linux-headers-generic:amd64 Dépend on linux-headers-4.4.0-67-generic [ amd64 ] < 4.4.0-67.88 > ( devel )
  Considering linux-headers-4.4.0-67-generic:amd64 1 as a solution to linux-headers-generic:amd64 0
  Removing linux-headers-generic:amd64 rather than change linux-headers-4.4.0-67-generic:amd64
  MarkDelete linux-headers-generic [ amd64 ] < 4.4.0.67.72 > ( devel ) FU=0
Done
  MarkDelete linux-image-4.4.0-67-generic [ amd64 ] < 4.4.0-67.88 > ( kernel ) FU=1

La page http://packages.ubuntu.com/search?keywo … rs-generic n'est toujours pas à jour. étrange cette màj.

Dernière modification par tarkan99 (Le 22/03/2017, à 23:38)


xubuntu 16.04.1 sur HP probook 6560b et sur vieux Core 2 duo
lubuntu 16.04.2 sur Samsung NC10

Hors ligne

#22 Le 05/04/2017, à 10:11

eeried

Re : Le noyau 4.4.0-67 semble bogué : perte de réseau

CRIMA a écrit :

Sur une machine équipée de Ubuntu 16.04 et connectée en Wifi, réglée en "pour les versions prises en charge sur le long terme", j'ai été contraint (vu la persistance de la demande du gestionnaire des mises à jour) d'effectuer une mise à niveau partielle.

Comment est-on contraint? Est-ce que tu ne peux pas décocher "pour les versions prises en charge sur le long terme", donc décocher toutes les mis mise à niveaux? Les versions LTS sont annoncées bien à l’avance et c’est à peu près tous les 5 ans, donc tu ne risques pas de les rater. Mais peut-être que ça ne changerait rien, d’ailleurs.

Mais j’ignorais qu’Ubuntu installe des versions de noyau devel, donc non stable. C’est ça le bug, en fait?

Et on a donc intérêt à se méfier de quelques versions de noyau, quelque soit la distribution, brrr

En tous cas, c’est bien d’avoir signalé cet incident, ce fil est une bonne mise en garde. Et donc, je note bien aussi qu’Ubuntu demande si on veut bien supprimé tel ou tel noyau et on peut décocher le noyau actuel qui marche  bien pour qu’il soit conservé. Ce serait quand même mieux qu’Ubuntu garde le noyau actuel par défaut.

Et dire que si j’ai bien compris chez Debian ils envisagent de mettre un programme de mise à jour automatique, ce n’est peut-être pas très prudent.


Libre-Fan http://librefan.eu.org/  Mozilla, GNU/Linux, Le libre (et les femmes?)
Libres-Ailé(e)s association pour GNU/Linux et le monde du Libre  (Haute-Loire)

Hors ligne