Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 01/03/2017, à 09:27

Woodnote

[Résolu] Latence trop importante sous Ubuntu Studio

Bonjour,
Etant sous Ubuntu Studio (que je viens d'installer "Xenius Xerus 16.04.2"), je ne comprend pas pourquoi j'ai autant de latence qui m'empêche de jouer de la guitare normalement ?
Je passe par 'Jack' (QJackCtl) et en simulateur 'Guitarix ou 'Rakarrack', même problème. Ma carte son est une 'Cakewalk UA-25-EX' qui affiche dans les 'Réglages' de 'Jack' 23.2 ms de latence  sur un 'Echantillons/ Période' de 512.

Dernière modification par Woodnote (Le 03/03/2017, à 16:54)


(Ubuntu Studio 16.04.2)

Hors ligne

#2 Le 01/03/2017, à 12:10

xabilon

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Salut

Assure-toi que tu utilises bien le noyau temps réel ou basse latence
Puis, dans les réglages de Jack, baisse les "échantillons/périodes" (le buffer audio) à 256 samples. Si tu n'as pas de craquements audio, teste à 128.
Il faudrait arriver au plus à 10ms de latence (10ms, c'est la latence d'un ampli situé à 3,40 m).


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 01/03/2017, à 14:50

Woodnote

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Slt, merci d'intervenir.
Il me semble que sur Ubuntu Studio c'est le noyau basse latence qui est en fonction, n'est-ce pas ? (ou y a t-il un "bouton" On/Off quelque part ?)

4.8.0-39-lowlatency

J'ai tout de même une aspiration, un temps de retard (un peu comme une Whawha) encore perceptible et gênant en tombant l'échantillon à 256, pourtant il m'est indiqué que la latence est de seulement 5.6 ms !
Je me demande d'où vient le problème (de ma carte son ?), car que ce soit rabarrack ou guitarix, j'ai des sons faibles, qui grésillent, dont les saturations ressemblent plus à ce que sortirait un vieil ampli transistor pousser à fond...

Dernière modification par Woodnote (Le 01/03/2017, à 15:11)


(Ubuntu Studio 16.04.2)

Hors ligne

#4 Le 01/03/2017, à 17:17

xabilon

Re : [Résolu] Latence trop importante sous Ubuntu Studio

En fait oui, les fonctionnalités temps réel sont implémentées de base dans le noyau générique depuis la version 12.04

Dans la fenêtre principale de Qjackctl, il faut que "RT" soit allumé, ça veut dire que le lowlatency/realtime est activé.

Si c'est le cas, essaye de faire transiter le son directement de l'entrée vers la sortie, sans aucun effet ; as-tu encore une latence ? 5.6ms n'est normalement pas perceptible.
Les grésillements peuvent venir des Xruns (ce sont les chiffres dans la fenêtre de Qjackctl, à gauche au milieu), c'est que le CPU ne peut pas assurer les calculs dans le temps de latence imparti. L'idéal est d'en avoir 0 (0).

Quel est ta fréquence d'échantillonnage ? 44100 Hz est normalement suffisant et prend moins de puissance de calcul.

Dernière modification par xabilon (Le 01/03/2017, à 17:25)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#5 Le 01/03/2017, à 17:35

Woodnote

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Oui "RT" en jaune clignote.
Si je n'allume pas rakarrack je n'ai pas de son au casque (je n'ai pas de moniteur, d'enceintes pour le moment).
Guitarix sans Jack ne fonctionne pas.
A gauche au milieu de Jack je ne vois qu'un "0(1)" en rouge qui ne bouge pas.
La fréquence est bien arrêtée sur 44100 Hz.
L'"aspiration" à chaque note dont je te parlais précédemment, c'est vraiment très léger depuis que l'échantillon est à 256. Mais c'est bien présent.
Je viens de changer mon PC qui dispose de 16 G de ram, processeur i5 7500 3.4 Ghz ; si ça déconne avec ça, ce n'est pas normal. J'ai justement changé mon vieux PC parce que j'avais des soucis de craquement lors de mes petits enregistrements qui provoquaient régulièrement des "sautes de rythmes", ce qui rendait l'exercice particulièrement difficile... Puis j'ai vu que Ubuntu Studio est son noyau devrait me satisfaire pleinement. J'espère juste que ce ne sont que quelques réglages à peaufiner pour enfin pouvoir enregistrer mes petites prises guitares sans aucun souci.

Edit : Ok, c'est mieux (Ta rédit m'a mis la puce à l'oreille); je suis passé dans les réglages de Jack et j'ai rétabli UA25EX,0 (précédemment je l'avais sur UA25EX,1), et donc maintenant "0.(0) est en vert au milieu à gauche de Jack.
Avec Rakarrack, y'a toujours un très léger décalage (à peine perceptible, une monté de volume après impact sur corde) ; Guitarix réagit lui beaucoup mieux. Par contre, quand j'attaque un peu les cordes j'ai tjrs une saturation anormale dans le casque.  Une idée là dessus ?

Edit² : En fait, les grésillements, saturations etc disparaissent en diminuant tout simplement  le "pregain" sur Guitarix (mais étrangement le problème persiste sur Rakarrack), dont les sons guitares dans la 'selection preset' : A: Sonnie_Tele (clean-clean ou clean delay chorus), les sons clairs sont d'une pure merveille, un régal ! Rien à envier Guitar rig de ce côté ci. Par contre je suis du coup obligé de compenser au volume de ma carte son qui est monté au 3/4 pour avoir un son raisonnable au casque.

Dernière modification par Woodnote (Le 01/03/2017, à 19:01)


(Ubuntu Studio 16.04.2)

Hors ligne

#6 Le 01/03/2017, à 19:03

xabilon

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Un i5 à 3.4GHz et 16Go de RAM, tu as laaaaaargement de quoi faire.

Dans les connexions de Jack, tu devrais relier l'entrée de ta carte son directement à la sortie casque de celle-ci, comme ça tu entendra le son direct de ce qui y entre. Normalement tu ne devrais pas sentir de latence, et avoir un son clair sans saturation.

Si ça sature sans avoir aucun effet, essaye de baisser le gain de ta carte son (avec alsamixer), soit en entrée, soit en sortie (en fonction de ce qui sature).

Si tu as une carte son intégrée à la carte mère, pense aussi à la désactiver dans le BIOS.

Dernière modification par xabilon (Le 01/03/2017, à 19:04)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#7 Le 01/03/2017, à 19:18

xabilon

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Woodnote a écrit :

Edit² : En fait, les grésillements, saturations etc disparaissent en diminuant tout simplement  le "pregain" sur Guitarix (mais étrangement le problème persiste sur Rakarrack), dont les sons guitares dans la 'selection preset' : A: Sonnie_Tele (clean-clean ou clean delay chorus), les sons clairs sont d'une pure merveille, un régal ! Rien à envier Guitar rig de ce côté ci. Par contre je suis du coup obligé de compenser au volume de ma carte son qui est monté au 3/4 pour avoir un son raisonnable au casque.

Ça a donc l'air d'un problème de niveau audio. Je ne connais pas ta carte son, a-t-elle des préamplis à niveau réglable ? Entres-tu directement la guitare ou passes-tu par une tête d'ampli ?
Bref, il va falloir trouver le bon niveau d'entrée.

Si ça tourne bien niveau Xruns, essaye de baisser encore plus la latence, en mettant un buffer de 128. Si il y a des Xruns, tu n'auras qu'à revenir à 256 (5,6ms, c'est déjà quasiment rien).


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#8 Le 01/03/2017, à 20:23

Woodnote

Re : [Résolu] Latence trop importante sous Ubuntu Studio

"Dans les connexions de Jack, tu devrais relier l'entrée de ta carte son directement à la sortie casque de celle-ci.."

Je veux bien mais comment faut -il faire. Dans 'Connecter' sur Jack, je ne vois que 'PulseAudioJackSOurce' et 'System' (et aussi Rakarrack et/ou Guitarix quand il sont démarré)
Je ne dispose pas d''alsamixer' dans mes programmes, à moins que celui ci soit 'QasHctl' qui lui s'y trouve bien.

Si tu as une carte son intégrée à la carte mère, pense aussi à la désactiver dans le BIOS.

Oh, c'est peut-être bien ça qui met la pagaille, effectivement je n'ai pas désactivé la carte son intégré à la carte mère. Puis-je le faire par 'commande' ou dois-je booter pour le faire directement de mon bios ?

Ma carte son Cakewalk UA-25-EX est vraiment très basique, 2 entrées jack/ Xlr (et pour le reste je n'y connaîs rien, donc je suis bien incapable de te nommer les potards [sens ; Input ; Direct Monitor] autrement quand recopiant ce que j'y lis) Si tu veux y jeter un oeil, tu en as les détails ici : https://www.roland.com/fr/products/ua-25ex/

Je peux te dire que j'entre ma guitare direct sur l'input 1 (avec un jack guitare) .
Et enfin, je suis effectivement descendu à 128 pour une latence de 5.8ms (à 256 Jack affiche 11.6 ms).
Merci encore pour tes très bons conseils !

Edit : Je viens d'acheter le PC et j'aimerais qu'il me fasse le plus longtemps possible (à vie serait parfait, mais j'n'y crois pas trop smile ) ; à descendre aussi bas "l'échantillon/période", je ne risque pas de fatiguer le processeur trop rapidement (ou la ram ou je n'sais quoi d'autre)  ?

Dernière modification par Woodnote (Le 01/03/2017, à 20:42)


(Ubuntu Studio 16.04.2)

Hors ligne

#9 Le 01/03/2017, à 22:12

xabilon

Re : [Résolu] Latence trop importante sous Ubuntu Studio

"System", c'est ta carte son. Tu as les entrées à gauche et les sorties à droite.
En fait, Jack fonctionne comme un rack de modules que tu branches les uns aux autres. Si tu branches les ports "System" de droite à ceux de gauche, tu rediriges l'entrée de la carte son sur la sortie.

Alsamixer se trouve dans le paquet alsa-utils, il ne fonctionne que en terminal. Normalement il doit être installé (tape alsamixer en terminal)

Pour désactiver la carte audio intégrée, il faut passer par le BIOS, mais si ça marche comme ça c'est pas nécessaire, Jack sait gérer plusieurs cartes son en même temps.
D'ailleurs il pourrait être intéressant d'utiliser la carte intégrée juste pour les sons système, et la Cakewalk pour la musique... mais ça c'est de la config plus avancée.

Ta carte son n'a pas l'air si basique que ça : il y a des gains d'entrée, un compresseur/limiteur et un switch haute impédance pour l'entrée 2.
Justement, cette entrée 2, avec le Hi-Z activé, est spécialement dédiée à brancher une guitare en direct, donc utilise-la (et n'oublie pas d'enclencher le Hi-Z).

L'espèce "d'aspiration" que tu as notée au début pourrait venir du compresseur/limiteur, mets-le sur OFF (ou sur BYPASS sur la face arrière), et surveille que la LED "Peak" ne s'allume pas pendant que tu joues.
Si elle s'allume, il faudra baisser le niveau d'entrée, je suppose que le potard "Sens" sert à ça.

Si tu travailles en 44100 Hz, n'oublie pas de mettre le switch "Samplerate" de la face arrière arrière en position correspondante (44.1).

Concernant le CPU, ne t'inquiète pas, une plus basse latence ne signifie pas un plus gros travail du CPU, mais moins de temps à attendre après avoir fait le calcul (qui reste le même quelque soit la latence).
Et puis même, ça représenterait pas grand chose...
5.8ms c'est excellent, c'est la même latence que si tu jouais sur ampli placé à 2m de tes oreilles... donc négligeable. Il est inutile de descendre plus bas.

Dernière modification par xabilon (Le 01/03/2017, à 22:20)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#10 Le 02/03/2017, à 07:40

krodelabestiole

Re : [Résolu] Latence trop importante sous Ubuntu Studio

xabilon a écrit :

L'espèce "d'aspiration" que tu as notée au début pourrait venir du compresseur/limiteur, mets-le sur OFF (ou sur BYPASS sur la face arrière), et surveille que la LED "Peak" ne s'allume pas pendant que tu joues.

ah oui bien vu wink

effectivement le temps de latence ne fait pas un effet d'"aspiration" ni de "wah-wah". le son est juste reproduit trop tard (mais le son est reproduit fidèlement en gardant l'attaque). et en dessous de 30ms il est négligeable pour une guitare (il commence à être gênant pour jouer de la batterie électronique par ex.)

le problème est donc à aller chercher ailleurs et en particulier vers d’éventuels effets de dynamiques (compresseur / limiteur) appliqués par défaut.

En ligne

#11 Le 02/03/2017, à 08:21

Woodnote

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Bonjour,
[] Ok pour "système" dans Jack qui correspond à ma carte son (je précise que mon casque est connecté à ma carte son, pas à mon pc). Effectivement, je m'en doutais un peu au vu des 2 sorties (capture_1 et capture_2) significatives dans "Ports de sortie. Par contre dans la colonne "port d'entrée", sous "system" sont nommés "playback_1 et playback-2. Malgré tout je n'arrive pas à savoir où est dissociée cette sortie casque dans ce tableau 'Sortie/ Entrée'.
Guitarix démarré, j'ai 4 noms d'affichés à gauche (sortie) et 4 à droite (entrée) identiques dans chaque colonne :
-gx_head_amp
-gx_head_fx
-Pulse Audio Jack Source
-System

Mais ceci concerne la partie AUDIO. Comme tu le sais Jack dispose des tableaux MIDI (je n'ai rien pour le moment de connecté en MIDI donc rien n'y apparaît) et ALSA où 2 noms à gauche et 2 à droite y sont apposés :
14:Midi Through
20:UA-25EX

Voilà pour la description que tu dois bien connaître, mais qui représente pour moi une forêt qui ainsi planté ci-dessus devrait permettre de situer cette fameuse sortie casque.

[] En ce qui concerne Alsamixer, il est bien installé. Je me demande si toutes les colonnes correspondent à ma carte son, en voici le détail :
Commmande : alsamixer
Master [00] : 34
Headphon [MM] : 0<>0 (tiens dois-je monter mon casque ici, où est-ce le niveau pour le 'casque' du PC ?)
PCM : 100<>100
FRONT [00] : 100<>100
FRONT MIC [MM]: 0<>0
FRONT MIC BO : 53<>53
SURROUND [00] : 100<>100
CENTER [00] : 100
LFE [00] : 100
LINE [MM] : 0<>0
LINE BOOST : 0<>0

Tiens, et je ne me rend compte seulement maintenant que tout ceci correspond à "Carte : HDA Intel PCH" qui doit être la carte son de ma carte mère ... Cependant en faisant F6 il m'est possible de choisir la carte son à visiter, le truc c'est que l'étape suivante affiche"Light Load" au millieu de l'écran que je peux déplacer en "Hight Load", mais aucune réaction ne s'opère quand j'appuie sur Entrée de mon clavier ...
Du coup, me suggère-tu de forcer l'arrêt de celle ci dans mon BIOS ? Ce serait dommage de ne pas aller vers la config plus avancée "Sytème/ Musique dont tu me fais l'esquisse.

[] J'ai branché ma guitare sur la piste 2 comme tu me l'as dit. A l'arrière de la carte son le "comp" est Bypass, et sur 44100 Hz. Les potards 'Sens' sont au minimum donc coupé ; j'entends cependant toujours une saturation lorsque j'attaque les cordes (à l'impact seulement) au médiator sur un son pourtant clair. Le témoin peak ne s'allume pourtant pas.

Merci aussi de me rassurer sur l'usage de mon matériel. D'ailleurs, quand j'allumerais Ardours (dont il va falloir que j'apprenne le fonctionnement) ou tout autre logiciel, devrais-je tout caller sur ce même ratio : échantillon 128 pour 5.8 ms ?


Edit : Je viens à l'instant de voir ton intervention krodelabestiole, donc merci à toi.
En tout cas, si c'est un problème de compression, ce n'est pas au niveau de ma carte son externe puisque j'ai le potard de celle ci sur off en plus d'être bypassé à l'arrière.

Dernière modification par Woodnote (Le 02/03/2017, à 10:02)


(Ubuntu Studio 16.04.2)

Hors ligne

#12 Le 02/03/2017, à 12:53

xabilon

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Effectivement  après recherche, alsamixer ne gère pas la carte, donc tu peux l'ignorer.
C'est Jack qui s'occupe de tout.
De la même façon tu peux ignorer Pulse Audio Jack Source, c'est le serveur son d'Ubuntu.

Tu ne verras pas la sortie casque dans Jack, c'est la carte son qui se charge d'envoyer ce qu'elle reçoit du PC vers la sortie casque, donc envoie capture_2 vers les playback 1 et 2 pour avoir l'entrée directement en sortie.
Pas la peine de t'occuper des onglets MIDI et ALSA (en fait les prises MIDI de ta carte son dans l'onglet ALSA).

As-tu activé le Hi-Z sur l'entrée 2 ? Si oui, joue avec le potard "Sens" tout en jouant, et écoute ce que ça change.

Et concernant Ardour, oui, lorsqu'une fréquence d'échantillonnage et un buffer sont choisis, ils le sont pour tous les logiciels. Ardour se calera probablement tout seul.

Edit : effectivement si tu n'as jamais fait de MAO (Musique Assistée par Ordinateur), la pente risque d'être un peu raide au début. On est là pour t'aider, tout comme l'excellent site francophone consacré à la MAO sous Linux : http://linuxmao.org/Accueil

Dernière modification par xabilon (Le 02/03/2017, à 12:57)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#13 Le 02/03/2017, à 16:01

Woodnote

Re : [Résolu] Latence trop importante sous Ubuntu Studio

J'ai connecté 'capture_2' vers 'playback 1 et 2'. (je ne vois pas de différence)
Le Hi-z est bien activé (bouton appuyé) sur l'entrée 2 qui, au vu du trait dessiné sur la carte son, ne concerne que cette entrée 2 (j'ai fait l'essai sur l'entrée 1 et aucun effet ne se produit quand j'appuie sur Hi-z). 
Plus je monte le potard 'Sens' plus il y a saturation, et pourtant il me permet de gagner un peu de volume qui sans lui est très faible (Ici, en son clair, j'ai l'impression de devoir m'en servir comme gain, d'observer les niveau des amplis virtuels et de ne pas rentrer dans le "rouge" pour ne pas saturer). Par contre sur les sons saturés, j'ai l'impression que si je ne joue pas un peu de ce potard, les effets ne sont pas autant prononcés (même impression en son clair).

Je résume la situation actuelle : les problèmes de latences sont complètement résolues.
Par contre j'ai toujours cette saturation anormale quand j'attaque les cordes, surtout en accord que j'arrive à éliminer avec le potard 'Sens'  et en tombant à un volume relativement faible, que je peux cependant compenser en montant le volume de mon Input au 3/4, jusqu'au taquet. J'ai pas trop de connaissance, mais ce doit être plus ou moins normal étant donné que je ne passe pas par un ampli...

Du coup, dois-je afficher ce post comme 'résolu' et continuer la discussion avec toi (si tu le veux bien) sur un autre fil (ou par un autre moyen) ; ou peut-on continuer ici nos échanges ?


(Et au fait, je suis pas sûr que tu m'ais répondu, plus besoin de toucher au BIOS car Jack gère parfaitement les 2 cartes son ?)
(Et quand tu me dis, "il pourrait être intéressant d'utiliser la carte intégrée juste pour les sons système, et la Cakewalk pour la musique... mais ça c'est de la config plus avancée." ; ça serait trop long à expliquer, trop difficile à faire ou pas ?)

Merci encore pour toutes tes réponses qui m'ont déjà permis d'avancer sur Ubuntu Studio et d'enregistrer un petit bout sur Ardour5 avec lequel je devrais vite me familiariser (j'ai même réussi à synchroniser une petite batterie "Hydrogene"), surtout pour la petite utilisation que je vais en avoir.

Dernière modification par Woodnote (Le 02/03/2017, à 16:04)


(Ubuntu Studio 16.04.2)

Hors ligne

#14 Le 02/03/2017, à 22:27

krodelabestiole

Re : [Résolu] Latence trop importante sous Ubuntu Studio

non ça sert à rien de toucher au bios. soit jack gère la carte son, soit pas. si il la gère on peut toujours la choisir au lieu de la carte intégrée. et en l'occurrence il semble là gérer.

à mon avis tu devrais mettre un vu-metre juste après ton entrée pour avoir un bon moniteur sur le gain en entrée (le dpm du jack meterbridge par ex.). tu tires un cable de capture_2 vers l'entrée meter_1 de "Meter Bridge Digital Peak Meter".
ta guitare est passive ou active ? (il y a une pile dedans ?)
le bouton "sens" c'est effectivement le réglage du gain (du préamp). donc effectivement pas besoin de "pregain" ou autre "preamp" dans guitarix ou rakarrack.

tu peux laisser "comp/limit" et "direct monitor" à zero.

En ligne

#15 Le 02/03/2017, à 23:01

xabilon

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Woodnote a écrit :

(Et quand tu me dis, "il pourrait être intéressant d'utiliser la carte intégrée juste pour les sons système, et la Cakewalk pour la musique... mais ça c'est de la config plus avancée." ; ça serait trop long à expliquer, trop difficile à faire ou pas ?)

Disons qu'il faut pas mettre la charrue avant les bœufs. Une fois familiarisé avec Jack, Alsa, etc... tu pourras tenter ça, mais c'est pas indispensable.

Tu dis que tu as réussi à enregistrer un bout de guitare dans Ardour... est-ce que l'enregistrement sature tout autant ?
Si ta guitare est passive (le plus courant), il est normal de devoir pas mal monter le gain pour avoir un bon signal, mais justement, ça ne devrait pas saturer.
Le tout est de trouver à quel endroit ça sature.
Le volume de ta guitare est-il au maximum ?

Peux-tu essayer avec un instrument à sortie de niveau ligne, comme un clavier (dans ce cas éteint le Hi-Z) ?

En revanche je ne comprends pas le rapport avec le gain d'entrée sur l'entrée 2, et le niveau des input 3/4... c'est censé être des entrées séparées...
Assure-toi aussi que le direct monitoring soit désactivé, sinon ce que tu entendras dans ton casque ce sera ta guitare... mais directement, sans passer par le PC.

Dernière modification par xabilon (Le 02/03/2017, à 23:03)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#16 Le 03/03/2017, à 07:55

Woodnote

Re : [Résolu] Latence trop importante sous Ubuntu Studio

@krodelabestiole, ok, je ne touche donc pas au BIOS. Très bonne idée pour le vu-metre dont je ne me suis jamais servi, mais ce doit être d'un usage relativement instinctif ; et merci pour les câblages. J'ai une Strat tout à fait classique, donc passive.

@Xabilon, finalement jack n'a pas l'air très compliqué surtout qu'il câble tout automatiquement. Je me disais que la manip à laquelle tu penses pourrais peut-être me permettre d'avoir du son sur une page internet (un tuto sur youtube par ex.) tout en ayant JAck allumé. Ce qui, comme tu le sais, n'est pas le cas.

Avant que je ne comprenne que le potard SENS n'était ni plus ni moins ce que Krodelabestiole me permet de nommer 'Pré-gain', oui, j'ai fait le test et la guitare saturait bel et bien encore une fois enregistrée (même si au début j'ai cru que ce n'était pas le cas, tout simplement parce que le 'volume' guitare dans Ardour était plus faible).

Ce que je dois monter quasi à font (ou 3/4) pour avoir un son qui commence à être fort (donc suffisant) dans le casque, c'est l''Input' (le potard en haut à droite de la carte son comme tu peux voir sur le lien susmentionné menant à ma carte son Cakewalk), ce que j'imagine être le 'master' en terme pro (?)
Le volume de ma guitare est bien sûr au maxi. Je n'ai pas d'autre instrument chez moi pour faire le test que tu proposes ; je pensais me trouver un petit clavier midi prochainement pour pouvoir jouer des basses avec des vrais sons de basse impossible à faire avec une guitare. Je dispose d'un micro, ça fera l'affaire ?

Quant à ton questionnement "je ne comprends pas le rapport avec le gain d'entrée sur l'entrée 2, et le niveau des input 3/4... c'est censé être des entrées séparées..." ; on y a, je crois, répondu en observant que le SENS est un 'pré-gain', plus je monte, plus sa sature ; mais aussi, me semble t-il en tout cas, mieux j'entends les effets.

Je teste maintenant avec le vu-metre que j'ai connecté préalablement à ma carte son avec jack (là pour le coup ça me fait mentir, jack ne le connecte pas automatiquement).
En fait ça commence à saturer dès que je passe le premier quart du potard SENS, ce qui correspond à peu près à la gradation "40" (un peu en dessous. J'ai tout de même l'impression que plus je monte le volume (Input) plus je peux monter (mais très légèrement) le SENS. De toute façon, même SENS coupé complètement, j'entend, selon les sons de Guitarix, une saturation.

J'ai bien envie d'essayer avec la tête (JVM 205h) de mon ampli de scène voir ce que ça donne. Mais la sortie Xlr à l'arrière de celui-ci envoie un très haut niveau ; je me souviens lors de mon dernier enregistrement studio (petit, mais fort sympathique), l'ingé n'avait pas pu laisser le branchement xlr comme je lui demandais pour pouvoir mixer mes prises avec différentes sorties parce qu'à sa table il recevait trop de gain, rendant inexploitable cette voie.

Encore merci à tous les deux.

(Edit : Je branche ma tête d'ampli à ma carte son par xlr, mais je n'arrive à sortir qu'un tout petit peu de son au casque à la condition d'allumer le 'Direct Monitor' (avec pas mal de souffle) ; sans ça rien. Dans cette config, JAck à t-il encore un rôle à jouer ?
(Dans 'paramètre sonore' je vois dans les 'périphérique d'entrée" positionné sur 'Edirol Ua 25 Ex' qu'un signal passe... )

Dernière modification par Woodnote (Le 03/03/2017, à 08:40)


(Ubuntu Studio 16.04.2)

Hors ligne

#17 Le 03/03/2017, à 09:13

krodelabestiole

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Woodnote a écrit :

l''Input' (le potard en haut à droite de la carte son comme tu peux voir sur le lien susmentionné menant à ma carte son Cakewalk), ce que j'imagine être le 'master' en terme pro (?)

je vois pas de potard input sur la carte... tu parles du potard "output" ?
j'aurais pensé que ça correspond au volume de ta carte en sortie (les sorties jack ou rca derrière), donc en principe ce que tu envoies à tes enceintes. mais visiblement ça concerne aussi (ou seulement ?) la sortie casque. dans tous les cas c'est normal qu'il faille le pousser un peu : à zero c'est sensé être silencieux.

bon je viens de voir la face arrière de ta carte.
pour comp/limit type tu mets sur bypass
pour phantom off
le sample rate c'est comme tu veux (ce doit être le même que dans jack). ça a habituellement pas grand intérêt de pousser au dessus de 48kHz (et ça bouffera plus de cpu).
advanced driver : aucune idée

des vu-metre juste après l'entrée et/ou juste avant la sortie vers la carte son pourront nous permettre d'en savoir plus.

En ligne

#18 Le 03/03/2017, à 09:22

krodelabestiole

Re : [Résolu] Latence trop importante sous Ubuntu Studio

si tu utilises seulement un casque il faudrait aussi voir en quoi consiste le mon sw (monitor switch probablement).

vu qu'il y a qu'une entrée (stereo) et une sortie (stereo) je vois pas trop entre quoi et quoi il peut switcher... je suppose justement vers le direct monitor qui te permet d'écouter ce qui entre directement depuis l'entrée ?

En ligne

#19 Le 03/03/2017, à 09:29

krodelabestiole

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Woodnote a écrit :

Je teste maintenant avec le vu-metre que j'ai connecté préalablement à ma carte son avec jack (là pour le coup ça me fait mentir, jack ne le connecte pas automatiquement).
En fait ça commence à saturer dès que je passe le premier quart du potard SENS, ce qui correspond à peu près à la gradation "40" (un peu en dessous. J'ai tout de même l'impression que plus je monte le volume (Input) plus je peux monter (mais très légèrement) le SENS. De toute façon, même SENS coupé complètement, j'entend, selon les sons de Guitarix, une saturation.

c'est le même résultat avec et sans Hi-Z ?
Tu parles toujours de "output" ?

Woodnote a écrit :

J'ai bien envie d'essayer avec la tête (JVM 205h) de mon ampli de scène voir ce que ça donne. Mais la sortie Xlr à l'arrière de celui-ci envoie un très haut niveau ; je me souviens lors de mon dernier enregistrement studio (petit, mais fort sympathique), l'ingé n'avait pas pu laisser le branchement xlr comme je lui demandais pour pouvoir mixer mes prises avec différentes sorties parce qu'à sa table il recevait trop de gain, rendant inexploitable cette voie.

en principe tu peux sans problème, essaie avec sens à zero (niveau d'entrée max de carte +12dB, la tête d'ampli devrait pas te sortir plus que + 4db sur un xlr niveau line).

En ligne

#20 Le 03/03/2017, à 09:37

krodelabestiole

Re : [Résolu] Latence trop importante sous Ubuntu Studio

pour rappel tu entres la guitare dans l'input 2, tu moulines le tout avec jack et guitarix, et depuis la sortie jack L à l'arrière de ta carte tu tires un cable vers ta tête d'ampli, c'est bien ça ?

dans ce cas pour monitorer le plus simplement du monde ça serait une bonne idée de brancher ton casque sur cette sortie L (tu n'auras le son que d'un côté mais on sera sûr de ce qu'on monitor).

En ligne

#21 Le 03/03/2017, à 09:38

krodelabestiole

Re : [Résolu] Latence trop importante sous Ubuntu Studio

et hésites pas à envoyer un screenshot de ton câblage dans jack

En ligne

#22 Le 03/03/2017, à 10:58

Woodnote

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Oui, c'est le potard 'Output' et non 'Inpout'(qui n'existe pas d'ailleurs) comme je l'ai mentionné dans mes autres commentaires ; dsl, du haut de ma chaise je ne voyais que le 'put' de 'Ouput', j'ai donc mal déduit ce qui précédait ces trois lettres 'put' ...

Pas de différence avec ou sans Hi-z.

Au sujet de ma tête d'ampli, tu me dis :

"pour rappel tu entres la guitare dans l'input 2, tu moulines le tout avec jack et guitarix, et depuis la sortie jack L à l'arrière de ta carte tu tires un cable vers ta tête d'ampli, c'est bien ça ?"

Non, j'ai une sortie Xlr à l'ampli que je branche en façade xlr dans mon 'entrée 2' (comme précédemment je le faisais avec mon jack guit. [les 2 connectiques (jack/ xlr) par entrée existent]) ; ensuite je branche un jack guitare comme en live à mon ampli (dans son input). Mais comme je le dis dans la redit de mon com précédent :
"Je branche ma tête d'ampli à ma carte son par xlr, mais je n'arrive à sortir qu'un tout petit peu de son au casque à la condition d'allumer le 'Direct Monitor' (avec pas mal de souffle) ; sans ça rien."

Et du coup je vous demande :
"Dans cette config, JAck à t-il encore un rôle à jouer ?"
histoire de savoir si je dois faire une manip là ou pas. Même si je ne vois pas trop ce que JackAudioConn.. aurait à gérer ici.

Et je précise que :
"(Dans 'paramètre sonore' [qui n'est autre que le 'contrôle volume' de Pulsaudio je crois] je vois dans les 'périphérique d'entrée" positionné sur 'Edirol Ua 25 Ex' qu'un signal passe... )"


A noter que je n'ai pas d'enceinte, je ne dispose que d'un casque !

Edit : Je viens de remarquer que le signal reçu que je peux observer dans  'paramètre sonore' (dont je parle plus haut)  est bien plus fort que quand je passe par ma tête d'ampli (avec les branchements que je fais en tout cas). Quand je n'ai que JackAudio d'ouvert, que je branche (dans Jack) mon 'entrée 2' (Input 2/R sur ma carte)  du port de sortie vers Playback 1et 2 des ports d'entrée, je peux, en ayant le volume à midi (mon outpout à la carte son) m'entendre raisonnablement, sans aucun effet bien évidemment. Mais ce qui est intéressant, c'est que dans cette config, je peux monter le potard sens à moitié sans que ça ne sature ; si je monte encore un peu plus le son sature mais de plus une diode s'éclaire en rouge pour me signifier que j'atteins un pic à ne pas dépasser. Quand Guitarix est allumé, cette diode ne se déclenche que bien après que j'eusse entendu la saturation dans le casque en montant le potard SENS, à tel point que pour vérifier quelle fonctionne bien dans cette nouvelle config (Guitarix allumé) je dois pousser le potard SENS au 3/4 ...

Dernière modification par Woodnote (Le 03/03/2017, à 11:30)


(Ubuntu Studio 16.04.2)

Hors ligne

#23 Le 03/03/2017, à 11:37

xabilon

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Ouf, j'ai du mal à suivre...
Si tu passes par la DI d'une tête d'ampli pour attaquer la carte son, le Hi-Z est inutile.

J'avais confondu "3/4" (trois quarts) avec "input 3/4" (entrées 3 et 4)... qui n'existent pas sur ta carte, d'où mon incompréhension smile

Tu ne peux pas trop te fier au niveau de la sortie casque, il est faiblement représentatif de ce qui se passe en amont (sauf si tu enclenches le direct monitoring, qui te permet d'écouter directement ce qui rentre dans la carte, sans passer par le PC). En outre, la carte étant alimentée par le PC en USB, il est normal qu'elle soit un peu limitée en volume à la sortie du casque.
Autre détail, le potard Output ne gère que le volume du casque, pas le niveau de sortie de la carte (les 2 prises jack L/R à l'arrière).

Si déjà en direct monitoring tu as un mauvais son, ça n'a rien à voir avec le PC, Ubuntu Studio ni Jack. Pour le souffle essaye le Ground Lift sur la face arrière, mais si tu as un petit son et plein de souffle, c'est que la sortie de la tête d'ampli est trop faible plutôt que trop forte.

Edit : la technique pour bien régler les gains quand il y a une longue chaîne comme ici, c'est d'y aller étape par étape, de la source du son jusqu'à l'arrivée, régler le gain à chaque étape, pour qu'il soit suffisamment au-dessus du souffle mais sans que ça sature (même en jouant fort de gros accords à vide).
Une fois un gain réglé, tu passes au suivant, sans plus toucher au premier.

Dernière modification par xabilon (Le 03/03/2017, à 11:41)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#24 Le 03/03/2017, à 11:39

krodelabestiole

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Woodnote a écrit :

Non, j'ai une sortie Xlr à l'ampli que je branche en façade xlr dans mon 'entrée 2' (comme précédemment je le faisais avec mon jack guit. [les 2 connectiques (jack/ xlr) par entrée existent]) ;

si tu branches la tête d'ampli, vire Hi-Z. Mets le seulement pour la guitare directe.

Woodnote a écrit :

"Je branche ma tête d'ampli à ma carte son par xlr, mais je n'arrive à sortir qu'un tout petit peu de son au casque à la condition d'allumer le 'Direct Monitor' (avec pas mal de souffle) ; sans ça rien."

Je pense que le direct monitor ne te donnera que le signal qui entre, pas celui qui a été mouliné par ton ordi.

Woodnote a écrit :

"Dans cette config, JAck à t-il encore un rôle à jouer ?"

Ben du coup je pense pas, mais j'ai jamais utilisé ta carte son. Check dans le manuel si direct monitor concerne bien l'écoute directe de l'entrée (c'est ce qui ferait le plus de sens).
Dans ce cas le problème du souffle vient probablement de la carte elle-même (puisque tu as le problème avec la guitare ET avec la tête).
Pour être sûr : le son de la guitare est ok sur l'ampli ?

Woodnote a écrit :

"(Dans 'paramètre sonore' [qui n'est autre que le 'contrôle volume' de Pulsaudio je crois] je vois dans les 'périphérique d'entrée" positionné sur 'Edirol Ua 25 Ex' qu'un signal passe... )"

Dans un premier temps pour utiliser Jack il faut arrêter Pulseaudio. Donc en principe tu ne devrait rien voir ce ce côté là si Jack tourne avec ta carte son. Des captures de tes écrans de config pourraient nous aider à ce sujet.

En ligne

#25 Le 03/03/2017, à 11:46

krodelabestiole

Re : [Résolu] Latence trop importante sous Ubuntu Studio

Et puis je vois pas trop l’intérêt de ta tête d'ampli dans cette config.
Il me semble que tu ferais mieux d'en rester à ton premier setup : la guitare direct dans la carte son.

Comme ça tu peux brancher la sortie de ta carte à l'ampli et t'écouter avec autre chose qu'un casque cool

Donc restons-en peut-être au debug de cette version, non ?

En ligne