Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 20/02/2017, à 12:19

Romuald-25

Erreur de bibliothèque photofiltre

Bonjour,

Après avoir installé la version linux de photofiltre, (https://doc.ubuntu-fr.org/photofiltre), j'ai voulu le démarrer par la commande que me donna le raccourci sur le bureau mais ça ne marche pas.
En effet, dans un terminal:

matthias@matthias-Aspire-V3-771:~$ PhotoFiltre-LX-Studio %f
PhotoFiltre-LX-Studio: error while loading shared libraries: libGraphicsMagick++-Q16.so.12: cannot open shared object file: No such file or directory
matthias@matthias-Aspire-V3-771:~$ 

J'avais eu des problèmes similaires avec un logiciel appelé autopano mais j'avais pu facilement trouver la bibliothèque manquante et l'installer, or là je n'obtiens pas de résultats probants pour cette bibliothèque à nom à rallonge.

Des idées ? Quelqu'un aurait-il de l'expérience sur le sujet ? Merci.

Dernière modification par Romuald-25 (Le 20/02/2017, à 12:20)


ACER-V3 771G / Intel Core i5 3230M 2.6GHz / NVIDIA GeForce 710M / 8GB RAM/ 2HDD WD 750 & 500GB / Windows 8.1 et Xubuntu 16.04.2
« On mesure l'intelligence d'un individu à la quantité d'incertitudes qu'il est capable de supporter. »  Emmanuel Kant

Hors ligne

#2 Le 20/02/2017, à 12:50

Romuald-25

Re : Erreur de bibliothèque photofiltre

Bon. J'ai avancé. En voulant mettre à jour InkScape, l'ordinateur m'a proposé tout seul de corriger le problème.

Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 photofiltre-lx-studio : Dépend: libgraphicsmagick++-q16-12 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
matthias@matthias-Aspire-V3-771:~$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  asymptote-doc bzr calligra-l10n-engb calligra-l10n-fr cinnamon-desktop-data
  gjs gstreamer1.0-plugins-bad-faad gstreamer1.0-plugins-bad-videoparsers
  hyphen-en-gb iucode-tool junit4 kde-l10n-engb kde-l10n-fr lib32gcc1
  libcinnamon-desktop4 libcommons-collections3-java libcommons-math-java
  libcuda1-340 libde265-0 libfreehand-0.1-1 libfreehep-graphicsio-pdf-java
  libfreehep-graphicsio-svg-java libfreehep-xml-java libgjs0e
  libgstreamer-plugins-bad1.0-0 libhamcrest-java libjas-java libjcommon-java
  libjfreechart-java libjfugue-java libmimic0 libmms0 libmozjs-24-0v5
  libmspub-0.1-1 libofa0 libomxil-bellagio-bin:i386 libomxil-bellagio0:i386
  libopencv-contrib2.4v5 libosmesa6 libpagemaker-0.0-0 libreoffice-base-core
  libreoffice-l10n-en-za libsbc1 libspandsp2 libvo-aacenc0 libvo-amrwbenc0
  libwildmidi1 libxvmc1:i386 libzbar0 linux-headers-4.4.0-21
  linux-headers-4.4.0-21-generic linux-headers-4.4.0-45
  linux-headers-4.4.0-45-generic linux-headers-4.4.0-47
  linux-headers-4.4.0-47-generic linux-headers-4.4.0-51
  linux-headers-4.4.0-51-generic linux-headers-4.4.0-57
  linux-headers-4.4.0-57-generic linux-image-4.4.0-21-generic
  linux-image-4.4.0-45-generic linux-image-4.4.0-47-generic
  linux-image-4.4.0-51-generic linux-image-4.4.0-57-generic
  linux-image-extra-4.4.0-21-generic linux-image-extra-4.4.0-45-generic
  linux-image-extra-4.4.0-47-generic linux-image-extra-4.4.0-51-generic
  linux-image-extra-4.4.0-57-generic linux-signed-image-4.4.0-45-generic
  linux-signed-image-4.4.0-47-generic linux-signed-image-4.4.0-51-generic
  linux-signed-image-4.4.0-57-generic mathpiper mypaint-data mythes-en-au
  nvidia-opencl-icd-340 ocl-icd-libopencl1 python-bzrlib python-cssutils
  python-gpgme python-keyring python-launchpadlib python-lazr.restfulclient
  python-lazr.uri python-oauth python-pocket-lint python-secretstorage
  python-simplejson python-wadllib xserver-xorg-legacy
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  libgraphicsmagick++-q16-12
Paquets suggérés :
  graphicsmagick-dbg
Les NOUVEAUX paquets suivants seront installés :
  libgraphicsmagick++-q16-12
0 mis à jour, 1 nouvellement installés, 0 à enlever et 2 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 101 ko dans les archives.
Après cette opération, 521 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 libgraphicsmagick++-q16-12 amd64 1.3.23-1build1 [101 kB]
101 ko réceptionnés en 1s (98,4 ko/s)                
Sélection du paquet libgraphicsmagick++-q16-12 précédemment désélectionné.
(Lecture de la base de données... 746153 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libgraphicsmagick++-q16-12_1.3.23-1build1_amd64.deb ...
Dépaquetage de libgraphicsmagick++-q16-12 (1.3.23-1build1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...
Paramétrage de libgraphicsmagick++-q16-12 (1.3.23-1build1) ...
Paramétrage de photofiltre-lx-studio (1.2.0~yakkety1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...
matthias@matthias-Aspire-V3-771:~$

Mais maintenant j'ai un autre problème encore plus alambiqué:

matthias@matthias-Aspire-V3-771:~$ PhotoFiltre-LX-Studio %f
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5WebKitWidgets.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5Network.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.6' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
matthias@matthias-Aspire-V3-771:~$ 

et même un

sudo apt-get install qt5-default

ne corrige pas le problème.

Dernière modification par Romuald-25 (Le 20/02/2017, à 12:58)


ACER-V3 771G / Intel Core i5 3230M 2.6GHz / NVIDIA GeForce 710M / 8GB RAM/ 2HDD WD 750 & 500GB / Windows 8.1 et Xubuntu 16.04.2
« On mesure l'intelligence d'un individu à la quantité d'incertitudes qu'il est capable de supporter. »  Emmanuel Kant

Hors ligne

#3 Le 09/03/2017, à 21:52

Lilie_G

Re : Erreur de bibliothèque photofiltre

Bonjour Romuald-25,

j'ai exactement le même problème que toi :

PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5WebKitWidgets.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5Network.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.6' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)
PhotoFiltre-LX-Studio: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version `Qt_5' not found (required by PhotoFiltre-LX-Studio)

As-tu trouvé un solution? Quelqu'un d'autre a-t-il une solution?

En vous remerciant d'avance,

Lilie

Hors ligne

#4 Le 23/03/2017, à 11:43

4sStylZ

Re : Erreur de bibliothèque photofiltre

Même problème ici sur un Elementary OS Loki.

Hors ligne