Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 10/01/2016, à 13:38

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

nam1962 a écrit :

..en fait, pas exactement.
Ce fil suppose que l'utilisateur passe un autoremove.

Oui et non. dans les duplicates, il y a ce fil qui laisse bon espoir quant à une future automatisation.
Bon, il y a aussi celui-ci où j’avoue ne pas savoir si la résolution est effective ou non car il est passé régulièrement de released à comitted et inversement.

Quant à la gestion des noyaux dans Arch, je ne développerai pas dans ce fil car ce n’est pas le sujet (ce n’est d’ailleurs pas le sujet de ce forum). wink



grandtoubab a écrit :

Salut,
Pour moi tout est déja prévu dans apt  pour automatiser

2 fichiers pour définir ce qui va être ou non supprimé:

root@desktop:/# locate *autoremove*
/etc/apt/apt.conf.d/01autoremove
/etc/apt/apt.conf.d/01autoremove-kernels

Généré par le script de post install

/etc/kernel/postinst.d/apt-auto-removal

[…]

Oui, et si tu as lu ma procédure, je fais appel au script de post-install à un moment car il y avait un bug (initialisé par nam1962, d’ailleurs) que j’ai la flemme de rechercher et je ne sais donc pas s’il est résolu. De toute façon, ça ne mange pas de pain de relancer ce script afin d’être sûr que tout soit correct.
Ensuite, je pointe un bug où les paquets de noyaux peuvent être marqués comme installés manuellement et l’autoremove n’aura pas d’effet sur ceux-ci.
Enfin, j’avais prévu de mettre un message de plus pour l’automatisation en paramétrant justement unattented-upgrade mais comme tous ces bugs sont déjà bien avancés dans leur résolution, j’y ai renoncé car je pense que tout ceci sera réglé dans les prochains mois. Ce fil n’aura alors plus de raison d’être (kclean non plus qui aura pourtant bien vécu).
Quant à la raison de ce fil, il s’agit d’abord de débloquer les personnes qui, faute d’être suffisamment informées, se retrouvent dans une situation inextricable. En effet, pour conduire une voiture, on ne demande pas aux gens d’avoir un CAP de mécanicien automobile mais seulement un permis de conduire. wink

Dernière modification par nany (Le 11/01/2016, à 22:50)


Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne

#27 Le 13/01/2016, à 12:30

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Mise à jour : ajout d’une troisième commande magique après confirmation de mes doutes sur le cas du répertoire /boot plein.


Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne

#28 Le 13/01/2016, à 15:05

moko138

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

"après confirmation de mes doutes" :
S'il te plaît, de quels doutes parles-tu ?
Parce que dans le cas que tu mentionnes :

sdaN   ext2       237M    227M   0   100%   /boot

je ne vois que du classique.    Merci !


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#29 Le 14/01/2016, à 19:56

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Eh bien mes doutes se portent sur la valeur à partir de laquelle le remplissage de /boot est bloquant.
En effet, d’après ce message (merci à cardabelle d’avoir rendu le fil cacophonique en squattant le fil d’un autre roll) que 77% peuvent suffire à bloquer la situation. Mais je pense que dans ce cas l’autoremove peut suffire à condition de s’assurer auparavant que les paquets sont en automatique.
En revanche, dans le cas d’une valeur inférieure mais suffisamment élevée, je pense que le calcul d’espace nécessaire n’est pas correct (du moins, pas assez pointu) et lance l’installation de la dernière version du noyau qui n’aboutit malheureusement pas en remplissant /boot à 100% et se retrouve avec des paquets qui ne sont pas complètement installés.


Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne

#30 Le 16/01/2016, à 13:53

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

nany a écrit :

À noter que les paquets tools sont apparemment relativement récents et ne sont actuellement pas pris en charge par kclean. J’ai proposé un patch à hoper qui doit faire une nouvelle version très prochainement.

La nouvelle version de kclean viens de sortir. wink


Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne

#31 Le 16/01/2016, à 15:20

xubu1957

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Bonjour,
Après passage de Kclean, j'obtiens:

dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)"
ii  linux-generic-lts-vivid                    3.19.0.43.28                            i386         Complete Generic Linux kernel and headers
ii  linux-headers-3.19.0-42                    3.19.0-42.48~14.04.1                    all          Header files related to Linux kernel version 3.19.0
ii  linux-headers-3.19.0-42-generic            3.19.0-42.48~14.04.1                    i386         Linux kernel headers for version 3.19.0 on 32 bit x86 SMP
ii  linux-headers-3.19.0-43                    3.19.0-43.49~14.04.1                    all          Header files related to Linux kernel version 3.19.0
ii  linux-headers-3.19.0-43-generic            3.19.0-43.49~14.04.1                    i386         Linux kernel headers for version 3.19.0 on 32 bit x86 SMP
ii  linux-headers-generic-lts-vivid            3.19.0.43.28                            i386         Generic Linux kernel headers
ii  linux-image-3.19.0-42-generic              3.19.0-42.48~14.04.1                    i386         Linux kernel image for version 3.19.0 on 32 bit x86 SMP
ii  linux-image-3.19.0-43-generic              3.19.0-43.49~14.04.1                    i386         Linux kernel image for version 3.19.0 on 32 bit x86 SMP
ii  linux-image-extra-3.19.0-42-generic        3.19.0-42.48~14.04.1                    i386         Linux kernel extra modules for version 3.19.0 on 32 bit x86 SMP
ii  linux-image-extra-3.19.0-43-generic        3.19.0-43.49~14.04.1                    i386         Linux kernel extra modules for version 3.19.0 on 32 bit x86 SMP
ii  linux-image-generic-lts-vivid              3.19.0.43.28                            i386         Generic Linux kernel image
ii  linux-tools-3.19.0-42-generic              3.19.0-42.48~14.04.1                    i386         Linux kernel version specific tools for version 3.19.0-42
ii  linux-tools-3.19.0-43-generic              3.19.0-43.49~14.04.1                    i386         Linux kernel version specific tools for version 3.19.0-43
ii  linux-tools-common                         3.13.0-74.118                           all          Linux kernel version specific tools for version 3.13.0
ii  linux-tools-virtual-lts-vivid              3.19.0.43.28                            i386         This package will always depend on the latest minimal generic kernel tools.
regis@regis-Aspire-9410:~$ 

Par rapport au # 14

ii  linux-tools-3.19.0-41-generic              3.19.0-41.46~14.04.2 

est bien supprimé.

Merci à Hoper et à nany pour cette amélioration du nettoyage !

Cordialement


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#32 Le 24/02/2016, à 17:37

moko138

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

nany a écrit :

Eh bien mes doutes se portent sur la valeur à partir de laquelle le remplissage de /boot est bloquant.
En effet, d’après ce message (merci à cardabelle d’avoir rendu le fil cacophonique en squattant le fil d’un autre roll) que 77% peuvent suffire à bloquer la situation. Mais je pense que dans ce cas l’autoremove peut suffire à condition de s’assurer auparavant que les paquets sont en automatique.
En revanche, dans le cas d’une valeur inférieure mais suffisamment élevée, je pense que le calcul d’espace nécessaire n’est pas correct (du moins, pas assez pointu) et lance l’installation de la dernière version du noyau qui n’aboutit malheureusement pas en remplissant /boot à 100% et se retrouve avec des paquets qui ne sont pas complètement installés.

nany, avant que je ne redémarre la machine concernée (le problème est réglé par une simple purge manuelle du noyau N-2) es-tu intéressé(e) par des infos complémentaires ?

     Situation initiale :
Partition boot (Xubuntu 14.04.4) de 140 Mio exactement (*) avec deux noyaux

:~$ df -Th | grep -Ev "tmpfs|none|udev"
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
/dev/sdb5        ext4       5,8G    3,6G  2,0G  65% /
/dev/sdb2        ext4       103G     26G   73G  27% /data2
/dev/sdb1        ext2       136M     80M   49M  63% /boot

:~$ df -Ti | grep -Ev "tmpfs|none|udev"
Sys. de fichiers Type      Inœuds IUtil.  ILibre IUti% Monté sur
/dev/sdb5        ext4      385536 238361  147175   62% /
/dev/sdb2        ext4     6864896   3768 6861128    1% /data2
/dev/sdb1        ext2       36720    313   36407    1% /boot

Puis

dist-upgrade
(...)
Paramétrage de cpio (2.11+dfsg-1ubuntu1.2) ...
Paramétrage de linux-image-extra-3.13.0-79-generic (3.13.0-79.123) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-79-generic /boot/vmlinuz-3.13.0-79-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-79-generic /boot/vmlinuz-3.13.0-79-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-79-generic
gzip: stdout: No space left on device

suite :

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.13.0-79-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-extra-3.13.0-79-generic (--configure):
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de linux-image-generic :
 linux-image-generic dépend de linux-image-extra-3.13.0-79-generic ; cependant :
 Le paquet linux-image-extra-3.13.0-79-generic n'est pas encore configuré.

dpkg: error processing package linux-image-generic (--configure):
 problèmes de dépendances - laissé non configuré
Paramétrage de linux-headers-3.13.0-79 (3.13.0-79.123) ...
Paramétrage de linux-headers-3.13.0-79-generic (3.13.0-79.123) ...
Paramétrage de linux-headers-generic (3.13.0.79.85) ...
dpkg: des problèmes de dépendances empêchent la configuration de linux-generic :
 linux-generic dépend de linux-image-generic (= 3.13.0.79.85) ; cependant :
 Le paquet linux-image-generic n'est pas encore configuré.

dpkg: error processing package linux-generic (--configure):
 problèmes de dépendances - laissé non configuré
Paramétrage de linux-libc-dev:i386 (3.13.0-79.123) ...
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-extra-3.13.0-79-generic
 linux-image-generic
 linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
:~$ 

---------
(*) df affiche "136M", en réalité, j'ai formaté à 140 Mio (vérifié dans gparted après coup) et il semble que df compte en Gio, multiplie par 1000 et arrondisse à l'entier inférieur :
140 Mio * 1000 / 1024 = 136,71875


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#33 Le 24/02/2016, à 17:53

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Mmmh… Il faudrait maintenant voir un nouveau retour de df -Th. Je pense que ça a dû passer à 100%.
Mais, a priori, je ne pense pas que ça pourra permettre de déterminer un « seuil de déclenchement ».


Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne

#34 Le 24/02/2016, à 18:22

moko138

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Juste après le blocage, 90% de 140 Mio :

df -Th | grep -Ev "tmpfs|none|udev"
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
/dev/sdb5        ext4       5,8G    4,0G  1,6G  73% /
/dev/sdb2        ext4       103G     26G   73G  27% /data2
/dev/sdb1        ext2       136M    116M   14M  90% /boot

  Et après la purge manuelle du N-2, automatiquement suivie de la fin de l'installation du N, retour à 63% :

df -Th | grep -Ev "tmpfs|none|udev"
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
/dev/sdb5        ext4       5,8G    3,8G  1,8G  68% /
/dev/sdb2        ext4       103G     26G   73G  27% /data2
/dev/sdb1        ext2       136M     80M   49M  63% /boot

  - -
J'ai laissé ouverts tous les onglets du terminal.
Donc si tu veux d'autres infos...?


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#35 Le 24/02/2016, à 18:44

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Bon ben, ce qui apparaît clair là-dedans, c’est que 140Mio ne suffisent pas pour loger trois noyaux (pour pouvoir ensuite supprimer le plus ancien). Après une rapide recherche de différents retours de df sur le forum, il m’apparaît que l’installation automatique donne 236M (je suppose 240Mio).
Si j’ai bien compris, c’est toi qui as donné cette taille à la partition. Je te conseille donc de l’agrandir si tu n’as pas envie de mettre les mains dans le cambouis à chaque mise à jour de noyau. tongue
Du coup, cette configuration ne m’éclaire pas plus sur un pourcentage minimal éventuel.


Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne

#36 Le 24/02/2016, à 18:59

jplemoine

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Dans l'installation classique (#250 Mo), de mémoire, c'est le 5ième qui bloque...
En première approche, Il faut donc compter 50 Mo par noyau... Et donc, effectivement à 140 Mo, il manque un petit bout pour le 3ième noyau.


Compte volontairement inactif
Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre) et de ALDI4 (Atelier Libre d'Informatique du 4ième)

Hors ligne

#37 Le 24/02/2016, à 22:08

moko138

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

nany a écrit :

Si j’ai bien compris, c’est toi qui as donné cette taille à la partition.

Oui.

nany a écrit :

Je te conseille donc de l’agrandir si tu n’as pas envie de mettre les mains dans le cambouis à chaque mise à jour de noyau. tongue
Du coup, cette configuration ne m’éclaire pas plus sur un pourcentage minimal éventuel.

J'aime mettre les mains dans le cambouis, mais là c'était en-dessous de mon objectif  "avoir une /boot minimale, avec un peu de marge".
Donc oui, j'agrandis.
Mais je ne comprends pas pourquoi tu raisonnes en pourcentage et non en octets, puisque dans le cas d'une utilisation saine, façon kclean -k, ce sont les octets qui manquent, pas les i-noeuds. Sans doute ai-je mal compris ta démarche.
  Peux-tu m'éclairer, s'il te plaît?
  - -
  En attendant, j'ai réfléchi et je pense que c'est de peu que je me suis raté.
1) Calcul:
a) Je m'étais basé sur les noyaux 3.2 qui sont, à la louche, 10% plus petits que les 3.13.
b) Je n'avais pas encore compris la minoration des tailles affichées par df (cf.fin du #32).
c) Il n'est pas exclu que j'ai oublié les 5% de /lost+found/.
  Ce qui me ferait une erreur de 13 ou de 18%. Donc il faudrait que j'agrandisse /boot à 165Mio.

2) Expérience:
D'après /var/log/term.log, le 9/2/2016, j'avais 3.13.0-74 et 3.13.0-24.

D'après /var/log/apt/history.log, le 10/2, j'avais d'abord installé 3.13.0-77; 3.13.0.74 s'était (pourquoi???) mis à jour - notons que ce jour-là, l'installation d'un troisième noyau s'était bien passée -  et enfin j'avais purgé 3.13.0-24.

Voilà pourquoi je pense que c'est de peu que je me suis raté.
  - -
Donc, en attendant de te lire, j'ai déjà ajouté à /boot les 8Mio (-->148Mio) qui la séparaient de la partition suivante.
Ce ne sera sans doute pas toujours suffisant (*), mais bon:
c'est provisoire et le cambouis ne devrait pas aller plus loin qu'un chroot big_smile
Ah! mes nouilles ont fini de cuire (au jus de canne): je vais vous égoutter ça.

-----------
AJOUT 18/3/16:
Après petit agrandissement de /boot, de 140 à 148Mio,
L'installation d'un 3ème noyau (3.13.0-83-generic) (les 64bits sont-ils plus gros?) se passe bien
df -Th indique     144M           116M    21M            85% /boot
gparted indique   148,00Mio   119,91   28,09   (20,60 en déduisant lost+found/)

-----------
(*) Sept mois plus tard, la /boot à 148 Mio a toujours pu supporter l'installation d'un troisième noyau 3.13 (32 bits).

Dernière modification par moko138 (Le 16/10/2016, à 12:18)


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#38 Le 25/02/2016, à 00:02

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

moko138 a écrit :

Mais je ne comprends pas pourquoi tu raisonnes en pourcentage et non en octets, puisque dans le cas d'une utilisation saine, façon kclean -k, ce sont les octets qui manquent, pas les i-noeuds. Sans doute ai-je mal compris ta démarche.
  Peux-tu m'éclairer, s'il te plaît ?

Il n’y a aucun raisonnement. J’ai juste recopié la commande pour le cas de la racine bloquée (donc par les inœuds) que j’ai légèrement modifiée pour afficher les résultats de /boot. Donc, oui, elle mériterait d’être revue pour rechercher des valeurs en octets. Ceci dit, comme la taille des noyaux peut varier (j’en veux pour preuve que dans ton expérience tu as eu un cas où trois noyaux ont réussi à cohabiter), difficile de toute façon de trouver une valeur. Et comme la commande passe en l’état, je pense que ça restera ainsi car elle permet de débloquer une situation bloquée, ce qui est somme toute le seul but de ce fil. wink


Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne

#39 Le 25/02/2016, à 07:36

moko138

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Merci  smile


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#40 Le 18/03/2016, à 08:36

moko138

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

nany,
je viens de voir dans kernel, § "Méthode permettant de conserver deux noyaux" ce script pour automatiser kclean -k à chaque mise à jour

echo 'DPkg::Post-Invoke {"echo Suppression anciens kernels;kclean -k -f ";}'|sudo tee -a /etc/apt/apt.conf.d/98removekernel

J'en rêvais pour les utilisateurs lambda. Mais
Que se passe-t-il si deux noyaux bugués sortent consécutivement ?

Ce n'est pas une vue de l'esprit : ça s'est produit en février 2013, avec les noyaux 3.2.0-39 et 3.2.0-38.


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#41 Le 18/03/2016, à 08:40

nam1962

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Et ce fil que tu connais bien avec les 4.2.0-23 - 4.2.0-24 - 4.2.0-25 ! https://forum.ubuntu-fr.org/viewtopic.p … #p21478696


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#42 Le 18/03/2016, à 09:04

moko138

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

nam1962 a écrit :

Et ce fil que tu connais bien avec les 4.2.0-23 - 4.2.0-24 - 4.2.0-25 ! https://forum.ubuntu-fr.org/viewtopic.p … #p21478696

Oui mais cet utilisateur avait activé les "proposed".
Or ce qui m'intéresse c'est l'automatisation de la maintenance

pour les utilisateurs lambda

auxquels jamais je ne conseillerais cette option casse-cou.

Dernière modification par moko138 (Le 18/03/2016, à 09:06)


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#43 Le 18/03/2016, à 17:09

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

moko138 a écrit :

nany,
je viens de voir dans kernel, § "Méthode permettant de conserver deux noyaux" ce script pour automatiser kclean -k à chaque mise à jour

echo 'DPkg::Post-Invoke {"echo Suppression anciens kernels;kclean -k -f ";}'|sudo tee -a /etc/apt/apt.conf.d/98removekernel

Eh bien je pense que c’est une fausse bonne idée.
D’une part parce que ça va lancer kclean après chaque mise à jour (après chaque invocation de dpkg, d’ailleurs) et pas seulement après chaque mise à jour du noyau.
D’autre part parce que, lorsque c’est vraiment utile c’est à dire après une mise à jour du noyau, la dernière version installée n’est pas la version utilisée ; kclean va donc détecter une version plus récente que la version utilisée mais continuera quand même puisqu’il est exécuté avec l’option -f ; l’option -k va conserver l’avant dernière version (et là je viens de découvrir un bug car ça devrait en fait être la version la plus récente parmi les versions inutilisées) ainsi que la version utilisée (a priori l’avant dernière donc la même) ; conclusion, la version du noyau sera figée.
Ce que je viens de dire reste à confirmer par des tests mais je ne crois pas me tromper.

J'en rêvais pour les utilisateurs lambda. Mais
Que se passe-t-il si deux noyaux bugués sortent consécutivement ?

Ce n'est pas une vue de l'esprit : ça s'est produit en février 2013, avec les noyaux 3.2.0-39 et 3.2.0-38.

kclean conserve de toute façon la version en cours d’utilisation qui, puisqu’elle est utilisée, n’est a priori pas buguée.


Bref, kclean est un bon outil mais il reste bugué et doit être exécuté sur la dernière version du noyau pour qu’il fasse un job correct.

Du coup j’ai fait une mise à jour pour une automatisation sans utilisation de kclean : #7.

Dernière modification par nany (Le 18/03/2016, à 17:11)


Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne

#44 Le 18/03/2016, à 18:15

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

nany a écrit :

Ce que je viens de dire reste à confirmer par des tests mais je ne crois pas me tromper.

Tests effectués.

nany@stupidcomputer:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)"
ii  linux-generic                                 4.2.0.34.37                                amd64        Complete Generic Linux kernel and headers
ii  linux-headers-4.2.0-27                        4.2.0-27.32                                all          Header files related to Linux kernel version 4.2.0
ii  linux-headers-4.2.0-27-generic                4.2.0-27.32                                amd64        Linux kernel headers for version 4.2.0 on 64 bit x86 SMP
ii  linux-headers-4.2.0-30                        4.2.0-30.36                                all          Header files related to Linux kernel version 4.2.0
ii  linux-headers-4.2.0-30-generic                4.2.0-30.36                                amd64        Linux kernel headers for version 4.2.0 on 64 bit x86 SMP
ii  linux-headers-4.2.0-34                        4.2.0-34.39                                all          Header files related to Linux kernel version 4.2.0
ii  linux-headers-4.2.0-34-generic                4.2.0-34.39                                amd64        Linux kernel headers for version 4.2.0 on 64 bit x86 SMP
ii  linux-headers-generic                         4.2.0.34.37                                amd64        Generic Linux kernel headers
ii  linux-image-4.2.0-27-generic                  4.2.0-27.32                                amd64        Linux kernel image for version 4.2.0 on 64 bit x86 SMP
ii  linux-image-4.2.0-30-generic                  4.2.0-30.36                                amd64        Linux kernel image for version 4.2.0 on 64 bit x86 SMP
ii  linux-image-4.2.0-34-generic                  4.2.0-34.39                                amd64        Linux kernel image for version 4.2.0 on 64 bit x86 SMP
ii  linux-image-extra-4.2.0-27-generic            4.2.0-27.32                                amd64        Linux kernel extra modules for version 4.2.0 on 64 bit x86 SMP
ii  linux-image-extra-4.2.0-30-generic            4.2.0-30.36                                amd64        Linux kernel extra modules for version 4.2.0 on 64 bit x86 SMP
ii  linux-image-extra-4.2.0-34-generic            4.2.0-34.39                                amd64        Linux kernel extra modules for version 4.2.0 on 64 bit x86 SMP
ii  linux-image-generic                           4.2.0.34.37                                amd64        Generic Linux kernel image
ii  linux-tools-4.2.0-27                          4.2.0-27.32                                amd64        Linux kernel version specific tools for version 4.2.0-27
ii  linux-tools-4.2.0-27-generic                  4.2.0-27.32                                amd64        Linux kernel version specific tools for version 4.2.0-27
ii  linux-tools-4.2.0-30                          4.2.0-30.36                                amd64        Linux kernel version specific tools for version 4.2.0-30
ii  linux-tools-4.2.0-30-generic                  4.2.0-30.36                                amd64        Linux kernel version specific tools for version 4.2.0-30
ii  linux-tools-4.2.0-34                          4.2.0-34.39                                amd64        Linux kernel version specific tools for version 4.2.0-34
ii  linux-tools-4.2.0-34-generic                  4.2.0-34.39                                amd64        Linux kernel version specific tools for version 4.2.0-34
ii  linux-tools-common                            4.2.0-34.39                                all          Linux kernel version specific tools for version 4.2.0
ii  linux-tools-virtual                           4.2.0.34.37                                amd64        This package will always depend on the latest minimal generic kernel tools.
nany@stupidcomputer:~$ uname -r
4.2.0-30-generic
nany@stupidcomputer:~$ sudo apt-get purge linux-headers-4.2.0-34 linux-image-4.2.0-34 linux-tools-4.2.0-34 linux-tools-virtual linux-tools-common linux-image-generic linux-headers-generic linux-generic
Mot de passe [sudo] pour nany : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de linux-image-4.2.0-34-generic pour l'expression rationnelle « linux-image-4.2.0-34 »
Note : sélection de linux-image-4.2.0-34-lowlatency pour l'expression rationnelle « linux-image-4.2.0-34 »
Le paquet « linux-image-4.2.0-34-lowlatency » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-headers-4.2.0-27-generic linux-image-4.2.0-27-generic linux-image-extra-4.2.0-27-generic thermald
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-generic* linux-headers-4.2.0-34* linux-headers-4.2.0-34-generic* linux-headers-generic* linux-image-4.2.0-34-generic* linux-image-extra-4.2.0-34-generic*
  linux-image-generic* linux-tools-4.2.0-27* linux-tools-4.2.0-27-generic* linux-tools-4.2.0-30* linux-tools-4.2.0-30-generic* linux-tools-4.2.0-34* linux-tools-4.2.0-34-generic*
  linux-tools-common* linux-tools-virtual*
0 mis à jour, 0 nouvellement installés, 15 à enlever et 14 non mis à jour.
Après cette opération, 294 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 269470 fichiers et répertoires déjà installés.)
Suppression de linux-generic (4.2.0.34.37) ...
Suppression de linux-headers-generic (4.2.0.34.37) ...
Suppression de linux-headers-4.2.0-34-generic (4.2.0-34.39) ...
Suppression de linux-headers-4.2.0-34 (4.2.0-34.39) ...
Suppression de linux-image-generic (4.2.0.34.37) ...
Suppression de linux-image-extra-4.2.0-34-generic (4.2.0-34.39) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
update-initramfs: Generating /boot/initrd.img-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
Création du fichier de configuration GRUB…
Attention : Définir GRUB_TIMEOUT à une valeur non nulle si GRUB_HIDDEN_TIMEOUT est définie n’est plus possible.
Image Linux trouvée : /boot/vmlinuz-4.2.0-34-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-34-generic
Image Linux trouvée : /boot/vmlinuz-4.2.0-30-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-30-generic
Image Linux trouvée : /boot/vmlinuz-4.2.0-27-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-27-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Navigatrix (14.04) trouvé sur /dev/sda6
Ubuntu 14.04.3 LTS (14.04) trouvé sur /dev/sda7
fait
Purge des fichiers de configuration de linux-image-extra-4.2.0-34-generic (4.2.0-34.39) ...
Suppression de linux-image-4.2.0-34-generic (4.2.0-34.39) ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/dkms 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
dkms: removing: virtualbox 5.0.14 (4.2.0-34-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 5.0.14
Kernel:  4.2.0-34-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.2.0-34-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.2.0-34-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.2.0-34-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.2.0-34-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
update-initramfs: Deleting /boot/initrd.img-4.2.0-34-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
Création du fichier de configuration GRUB…
Attention : Définir GRUB_TIMEOUT à une valeur non nulle si GRUB_HIDDEN_TIMEOUT est définie n’est plus possible.
Image Linux trouvée : /boot/vmlinuz-4.2.0-30-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-30-generic
Image Linux trouvée : /boot/vmlinuz-4.2.0-27-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-27-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Navigatrix (14.04) trouvé sur /dev/sda6
Ubuntu 14.04.3 LTS (14.04) trouvé sur /dev/sda7
fait
The link /vmlinuz is a damaged link
Removing symbolic link vmlinuz 
 you may need to re-run your boot loader[grub]
The link /initrd.img is a damaged link
Removing symbolic link initrd.img 
 you may need to re-run your boot loader[grub]
Purge des fichiers de configuration de linux-image-4.2.0-34-generic (4.2.0-34.39) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
Suppression de linux-tools-4.2.0-27-generic (4.2.0-27.32) ...
Suppression de linux-tools-4.2.0-27 (4.2.0-27.32) ...
Suppression de linux-tools-4.2.0-30-generic (4.2.0-30.36) ...
Suppression de linux-tools-4.2.0-30 (4.2.0-30.36) ...
Suppression de linux-tools-virtual (4.2.0.34.37) ...
Suppression de linux-tools-4.2.0-34-generic (4.2.0-34.39) ...
Suppression de linux-tools-4.2.0-34 (4.2.0-34.39) ...
Suppression de linux-tools-common (4.2.0-34.39) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.4-1) ...
nany@stupidcomputer:~$ echo 'DPkg::Post-Invoke {"echo Suppression anciens kernels;kclean -k -f ";}'|sudo tee -a /etc/apt/apt.conf.d/98removekernel
DPkg::Post-Invoke {"echo Suppression anciens kernels;kclean -k -f ";}
nany@stupidcomputer:~$ sudo apt-get install linux-tools-virtual linux-tools-common linux-generic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-headers-4.2.0-27-generic linux-image-4.2.0-27-generic linux-image-extra-4.2.0-27-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  linux-headers-4.2.0-34 linux-headers-4.2.0-34-generic linux-headers-generic linux-image-4.2.0-34-generic linux-image-extra-4.2.0-34-generic linux-image-generic
  linux-tools-4.2.0-34 linux-tools-4.2.0-34-generic
Paquets suggérés :
  fdutils linux-doc-4.2.0 linux-source-4.2.0 linux-tools
Les NOUVEAUX paquets suivants seront installés :
  linux-generic linux-headers-4.2.0-34 linux-headers-4.2.0-34-generic linux-headers-generic linux-image-4.2.0-34-generic linux-image-extra-4.2.0-34-generic linux-image-generic
  linux-tools-4.2.0-34 linux-tools-4.2.0-34-generic linux-tools-common linux-tools-virtual
0 mis à jour, 11 nouvellement installés, 0 à enlever et 14 non mis à jour.
Il est nécessaire de prendre 0 o/67,1 Mo dans les archives.
Après cette opération, 290 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
Sélection du paquet linux-image-4.2.0-34-generic précédemment désélectionné.
(Lecture de la base de données... 238124 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-image-4.2.0-34-generic_4.2.0-34.39_amd64.deb ...
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/intel-microcode 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
Done.
Dépaquetage de linux-image-4.2.0-34-generic (4.2.0-34.39) ...
Sélection du paquet linux-image-extra-4.2.0-34-generic précédemment désélectionné.
Préparation du dépaquetage de .../linux-image-extra-4.2.0-34-generic_4.2.0-34.39_amd64.deb ...
Dépaquetage de linux-image-extra-4.2.0-34-generic (4.2.0-34.39) ...
Sélection du paquet linux-image-generic précédemment désélectionné.
Préparation du dépaquetage de .../linux-image-generic_4.2.0.34.37_amd64.deb ...
Dépaquetage de linux-image-generic (4.2.0.34.37) ...
Sélection du paquet linux-headers-4.2.0-34 précédemment désélectionné.
Préparation du dépaquetage de .../linux-headers-4.2.0-34_4.2.0-34.39_all.deb ...
Dépaquetage de linux-headers-4.2.0-34 (4.2.0-34.39) ...
Sélection du paquet linux-headers-4.2.0-34-generic précédemment désélectionné.
Préparation du dépaquetage de .../linux-headers-4.2.0-34-generic_4.2.0-34.39_amd64.deb ...
Dépaquetage de linux-headers-4.2.0-34-generic (4.2.0-34.39) ...
Sélection du paquet linux-headers-generic précédemment désélectionné.
Préparation du dépaquetage de .../linux-headers-generic_4.2.0.34.37_amd64.deb ...
Dépaquetage de linux-headers-generic (4.2.0.34.37) ...
Sélection du paquet linux-generic précédemment désélectionné.
Préparation du dépaquetage de .../linux-generic_4.2.0.34.37_amd64.deb ...
Dépaquetage de linux-generic (4.2.0.34.37) ...
Sélection du paquet linux-tools-common précédemment désélectionné.
Préparation du dépaquetage de .../linux-tools-common_4.2.0-34.39_all.deb ...
Dépaquetage de linux-tools-common (4.2.0-34.39) ...
Sélection du paquet linux-tools-4.2.0-34 précédemment désélectionné.
Préparation du dépaquetage de .../linux-tools-4.2.0-34_4.2.0-34.39_amd64.deb ...
Dépaquetage de linux-tools-4.2.0-34 (4.2.0-34.39) ...
Sélection du paquet linux-tools-4.2.0-34-generic précédemment désélectionné.
Préparation du dépaquetage de .../linux-tools-4.2.0-34-generic_4.2.0-34.39_amd64.deb ...
Dépaquetage de linux-tools-4.2.0-34-generic (4.2.0-34.39) ...
Sélection du paquet linux-tools-virtual précédemment désélectionné.
Préparation du dépaquetage de .../linux-tools-virtual_4.2.0.34.37_amd64.deb ...
Dépaquetage de linux-tools-virtual (4.2.0.34.37) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.4-1) ...
Paramétrage de linux-image-4.2.0-34-generic (4.2.0-34.39) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
update-initramfs: Generating /boot/initrd.img-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
Création du fichier de configuration GRUB…
Attention : Définir GRUB_TIMEOUT à une valeur non nulle si GRUB_HIDDEN_TIMEOUT est définie n’est plus possible.
Image Linux trouvée : /boot/vmlinuz-4.2.0-34-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-34-generic
Image Linux trouvée : /boot/vmlinuz-4.2.0-30-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-30-generic
Image Linux trouvée : /boot/vmlinuz-4.2.0-27-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-27-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Navigatrix (14.04) trouvé sur /dev/sda6
Ubuntu 14.04.3 LTS (14.04) trouvé sur /dev/sda7
fait
Paramétrage de linux-image-extra-4.2.0-34-generic (4.2.0-34.39) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
update-initramfs: Generating /boot/initrd.img-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
Création du fichier de configuration GRUB…
Attention : Définir GRUB_TIMEOUT à une valeur non nulle si GRUB_HIDDEN_TIMEOUT est définie n’est plus possible.
Image Linux trouvée : /boot/vmlinuz-4.2.0-34-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-34-generic
Image Linux trouvée : /boot/vmlinuz-4.2.0-30-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-30-generic
Image Linux trouvée : /boot/vmlinuz-4.2.0-27-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.2.0-27-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Navigatrix (14.04) trouvé sur /dev/sda6
Ubuntu 14.04.3 LTS (14.04) trouvé sur /dev/sda7
fait
Paramétrage de linux-image-generic (4.2.0.34.37) ...
Paramétrage de linux-headers-4.2.0-34 (4.2.0-34.39) ...
Paramétrage de linux-headers-4.2.0-34-generic (4.2.0-34.39) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.2.0-34-generic /boot/vmlinuz-4.2.0-34-generic
Paramétrage de linux-headers-generic (4.2.0.34.37) ...
Paramétrage de linux-generic (4.2.0.34.37) ...
Paramétrage de linux-tools-common (4.2.0-34.39) ...
Paramétrage de linux-tools-4.2.0-34 (4.2.0-34.39) ...
Paramétrage de linux-tools-4.2.0-34-generic (4.2.0-34.39) ...
Paramétrage de linux-tools-virtual (4.2.0.34.37) ...
Suppression anciens kernels
 
Noyau actuellement en cours d'utilisation : 4.2.0-30
Par defaut, seul ce noyau est conserve.
 
ATTENTION : Presence de noyau(x) plus recent(s) sur le systeme.
Ce script va neanmoins poursuivre (utilisation du -f)
Ce script va tenter de trouver la version precedente du noyau pour la conserver.
 
La version precedemment installee (a conserver) est la version : 4.2.0-30
Les paquets suivants vont etre supprimes :
 
    linux-image-4.2.0-27-generic
    linux-image-4.2.0-34-generic
    linux-image-extra-4.2.0-27-generic
    linux-image-extra-4.2.0-34-generic
    linux-headers-4.2.0-27
    linux-headers-4.2.0-27-generic
    linux-headers-4.2.0-34
    linux-headers-4.2.0-34-generic
    linux-tools-4.2.0-34
    linux-tools-4.2.0-34-generic
 
Cela devrait liberer environ 549 MiB d'espace disque
 
 
 Suppression en cours :
 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-headers-4.2.0-27-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-image-4.2.0-27-generic* linux-image-extra-4.2.0-27-generic*
0 mis à jour, 0 nouvellement installés, 2 à enlever et 14 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-headers-4.2.0-27-generic linux-image-4.2.0-27-generic linux-image-extra-4.2.0-27-generic thermald
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-generic* linux-image-4.2.0-34-generic* linux-image-extra-4.2.0-34-generic* linux-image-generic*
0 mis à jour, 0 nouvellement installés, 4 à enlever et 14 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-headers-4.2.0-27-generic linux-image-4.2.0-27-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-image-extra-4.2.0-27-generic*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 14 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-headers-4.2.0-27-generic linux-image-4.2.0-27-generic linux-image-extra-4.2.0-27-generic thermald
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-generic* linux-image-extra-4.2.0-34-generic* linux-image-generic*
0 mis à jour, 0 nouvellement installés, 3 à enlever et 14 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-image-4.2.0-27-generic linux-image-extra-4.2.0-27-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-headers-4.2.0-27* linux-headers-4.2.0-27-generic*
0 mis à jour, 0 nouvellement installés, 2 à enlever et 14 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-image-4.2.0-27-generic linux-image-extra-4.2.0-27-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-headers-4.2.0-27-generic*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 14 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-headers-4.2.0-27-generic linux-image-4.2.0-27-generic linux-image-extra-4.2.0-27-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-generic* linux-headers-4.2.0-34* linux-headers-4.2.0-34-generic* linux-headers-generic*
0 mis à jour, 0 nouvellement installés, 4 à enlever et 14 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-headers-4.2.0-27-generic linux-image-4.2.0-27-generic linux-image-extra-4.2.0-27-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-generic* linux-headers-4.2.0-34-generic* linux-headers-generic*
0 mis à jour, 0 nouvellement installés, 3 à enlever et 14 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-headers-4.2.0-27-generic linux-image-4.2.0-27-generic linux-image-extra-4.2.0-27-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-tools-4.2.0-34* linux-tools-4.2.0-34-generic* linux-tools-virtual*
0 mis à jour, 0 nouvellement installés, 3 à enlever et 14 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.2.0-27 linux-headers-4.2.0-27-generic linux-image-4.2.0-27-generic linux-image-extra-4.2.0-27-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-tools-4.2.0-34-generic* linux-tools-virtual*
0 mis à jour, 0 nouvellement installés, 2 à enlever et 14 non mis à jour.
E: Impossible d'obtenir le verrou /var/cache/apt/archives/lock - open (11: Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire /var/cache/apt/archives/
 
 -------------- Suppression effectuee ---------------
 
nany@stupidcomputer:~$

Bon ben, en fait, ça ne désinstalle rien puisque kclean fait appel à une nouvelle instance d’apt-get alors qu’il y a toujours le verrou. On peut tout de même se rendre compte que kclean met la dernière version dans sa liste de désinstallation.


Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne

#45 Le 20/03/2016, à 12:17

moko138

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Merci beaucoup nany !


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#46 Le 01/04/2016, à 08:43

draco31.fr

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Bonjour,

Je viens de voir une contribution à la page kernel de la doc qui renvoi ici.
Merci à Nany pour ce retour d'expérience.
Je ne pense pas que ce paragraphe ait été ajouté à la doc sans test préalable.
Est-ce que kclean n'a pas changé son fonctionnement ?

Dans tous les cas, lancer kclean à chaque lancement de apt-get ne me semble pas judicieux.
On va donc probablement supprimer le paragraphe comme tu le recommandes.

NB: n'hésitez pas à venir discuter de la doc sur la liste dédiée : wiki@ubuntu-fr.org

Hors ligne

#47 Le 01/04/2016, à 12:52

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

draco31.fr a écrit :

Je ne pense pas que ce paragraphe ait été ajouté à la doc sans test préalable.

Eh bien, s’il y a eu un test préalable, le protocole de test était probablement mauvais.
Mon test montre bien que ça ne fait rien à cause du verrou et que, sans ce problème de verrou, la dernière version du noyau fraîchement installée serait désinstallée.

Est-ce que kclean n'a pas changé son fonctionnement ?

Depuis la toute première version, je ne sais pas. Mais je dirais que le fonctionnement est le même depuis au moins la version 3.0.

En bref, pour que kclean fonctionne correctement après une mise à jour de noyau, il faut d’abord redémarrer sur la nouvelle version du noyau.


Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne

#48 Le 07/04/2016, à 19:09

moko138

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

En #7, nany, dans le cadre de l'automatisation, tu proposes

(...) /etc/cron.weekly/autoremove :

#!/bin/bash

apt-get autoremove --purge -y

exit 0

Mais chez moi (qui désinstalle toujours à la main) sudo apt-get autoremove me propose de désinstaller mon avant-dernier noyau, donc de n'en garder qu'un.


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#49 Le 07/04/2016, à 19:18

jplemoine

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

moko138 a écrit :

Mais chez moi (qui désinstalle toujours à la main) sudo apt-get autoremove me propose de désinstaller mon avant-dernier noyau, donc de n'en garder qu'un.

Si j'ai bien analysé la situation : il y a un bug dans

/etc/kernel/postinst.d/apt-auto-removal

.
Il ne fonctionne correctement que si tu tournes avec le nouveau noyau....
Donc, une fois que tu as redémarré le système, il  faut exécuter :

sudo /etc/kernel/postinst.d/apt-auto-removal $(uname -r)

.
Sauf qu'il faut encore redémarrer.
Il doit y avoir un moyen de faire mieux mais ce processus fonctionnant, je n'ai pas cherché plus.

Dernière modification par jplemoine (Le 07/04/2016, à 19:18)


Compte volontairement inactif
Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre) et de ALDI4 (Atelier Libre d'Informatique du 4ième)

Hors ligne

#50 Le 07/04/2016, à 21:21

nany

Re : Sens interdit, paquets cassés > 0, espace insuffisant… Que faire ?

Oui, c’est le bug #1440608.
J’avoue que cette histoire de double redémarrage me dépasse un peu car je n’ai jamais pu constater ce bug chez moi (il faut dire que je ne m’empresse pas de faire un autoremove dès que je vois passer une mise à jour de noyau).
Néanmoins je sais qu’il existe et j’en parle en #3 sans y faire référence (je vais donc éditer pour ajouter cette référence) :

À ce stade le processus d’automatisation de marquage des deux dernières versions de noyau peut ne pas avoir été effectué.

Puis les quelques lignes qui suivent pour y remédier.

J’ajoute que le script autoremove n’est pas le seul que j’ai mis dans /etc/cron.weekly. Il y a aussi le script apt-mark-auto-kernels qui est exécuté avant (le choix des noms n’est pas anodin) et qui est justement là pour prévenir ce bug ainsi que le bug #1175637.

P.S. ; un test qui peut être effectué avec au moins trois versions de noyau :

sudo apt-get -s install

pour voir la liste des paquets suggérés en autoremove ; si cette liste est incorrecte,

sudo /etc/kernel/postinst.d/apt-auto-removal $(dpkg -l | awk '/linux-image-[0-9]/{k=$2}END{sub(/linux-image-/,"",k);print k}')

puis à nouveau

sudo apt-get -s install

Super ou ordinaire, nany, une essence qui va vous embaumer.
Comment bien utiliser les balises BBcode - My two cents
Libraries are not book-stores. − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
Pas de gedit ? Essayez xdg-open.

Hors ligne