Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#76 Le 17/05/2016, à 22:40

SpoKen

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Salut Baltus,

J'ai testé ta méthode en faisant un petit

 sudo apt-get install compton-conf

Après quoi l'option "Windows Effects" apparaissait bien !

Par la suite j'ai copié ta configuration à l'emplacement donné.

Mais voilà qu'une fois

compton

lancé en ligne de commande mon écran est devenu tout fade, et bien évidemment la vsync n'est toujours pas au rendez-vous !

Hors ligne

#77 Le 18/05/2016, à 07:07

Baltus

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

SpoKen a écrit :

lancé en ligne de commande mon écran est devenu tout fade, et bien évidemment la vsync n'est toujours pas au rendez-vous !

As-tu essayé les 3 options possibles ?

--vsync-opengl
--vsync-opengl-swc
--vsync-aggressive

Hors ligne

#78 Le 19/05/2016, à 19:00

SpoKen

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Rien n'y change ... de très légères améliorations mais cette vidéo : https://www.youtube.com/watch?v=22ftfoCSPQI pique toujours autant les yeux !

Hors ligne

#79 Le 19/05/2016, à 20:55

Baltus

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Je teste cette solution sans compton :

Another way to fix tearing and vsync issues using the Nvidia driver

Comme je n'ai pas de fichier xorg.conf, je lance cette commande au démarrage :

nvidia-settings --assign CurrentMetaMode="DVI-I-1: nvidia-auto-select { ForceCompositionPipeline = On }"

J'active également le compositeur.

C'est pas trop mal sur mon PC.

Hors ligne

#80 Le 19/05/2016, à 22:55

Pierre_K

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Baltus a écrit :

Je teste cette solution sans compton :

Another way to fix tearing and vsync issues using the Nvidia driver

Comme je n'ai pas de fichier xorg.conf, je lance cette commande au démarrage :

nvidia-settings --assign CurrentMetaMode="DVI-I-1: nvidia-auto-select { ForceCompositionPipeline = On }"

J'active également le compositeur.

C'est pas trop mal sur mon PC.

Est-ce que tu as encore du tearing ? Personnellement je n’avais plus de tearing avec compton, mais après l'installation de pilote graphique proprio toutes mes fenêtres sont devenus transparentes... J'ai dû désinstaller compton après avoir essayé de réinstaller le pilote libre et après avoir essayer également un pilote plus ancien.

[edit]La solution de Baltus fonctionne mais semble se désactiver au lancement d'une application qui fait appel au 3D

Dernière modification par Pierre_K (Le 19/05/2016, à 23:41)


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne

#81 Le 20/05/2016, à 06:52

Baltus

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Non, plus de tearing avec cette option mais je n'utilise pas d'application 3D.

C'est quand même moins fluide qu'avec compton, notamment pour le défilement vertical des pages de texte ou sur le web.

Hors ligne

#82 Le 20/05/2016, à 11:56

SpoKen

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

En lançant cette commande

xrandr

voici son résultat :

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected 1920x1080+0+0 381mm x 214mm
   1920x1080     60.04*+  59.93  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   800x512       60.17  
   700x525       59.98  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
VGA-1 disconnected
DP-1 disconnected
HDMI-1 disconnected
HDMI-2 disconnected

J'ai donc implémenté dans mon fichier xorg.conf cette nouvelle ligne d'option dans la section "Screen"

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
    Option "TearFree"	"true"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
    Option "metamodes" "eDP-1: nvidia-auto-select { ForceCompositionPipeline = On }"
EndSection

Mais encore une fois cela ne corrige que très peu le tearing chez moi …

Hors ligne

#83 Le 08/03/2017, à 19:07

lepetit

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

bonjour, j'up un peu le topok
je suis en train de configurer un pc avec un vieux proc + une geforce 710 sous pilote libre (nouveau donc)
le but étant donc de ne plus avoir de tearing, un peu de transparence et les meilleurs perfs possible en 2d, a noter que j'ai viré tout ce qui était fading et ombres (shadow) qui flingue les perfs en 2d.

voila mon compton.conf

backend = "glx"; 
paint-on-overlay = true; 
glx-no-stencil = true;
glx-no-rebind-pixmap = true;
vsync = "opengl-mswc";
sw-opti = true;
refresh-rate = 0;
menu-opacity = 1.0;
inactive-opacity = 0.75;
active-opacity = 1.0;
frame-opacity = 1.0;
inactive-opacity-override = false;
inactive-dim = 1.38777878078145e-17;
mark-wmwin-focused = true;
mark-ovredir-focused = true;
detect-rounded-corners = true;
detect-client-opacity = true; #Fixes opacity in some apps, such as xfce4-notifyd
focus-exclude = [ "class_g = 'Cairo-clock'" ];
detect-transient = true;
detect-client-leader = true;
unredir-if-possible = true;
use-ewmh-active-win = true;
no-dnd-shadow = true;
no-dock-shadow = true;
clear-shadow = true;
#alpha-step = 0.06;
wintypes : 
{
  tooltip : 
  {
    fade = false;
    shadow = false;
    opacity = 0.85;
    focus = true;
  };
};

si vous avez des conseils, n'hésité pas.

Dernière modification par lepetit (Le 08/03/2017, à 19:23)

Hors ligne

#84 Le 09/04/2017, à 09:33

Baltus

Re : [Tuto] Régler le problème de screen tearing sous Xubuntu avec Compton

Bonjour,

Avec les pilotes nVIDIA version 375.39, la commande suivante seule ne fonctionne plus :

nvidia-settings --assign CurrentMetaMode="DVI-I-1: nvidia-auto-select { ForceCompositionPipeline = On }"

Il faut en plus créer un fichier avec cette commande :

sudo gedit /etc/profile.d/tearing.sh

et d'y ajouter les lignes suivantes :

export __GL_YIELD="USLEEP"
export __GL_THREADED_OPTIMIZATIONS=1

Puis de rendre le fichier exécutable ainsi :

sudo chmod +x /etc/profile.d/tearing.sh

Il faut ensuite créer une nouvelle entrée au démarrage pour exécuter la commande suivante :

/etc/profile.d/tearing.sh

Pour appliquer ces changements, il est nécessaire de redémarrer l'ordinateur.

Cette technique fonctionne sur ma machine avec Xubuntu 16.04, voici la source.

Hors ligne